# Can't access rancher/server UI

**URL:** <https://forums.suse.com/t/cant-access-rancher-server-ui/7807>\
**Category:** Rancher 1.x\
**Created:** [November 16, 2017, 9:23am UTC](https://forums.suse.com/t/cant-access-rancher-server-ui/7807 "2017-11-16T09:23:12Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![marxper](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@marxper](https://forums.suse.com/u/marxper)\
**Post date:** [November 16, 2017, 9:23am UTC](https://forums.suse.com/t/cant-access-rancher-server-ui/7807/1 "2017-11-16T09:23:12Z")

</div>

Hello every one,  
Using ubuntu 16.04-server i execute this commande:  
docker run -d --restart=always -p 8080:8080 rancher/server

Now rancher server is ruuning as a docker container on port **8080** ,

I want to access to rancher server by putting **myhostname:8080** using my local navigator (local machine(windows))

I also execute those cmds:  
iptables -A INPUT -p tcp --dport 8080 -j ACCEPT  
iptables -A INPUT -p udp --dport 8080 -j ACCEPT

But now i can’t access to rancher/server UI

dicker logs \<my\_container\>  
I got those types of errors:

- level=info msg=“Downloading key from http:// localhost:8081/v1/scripts/api.crt”
- level=fatal msg=“Error getting config.” error=“Invalid key content”
- level=fatal msg=“Unable to create event router” error=“Get http:/ /localhost:8080/v2-beta: dial tcp 127.0.0.1:8080: getsockopt: connection refused”
- WARN [:] [] [] [] [main] [o.eclipse.jetty.webapp.WebAppContext] Failed startup of context o.e.j.w.WebAppContext@1bce4f0a{/,file:/usr/share/cattle/7ec510bfffb3e6d6cd2f7179e2082423/,STARTING}{file:/usr/share/cattle/7ec510bfffb3e6d6cd2f7179e2082423/} io.cattle.platform.lock.exception.FailedToAcquireLockException: Failed to acquire lock [DATA.CHANGE.host.api.key]
- level=fatal msg=“Unable to create event router” error="Get [http://localhost:8080/v2-beta:](http://localhost:8080/v2-beta:) dial tcp 127.0.0.1:8080: getsockopt: connection refused"  
STARTUP FAILED [830573] ms
- level=fatal msg=“Error getting config.” error=“Invalid key content”

What can i do for all those errors , it’s weird because i’m just running this container:  
docker ps :  
5394a37e021b rancher/server:stable “/usr/bin/entry /u…” About an hour ago Up 10 minutes 3306/tcp, 0.0.0.0:8080-\>8080/tcp focused\_gates

---

<div class="post-metadata">

**Author:** ![superseb](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/superseb/32/2424_2.png) [@superseb](https://forums.suse.com/u/superseb)\
**Post date:** [November 21, 2017, 3:24pm UTC](https://forums.suse.com/t/cant-access-rancher-server-ui/7807/2 "2017-11-21T15:24:37Z")

</div>

Answer is in [https://github.com/rancher/rancher/issues/10347](https://github.com/rancher/rancher/issues/10347)

---

<div class="post-metadata">

**Author:** ![marxper](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@marxper](https://forums.suse.com/u/marxper)\
**Post date:** [November 22, 2017, 5:14pm UTC](https://forums.suse.com/t/cant-access-rancher-server-ui/7807/3 "2017-11-22T17:14:15Z")

</div>

Thank you for your response, the pb is solved.

---

<div class="post-metadata">

**Author:** ![ydarb](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/ydarb/32/4949_2.png) [@ydarb](https://forums.suse.com/u/ydarb)\
**Post date:** [March 19, 2019, 9:30am UTC](https://forums.suse.com/t/cant-access-rancher-server-ui/7807/4 "2019-03-19T09:30:28Z")

</div>

In case anyone else comes across this. I fixed it by

> docker stop rancher-agent  
> docker start rancher-server  
> docker start rancher-agent
