# Can't start DomU

**URL:** <https://forums.suse.com/t/cant-start-domu/23431>\
**Category:** SLES Virtualization\
**Created:** [December 20, 2012, 8:57am UTC](https://forums.suse.com/t/cant-start-domu/23431 "2012-12-20T08:57:09Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![epretorious](https://avatars.discourse-cdn.com/v4/letter/e/90ced4/32.png) [@epretorious](https://forums.suse.com/u/epretorious)\
**Post date:** [December 20, 2012, 8:57am UTC](https://forums.suse.com/t/cant-start-domu/23431/1 "2012-12-20T08:57:09Z")

</div>

I’m not able to start, destroy, or delete the DomU “test2”.

[CODE]xen2:~ # xm list  
Name ID Mem VCPUs State Time(s)  
Domain-0 0 502 2 r----- 226.8  
test2 768 1 19.3  
test3 1 768 1 -b---- 1.6

xen2:~ # xm start test2  
Error: Domain is already running  
Usage: xm start

Start a Xend managed domain  
-p, --paused Do not unpause domain after starting it  
-c, --console\_autoconnect Connect to the console after the domain  
is created  
–vncviewer Connect to display via VNC after the  
domain is created  
–vncviewer-autopass Pass VNC password to viewer via stdin and  
-autopass

xen2:~ # xm shutdown test2  
Error:  
Usage: xm shutdown [-waRH]

Shutdown a domain.

xen2:~ # xm destroy test2

xen2:~ # xm start test2  
Error: Domain is already running  
Usage: xm start

Start a Xend managed domain  
-p, --paused Do not unpause domain after starting it  
-c, --console\_autoconnect Connect to the console after the domain  
is created  
–vncviewer Connect to display via VNC after the  
domain is created  
–vncviewer-autopass Pass VNC password to viewer via stdin and  
-autopass

xen2:~ # xm delete test2  
Error: Domain is not halted.  
Usage: xm delete

Remove a domain from Xend domain management.

xen2:~ # ps ax | grep test2  
6800 pts/0 S+ 0:00 grep test2

xen2:~ # ps ax | grep 2a694c2a-67ae-8aba-039d-d57a2d1e5eec  
6811 pts/0 S+ 0:00 grep 2a694c2a-67ae-8aba-039d-d57a2d1e5eec[/CODE]  
What do I need to do to un-wedge this DomU? 😕

Eric Pretorious  
Truckee, CA

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [December 20, 2012, 12:11pm UTC](https://forums.suse.com/t/cant-start-domu/23431/2 "2012-12-20T12:11:56Z")

</div>

Hi Eric,

> What do I need to do to un-wedge this DomU? 😕

your servers have been selected to be the first ones going down for Maja calendar reset. Nothing you can do about it but wait.

…

OK, back to a more serious answer: You have some truly strange problems going on at your site. Is there any background story - power hits, servers/disk arrays/… crashing or anything else that may have brought your servers to such a state?

First place to check for more descriptive error messages would be /var/log/xen/xend.log, and maybe the DomU-specific log file in the same directory, if xend got that far. Any other problems or annoyances on that server, that may lead to a common source? Any file systems at 100%, or mounted r/o because of file system trouble? Anything in syslog, “dmesg”?

Regards,  
Jens

---

<div class="post-metadata">

**Author:** ![epretorious](https://avatars.discourse-cdn.com/v4/letter/e/90ced4/32.png) [@epretorious](https://forums.suse.com/u/epretorious)\
**Post date:** [December 23, 2012, 7:20am UTC](https://forums.suse.com/t/cant-start-domu/23431/3 "2012-12-23T07:20:16Z")

</div>

> [@jmozdzen;10807](#):
>
> You have some truly strange problems going on at your site. Is there any background story - power hits, servers/disk arrays/… crashing or anything else that may have brought your servers to such a state?

LOL, Jens: So far all of the problems seem to be caused by my sloppy typing. :rolleyes:

> [@jmozdzen;10807](#):
>
> First place to check for more descriptive error messages would be /var/log/xen/xend.log, and maybe the DomU-specific log file in the same directory, if xend got that far. Any other problems or annoyances on that server, that may lead to a common source? Any file systems at 100%, or mounted r/o because of file system trouble? Anything in syslog, “dmesg”?

Nope:  
[LIST]  
[\*]The only thing related to the DomU in /var/log/xen/xend.log or /var/log/xen/xen-debug.log came after issuing the command `xm reboot test4`:

`[2012-12-22 20:49:10 4584] DEBUG (XendDomainInfo:523) XendDomainInfo.shutdown(reboot)
[2012-12-22 20:49:10 4584] ERROR (xmlrpclib2:181) Internal error handling xend.domain.shutdown
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/xen/util/xmlrpclib2.py", line 134, in _marshaled_dispatch
    response = self._dispatch(method, params)
  File "/usr/lib64/python2.6/SimpleXMLRPCServer.py", line 418, in _dispatch
    return func(*params)
  File "<string>", line 1, in <lambda>
  File "/usr/lib64/python2.6/site-packages/xen/xend/server/XMLRPCServer.py", line 56, in dispatch
    return getattr(info, fn)(*args)
  File "/usr/lib64/python2.6/site-packages/xen/xend/XendDomainInfo.py", line 532, in shutdown
    self.storeDom("control/shutdown", reason)
  File "/usr/lib64/python2.6/site-packages/xen/xend/XendDomainInfo.py", line 1760, in storeDom
    return xstransact.Store(self.dompath, *args)
  File "/usr/lib64/python2.6/site-packages/xen/xend/xenstore/xstransact.py", line 347, in Store
    complete(path, lambda t: t.store(*args))
  File "/usr/lib64/python2.6/site-packages/xen/xend/xenstore/xstransact.py", line 361, in complete
    t = xstransact(path)
  File "/usr/lib64/python2.6/site-packages/xen/xend/xenstore/xstransact.py", line 27, in __init__
    assert path is not None
AssertionError`  
[\*]The DomU-specific log file /var/log/xen/qemu-dm-test4.log hasn’t been changed in a week but contains this bit:

[CODE]xen1:~ # cat /var/log/xen/qemu-dm-test4.log  
domid: 25  
Warning: vlan 0 is not connected to host network  
char device redirected to /dev/pts/1  
xs\_read(): target get error. /local/domain/25/target.  
xs\_read(): vncpasswd get error. /vm/080fcd1b-40a6-9b8f-ad38-f5d4684c2ed4/vncpasswd.  
char device redirected to /dev/pts/2

xen1:~ # xm list -l test4 | grep vnc  
(vncunused 1)  
(vnc 1)[/CODE]  
[\*]Neither dmesg nor /var/log/messages contain anything related to the problem (and the other DomU’s on the host are working as expected).[/LIST]

How can I nuke this DomU from the xend?

Eric Pretorious  
Truckee, CA

---

<div class="post-metadata">

**Author:** ![epretorious](https://avatars.discourse-cdn.com/v4/letter/e/90ced4/32.png) [@epretorious](https://forums.suse.com/u/epretorious)\
**Post date:** [December 25, 2012, 10:51am UTC](https://forums.suse.com/t/cant-start-domu/23431/4 "2012-12-25T10:51:07Z")

</div>

> [@epretorious;10846](#):
>
> How can I nuke this DomU from the xend?

I noticed that the malfunctioning DomU appears in the output of `xm list` but not in the output of xenstore-ls:

`xen2:~ # xenstore-ls | grep name
   name = "Domain-0"
   name = "Pool-0"
  pool_name = "Pool-0"
  name = "Domain-0"
xen2:~ # xm list -l | grep '(name'
    (name Domain-0)
    (name test2)`  
How can I reconcile this discrepancy? i.e., How can I nuke test2 from xenstore (or wherever xm list is pulling its information)?

Eric Pretorious  
Truckee, CA
