#  certificate signed by unknown authority

**URL:** <https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906>\
**Category:** SUSE Rancher Prime\
**Created:** [July 26, 2019, 2:27pm UTC](https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906 "2019-07-26T14:27:06Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![kamlesh](https://avatars.discourse-cdn.com/v4/letter/k/aeb1de/32.png) [@kamlesh](https://forums.suse.com/u/kamlesh)\
**Post date:** [July 26, 2019, 2:27pm UTC](https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906/1 "2019-07-26T14:27:06Z")

</div>

Hi. I am using latest version of Rancher and i am getting this error ("2019-07-26 10:51:25.518141 I | embed: rejected connection from “10.0.8.61:60174” (error “tls: failed to verify client’s certificate: x509: certificate signed by unknown authority (possibly because of “crypto/rsa: verification error” while trying to verify candidate authority certificate “kube-ca”)”, ServerName “”), while setting up the Master (by choosing Node option as etcd and control panel)

---

<div class="post-metadata">

**Author:** ![JasonvanBrackel](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jasonvanbrackel/32/4558_2.png) [@JasonvanBrackel](https://forums.suse.com/u/JasonvanBrackel)\
**Post date:** [July 26, 2019, 2:30pm UTC](https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906/2 "2019-07-26T14:30:38Z")

</div>

Could use a little more context here. Is this an error on an HA Rancher cluster or a cluster being created by Rancher? How is this cluster being created? i.e. Which workflow?

---

<div class="post-metadata">

**Author:** ![kamlesh](https://avatars.discourse-cdn.com/v4/letter/k/aeb1de/32.png) [@kamlesh](https://forums.suse.com/u/kamlesh)\
**Post date:** [July 29, 2019, 5:34am UTC](https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906/3 "2019-07-29T05:34:39Z")

</div>

Ok so i have created one cluster, by selection Node option as ectd and control panel, from Rancher web GUI. and this Cluster in being created in different VM.  
And i am getting this error on newly created cluster.

---

<div class="post-metadata">

**Author:** ![JasonvanBrackel](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jasonvanbrackel/32/4558_2.png) [@JasonvanBrackel](https://forums.suse.com/u/JasonvanBrackel)\
**Post date:** [August 6, 2019, 12:10pm UTC](https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906/4 "2019-08-06T12:10:30Z")

</div>

Sorry was away last week on vacation. Is this error on the screen? Is the cluster being created and not working? Add a few screen shots if you can. There lots of areas where you can get a certificate error legitimately.

---

<div class="post-metadata">

**Author:** ![kamlesh](https://avatars.discourse-cdn.com/v4/letter/k/aeb1de/32.png) [@kamlesh](https://forums.suse.com/u/kamlesh)\
**Post date:** [August 8, 2019, 6:06am UTC](https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906/5 "2019-08-08T06:06:01Z")

</div>

Thanks for you response.But now problem has been sorted out.

---

<div class="post-metadata">

**Author:** ![dperalta](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/dperalta/32/5279_2.png) [@dperalta](https://forums.suse.com/u/dperalta)\
**Post date:** [August 9, 2019, 3:58am UTC](https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906/6 "2019-08-09T03:58:42Z")

</div>

hi @kamlesh, may I know how you solved the problem? I experiencing the same issue.

---

<div class="post-metadata">

**Author:** ![kamlesh](https://avatars.discourse-cdn.com/v4/letter/k/aeb1de/32.png) [@kamlesh](https://forums.suse.com/u/kamlesh)\
**Post date:** [August 13, 2019, 3:58am UTC](https://forums.suse.com/t/certificate-signed-by-unknown-authority/14906/7 "2019-08-13T03:58:00Z")

</div>

Ok so, this problem was because of worker node . so i cleaned everything from worker Node machine.  
Again i tried to add the node into the master node. I will suggest kindly add etcd and controlplane node first then add worker node.
