# ClusterController: failed to start user controllers: Unauthorized

**URL:** <https://forums.suse.com/t/clustercontroller-failed-to-start-user-controllers-unauthorized/15811>\
**Category:** SUSE Rancher Prime\
**Created:** [November 13, 2019, 1:36pm UTC](https://forums.suse.com/t/clustercontroller-failed-to-start-user-controllers-unauthorized/15811 "2019-11-13T13:36:49Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pcaetano](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/pcaetano/32/5801_2.png) [@pcaetano](https://forums.suse.com/u/pcaetano)\
**Post date:** [November 13, 2019, 1:36pm UTC](https://forums.suse.com/t/clustercontroller-failed-to-start-user-controllers-unauthorized/15811/1 "2019-11-13T13:36:49Z")

</div>

Hi,

after upgrading from Rancher 2.2.8 to 2.3.2 single and K8s from 1.11 to 1.16, we are having the following error:  
[ERROR] ClusterController c-hdx96 [user-controllers-controller] failed with : failed to start user controllers for cluster c-dzrz7: failed to contact server: Unauthorized

Which server is denying the request?

We are having also some errors about handshakes on:

- master: “http: TLS handshake error from 127.0.0.1:50508: EOF”
- registering a new cluster controller/rancher-agent: “level=error msg=“Failed to connect to proxy. Response status: 200 - 200 OK. Response body: [node.management.cattle.io](http://node.management.cattle.io) “c-dzrz7/m-6a7f4a83c4e6” not found” error=“websocket: bad handshake””

Meanwhile, on Rancher UI, we can’t see any information on the dashboard and the nodes page is outdated.

Thanks.

---

<div class="post-metadata">

**Author:** ![peetasan](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/peetasan/32/2257_2.png) [@peetasan](https://forums.suse.com/u/peetasan)\
**Post date:** [June 9, 2020, 1:56pm UTC](https://forums.suse.com/t/clustercontroller-failed-to-start-user-controllers-unauthorized/15811/2 "2020-06-09T13:56:57Z")

</div>

Did you manage to fix this?

Have a similar issue when trying to import a cluster from Google cloud in a Rancher running in AWS. Response is 200 ok, but it complains about a proxy which I don’t (think I) have:

```
level=info msg="Connecting to wss://MYDNS/v3/connect with token xxx"
level=info msg="Connecting to proxy" url="wss://MYDNS/v3/connect"
level=error msg="Failed to connect to proxy. Response status: 200 - 200 OK. Response 
body: node.management.cattle.io \"c-wjkc9/m-38115dee6999\" not found" 
error="websocket: bad handshake"
level=error msg="Remotedialer proxy error" error="websocket: bad handshake"

```

Thanks
