# CLVMD failed to start when bringing up single HA node

**URL:** <https://forums.suse.com/t/clvmd-failed-to-start-when-bringing-up-single-ha-node/30047>\
**Category:** SLES High Availability Extension\
**Created:** [July 12, 2017, 7:29pm UTC](https://forums.suse.com/t/clvmd-failed-to-start-when-bringing-up-single-ha-node/30047 "2017-07-12T19:29:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![arunabha\_banerjee](https://avatars.discourse-cdn.com/v4/letter/a/e480ec/32.png) [@arunabha\_banerjee](https://forums.suse.com/u/arunabha_banerjee)\
**Post date:** [July 12, 2017, 7:29pm UTC](https://forums.suse.com/t/clvmd-failed-to-start-when-bringing-up-single-ha-node/30047/1 "2017-07-12T19:29:19Z")

</div>

Dear Expert,

I am trying to build two node cluster. HA version is SLES 12 SP2 HAE. The problem is I’m able to build the cluster successfully but during HA test when both the node (node1 & node2) is down and I’m trying to bring up node1 “CLVMD” is always failed. Kindly help.

Error:

2017-07-12T06:16:30.076663-05:00 nfsnode1 dlm\_controld[2343]: 107 fence work wait for quorum  
2017-07-12T06:16:34.083064-05:00 nfsnode1 dlm\_controld[2343]: 111 clvmd wait for quorum  
…

Cluster configuration:

root@nfsnode1:/root\>crm configure show  
node 1084808202: nfsnode1  
node 1084808203: nfsnode2  
primitive admin\_addr IPaddr2 \  
params ip=192.168.220.13 \  
op monitor interval=10 timeout=20  
primitive clvm ocf:lvm2:clvmd \  
params daemon\_timeout=30 \  
op start timeout=90s interval=0 \  
op stop timeout=100s interval=0  
primitive dlm ocf:pacemaker:controld \  
op start timeout=90s interval=0 \  
op stop timeout=100s interval=0  
primitive fs\_sap Filesystem \  
params device="/dev/vgappdata/lvusrsap" directory="/usr/sap/XE1/" fstype=ext4 \  
meta target-role=Started \  
op start interval=0 timeout=60s \  
op stop interval=0 timeout=60s \  
op monitor interval=20s timeout=40s  
primitive stonith-sbd stonith:external/sbd \  
params pcmk\_delay\_max=30s  
primitive vg1 LVM \  
params volgrpname=vgappdata \  
op start timeout=60s interval=0 \  
op stop timeout=60s interval=0 \  
op monitor interval=30s timeout=60s  
primitive vip\_sap IPaddr2 \  
params ip=192.168.220.16 cidr\_netmask=24 \  
op start interval=0 timeout=20 \  
op stop interval=0 timeout=20 \  
op monitor interval=10 timeout=20  
group g-clvm dlm clvm vg1  
group g\_sap fs\_sap vip\_sap \  
meta target-role=Started  
clone c-clvm g-clvm \  
meta interleave=true ordered=true  
order g-constraint Optional: c-clvm:start g\_sap:start  
property cib-bootstrap-options: \  
have-watchdog=true \  
dc-version=1.1.15-21.1-e174ec8 \  
cluster-infrastructure=corosync \  
cluster-name=hacluster \  
stonith-enabled=true \  
placement-strategy=balanced \  
no-quorum-policy=ignore \  
stonith-action=reboot \  
stonith-timeout=150s  
rsc\_defaults rsc-options: \  
resource-stickiness=1000 \  
migration-threshold=5000  
op\_defaults op-options: \  
timeout=600 \  
record-pending=true  
root@nfsnode1:/root\>

Best regards,  
Arunabha

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [July 12, 2017, 7:57pm UTC](https://forums.suse.com/t/clvmd-failed-to-start-when-bringing-up-single-ha-node/30047/2 "2017-07-12T19:57:20Z")

</div>

Hi Arunabha,

could you please list the DLM config via “dlm\_tool dump\_config”? Just to verify its quorum setting.

Regards,  
J

---

<div class="post-metadata">

**Author:** ![arunabha\_banerjee](https://avatars.discourse-cdn.com/v4/letter/a/e480ec/32.png) [@arunabha\_banerjee](https://forums.suse.com/u/arunabha_banerjee)\
**Post date:** [July 12, 2017, 8:45pm UTC](https://forums.suse.com/t/clvmd-failed-to-start-when-bringing-up-single-ha-node/30047/3 "2017-07-12T20:45:25Z")

</div>

Here it is …

root@nfsnode1:/root\>dlm\_tool dump\_config  
daemon\_debug=0  
foreground=0  
log\_debug=0  
timewarn=0  
protocol=detect  
debug\_logfile=0  
enable\_fscontrol=0  
enable\_plock=1  
plock\_debug=0  
plock\_rate\_limit=0  
plock\_ownership=0  
drop\_resources\_time=10000  
drop\_resources\_count=10  
drop\_resources\_age=10000  
post\_join\_delay=30  
enable\_fencing=1  
enable\_concurrent\_fencing=0  
enable\_startup\_fencing=0  
enable\_quorum\_fencing=1  
enable\_quorum\_lockspace=1  
help=-1  
version=-1

root@nfsnode1:/root\>

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [July 13, 2017, 2:59pm UTC](https://forums.suse.com/t/clvmd-failed-to-start-when-bringing-up-single-ha-node/30047/4 "2017-07-13T14:59:25Z")

</div>

I don’t have an 12SP2 HAE installation at hand - what catches the eye is

[QUOTE]enable\_quorum\_fencing=1  
enable\_quorum\_lockspace=1[/QUOTE]

which I would have expected to be “0” in your two-node setup.

Unfortunately, “my hands are bound” (or rather, I’m sort of “blind”) until I am back at my office next week - if anyone else would like to chime in here, you’re welcome 😉

Regards,  
J
