# Connecting Redis from same name space

**URL:** https://forums.suse.com/t/connecting-redis-from-same-name-space/37585
**Category:** General
**Created:** [April 12, 2022, 5:21pm UTC](https://forums.suse.com/t/connecting-redis-from-same-name-space/37585 "2022-04-12T17:21:43Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![lpila](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/lpila/32/8871_2.png) [@lpila](https://forums.suse.com/u/lpila)
#### Post date: [April 12, 2022, 5:21pm UTC](https://forums.suse.com/t/connecting-redis-from-same-name-space/37585/1 "2022-04-12T17:21:43Z")

</div>

Hi,  
I am using rancher and deploying my docker 3 helm charts to the container

1. API
2. Redis
3. Redis commander  
All 3 are up and running, however I am unable to connect to redis in the commander as well as API.  
I tried with ingress host as well as container name all the time I am getting below error.

setUpConnection (R:redis:6379:0) Redis error Error: getaddrinfo ENOTFOUND redis

I have Environment variable exposed in redis commander as

containers:  
- env:  
- name: REDIS\_HOSTS  
value: local:redis:6379  
- name: REDIS\_PORT  
value: “”  
image: rediscommander/redis-commander:latest

Any inputs are highly appreciated.

---

<div class="post-metadata">

### Author: ![lpila](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/lpila/32/8871_2.png) [@lpila](https://forums.suse.com/u/lpila)
#### Post date: [April 12, 2022, 8:29pm UTC](https://forums.suse.com/t/connecting-redis-from-same-name-space/37585/2 "2022-04-12T20:29:16Z")

</div>

Resolved the issue while using service name instead of the container name
