# Containers stuck in 'In Progress' - cannot start anything else

**URL:** <https://forums.suse.com/t/containers-stuck-in-in-progress-cannot-start-anything-else/2942>\
**Category:** Rancher 1.x\
**Created:** [May 27, 2016, 10:07am UTC](https://forums.suse.com/t/containers-stuck-in-in-progress-cannot-start-anything-else/2942 "2016-05-27T10:07:07Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![kiboro](https://avatars.discourse-cdn.com/v4/letter/k/7993a0/32.png) [@kiboro](https://forums.suse.com/u/kiboro)\
**Post date:** [May 27, 2016, 10:07am UTC](https://forums.suse.com/t/containers-stuck-in-in-progress-cannot-start-anything-else/2942/1 "2016-05-27T10:07:08Z")

</div>

I’ve got several containers stuck in ‘In Progress’ which I haven’t seen for a long time. I also can’t remove via the API. How do I unstick this?

Text from UI  
Stack: geodocker  
hadoop-name\_1 In Progress  
hadoop-name\_1 In Progress  
hadoop-name\_1 In Progress

Trying to remove via API

````auto
"id": "44a0599b-bdd3-446a-9408-42690dad9999",
"type": "error",
"links": { },
"actions": { },
"status": 500,
"code": "Internal Server Error",
"message": "Internal Server Error",
"detail": null,
}```
````

---

<div class="post-metadata">

**Author:** ![denise](https://avatars.discourse-cdn.com/v4/letter/d/82dd89/32.png) [@denise](https://forums.suse.com/u/denise)\
**Post date:** [June 15, 2016, 6:11am UTC](https://forums.suse.com/t/containers-stuck-in-in-progress-cannot-start-anything-else/2942/2 "2016-06-15T06:11:01Z")

</div>

Are the containers located on the host at all?

---

<div class="post-metadata">

**Author:** ![kiboro](https://avatars.discourse-cdn.com/v4/letter/k/7993a0/32.png) [@kiboro](https://forums.suse.com/u/kiboro)\
**Post date:** [June 16, 2016, 10:29am UTC](https://forums.suse.com/t/containers-stuck-in-in-progress-cannot-start-anything-else/2942/3 "2016-06-16T10:29:29Z")

</div>

Sorry for the delay in getting back to you. In the middle of a large upgrade and it’s not going well.

I eventually sidestepped this issue. This instance of Rancher had been about for a long time and been upgraded from around 0.34 and had been played with a lot. We also had errors relating to long destroyed hosts. I built a new Rancher from scratch and migrated the hosts and redeployed everything. Not ideal but at least we’re ok now.

---

<div class="post-metadata">

**Author:** ![ranjith](https://avatars.discourse-cdn.com/v4/letter/r/8797f3/32.png) [@ranjith](https://forums.suse.com/u/ranjith)\
**Post date:** [June 14, 2018, 8:46am UTC](https://forums.suse.com/t/containers-stuck-in-in-progress-cannot-start-anything-else/2942/4 "2018-06-14T08:46:13Z")

</div>

Yes. There containers located in hosts only.
