# Convoy-gluster on specific storage hosts

**URL:** <https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254>\
**Category:** Convoy\
**Created:** [December 15, 2015, 11:17am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254 "2015-12-15T11:17:06Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![samouds](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/samouds/32/658_2.png) [@samouds](https://forums.suse.com/u/samouds)\
**Post date:** [December 15, 2015, 11:17am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/1 "2015-12-15T11:17:06Z")

</div>

Hello,

I have 5 hosts with two specific hosts to store data with glusterfs and convoy, one for the databases, one for the webservers, and one load balancer.

But i don’t know where to install the glusterFS server and convoy.

Do I need to install convoy on all hosts or only on the two storage hosts ?

---

<div class="post-metadata">

**Author:** ![cjellick](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/cjellick/32/2876_2.png) [@cjellick](https://forums.suse.com/u/cjellick)\
**Post date:** [December 15, 2015, 1:50pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/2 "2015-12-15T13:50:19Z")

</div>

Hi @samouds,

At this time, you cant control where the glusterfs services get deployed. They will land on three of your hosts.

Convoy-gluster you can (and must) control by adding the host label that you specify in the convoy-gluster setup page.

So, with that in mind, here’s what you’ll end up with: your actual data is going to be written to the three hosts that have glsuterfs-server running on them. But because of glusterfs’s distributed nature, those hosts need not be the same hosts as the ones running conovy-gluster and ultimately your containers that are going to use gluster backed volumes.

So it seems to me that in a relatively small (5 host) deployment like yours, you would be safe to deploy convoy-gluster to all hosts.

With all that said, I think what you’re telling us is that you have two hosts with a lot more storage and this is where you want to run glusterfs or whatever storage services are doing the actually data storage and taking up disk space. Is that right? If so, unfortunately I think your only option is two deactivate the three non-storage hosts while you deploy glusterfs (forcing glusterfs to the two storage nodes) and then reactivate them to deploy all your other services.

---

<div class="post-metadata">

**Author:** ![seb2411](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/seb2411/32/593_2.png) [@seb2411](https://forums.suse.com/u/seb2411)\
**Post date:** [December 30, 2015, 9:46pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/3 "2015-12-30T21:46:22Z")

</div>

In fact you can control where the glusterfs is deployed. But, for that you need to copy the docker-compose and rancher-compose info from the catalogue an create a stack yourself.

On the servers where you want to launch Glusterfs you have to add a label. For example `type = glusterfs`  
On the docker-compose, on the glusterfs-server section, you have to add :  
`io.rancher.scheduler.affinity:host_label_soft: type=glusterfs`

I did a test and I think is working. So at the end the docker-compose look like that :

```
glusterfs-server:
  image: rancher/glusterfs:v0.1.3
  cap_add:
    - SYS_ADMIN
  volumes_from:
    - glusterfs-data
  labels:
    io.rancher.container.hostname_override: container_name
    io.rancher.scheduler.affinity:host_label_soft: type=glusterfs
    io.rancher.sidekicks: glusterfs-peer,glusterfs-data,glusterfs-volume-create
  command: "glusterd -p /var/run/gluster.pid -N"
glusterfs-peer:
  image: rancher/glusterfs:v0.1.3
  net: 'container:glusterfs-server'
  volumes_from:
    - glusterfs-data
  labels:
    io.rancher.container.hostname_override: container_name
  command: /opt/rancher/peerprobe.sh
glusterfs-data:
  image: rancher/glusterfs:v0.1.3
  command: /bin/true
  volumes:
    - /var/run
  labels:
    io.rancher.container.hostname_override: container_name
    io.rancher.container.start_once: true
glusterfs-volume-create:
  image: rancher/glusterfs:v0.1.3
  command: /opt/rancher/replicated_volume_create.sh
  net: 'container:glusterfs-server'
  volumes_from:
    - glusterfs-data
  labels:
    io.rancher.container.hostname_override: container_name
    io.rancher.container.start_once: true

```

And the rancher-compose:

```
glusterfs-server:
  scale: 3
  metadata:
    volume_name: "data"

```

On the rancher-compose you have to take care of the scale and the volume name.

---

<div class="post-metadata">

**Author:** ![samouds](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/samouds/32/658_2.png) [@samouds](https://forums.suse.com/u/samouds)\
**Post date:** [January 19, 2016, 11:19am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/4 "2016-01-19T11:19:10Z")

</div>

Thank you guys !

I managed to get it work.

But now I have a problem with mysql docker with data volume managed by convoy. (I have no problem to run the mysql docker without convoy)

I cannot connect with the root user, and there are the docker compose and the logs

**docker compose**

> `  
> mysql:  
> labels:  
> io.rancher.scheduler.affinity:host\_label\_soft: ‘db=true’  
> environment:  
> MYSQL\_ROOT\_PASSWORD: myPassword  
> image: mysql  
> volumes:
> 
> - volume\_name:/var/lib/mysql  
> volume\_driver: convoy-gluster  
> `

**logs**

> `19/1/2016 12:14:242016-01-19T11:14:22.406638Z 0 [Note] mysqld (mysqld 5.7.10) starting as process 1 ... 19/1/2016 12:14:242016-01-19T11:14:24.254637Z 0 [Note] InnoDB: PUNCH HOLE support available 19/1/2016 12:14:242016-01-19T11:14:24.254667Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins 19/1/2016 12:14:242016-01-19T11:14:24.254675Z 0 [Note] InnoDB: Uses event mutexes 19/1/2016 12:14:242016-01-19T11:14:24.254680Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier 19/1/2016 12:14:242016-01-19T11:14:24.254686Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.8 19/1/2016 12:14:242016-01-19T11:14:24.254690Z 0 [Note] InnoDB: Using Linux native AIO 19/1/2016 12:14:242016-01-19T11:14:24.254979Z 0 [Note] InnoDB: Number of pools: 1 19/1/2016 12:14:242016-01-19T11:14:24.255099Z 0 [Note] InnoDB: Using CPU crc32 instructions 19/1/2016 12:14:242016-01-19T11:14:24.263800Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M 19/1/2016 12:14:242016-01-19T11:14:24.273229Z 0 [Note] InnoDB: Completed initialization of buffer pool 19/1/2016 12:14:242016-01-19T11:14:24.275315Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority(). 19/1/2016 12:14:262016-01-19T11:14:26.127752Z 0 [Note] InnoDB: Highest supported file format is Barracuda. 19/1/2016 12:14:322016-01-19T11:14:32.441219Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables 19/1/2016 12:14:332016-01-19T11:14:33.020198Z 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ... 19/1/2016 12:14:352016-01-19T11:14:35.637541Z 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB. 19/1/2016 12:14:352016-01-19T11:14:35.803490Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active. 19/1/2016 12:14:352016-01-19T11:14:35.803519Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active. 19/1/2016 12:14:352016-01-19T11:14:35.804182Z 0 [Note] InnoDB: Waiting for purge to start 19/1/2016 12:14:352016-01-19T11:14:35.854337Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 11579ms. The settings might not be optimal. (flushed=0 and evicted=0, during the time.) 19/1/2016 12:14:352016-01-19T11:14:35.855302Z 0 [Note] InnoDB: 5.7.10 started; log sequence number 1312096 19/1/2016 12:14:352016-01-19T11:14:35.855534Z 0 [Note] InnoDB: not started 19/1/2016 12:14:352016-01-19T11:14:35.855753Z 0 [Note] Plugin 'FEDERATED' is disabled. 19/1/2016 12:14:352016-01-19T11:14:35.937980Z 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool 19/1/2016 12:14:402016-01-19T11:14:40.718569Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key 19/1/2016 12:14:402016-01-19T11:14:40.718602Z 0 [Note] Server hostname (bind-address): '*'; port: 3306 19/1/2016 12:14:402016-01-19T11:14:40.718642Z 0 [Note] IPv6 is available. 19/1/2016 12:14:402016-01-19T11:14:40.718651Z 0 [Note] - '::' resolves to '::'; 19/1/2016 12:14:402016-01-19T11:14:40.718658Z 0 [Note] Server socket created on IP: '::'. 19/1/2016 12:14:402016-01-19T11:14:40.982808Z 0 [Note] InnoDB: Buffer pool(s) load completed at 160119 11:14:40 19/1/2016 12:14:422016-01-19T11:14:42.465016Z 0 [ERROR] Missing system table mysql.proxies_priv; please run mysql_upgrade to create it 19/1/2016 12:14:462016-01-19T11:14:46.338774Z 0 [ERROR] Native table 'performance_schema'.'cond_instances' has the wrong structure 19/1/2016 12:14:462016-01-19T11:14:46.668918Z 0 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure 19/1/2016 12:14:472016-01-19T11:14:47.080092Z 0 [ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure 19/1/2016 12:14:472016-01-19T11:14:47.407437Z 0 [ERROR] Native table 'performance_schema'.'events_waits_history_long' has the wrong structure 19/1/2016 12:14:472016-01-19T11:14:47.735771Z 0 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_host_by_event_name' has the wrong structure 19/1/2016 12:14:482016-01-19T11:14:48.064772Z 0 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_instance' has the wrong structure 19/1/2016 12:14:482016-01-19T11:14:48.474355Z 0 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_thread_by_event_name' has the wrong structure 19/1/2016 12:14:482016-01-19T11:14:48.804163Z 0 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_user_by_event_name' has the wrong structure 19/1/2016 12:14:492016-01-19T11:14:49.132609Z 0 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_account_by_event_name' has the wrong structure 19/1/2016 12:14:492016-01-19T11:14:49.543040Z 0 [ERROR] Native table 'performance_schema'.'events_waits_summary_global_by_event_name' has the wrong structure 19/1/2016 12:14:492016-01-19T11:14:49.871927Z 0 [ERROR] Native table 'performance_schema'.'file_instances' has the wrong structure 19/1/2016 12:14:502016-01-19T11:14:50.199755Z 0 [ERROR] Native table 'performance_schema'.'file_summary_by_event_name' has the wrong structure 19/1/2016 12:14:502016-01-19T11:14:50.527040Z 0 [ERROR] Native table 'performance_schema'.'file_summary_by_instance' has the wrong structure 19/1/2016 12:14:502016-01-19T11:14:50.938382Z 0 [ERROR] Native table 'performance_schema'.'host_cache' has the wrong structure 19/1/2016 12:14:512016-01-19T11:14:51.265176Z 0 [ERROR] Native table 'performance_schema'.'mutex_instances' has the wrong structure 19/1/2016 12:14:512016-01-19T11:14:51.591358Z 0 [ERROR] Native table 'performance_schema'.'objects_summary_global_by_type' has the wrong structure 19/1/2016 12:14:522016-01-19T11:14:52.002853Z 0 [ERROR] Native table 'performance_schema'.'performance_timers' has the wrong structure 19/1/2016 12:14:522016-01-19T11:14:52.331642Z 0 [ERROR] Native table 'performance_schema'.'rwlock_instances' has the wrong structure 19/1/2016 12:14:522016-01-19T11:14:52.659171Z 0 [ERROR] Native table 'performance_schema'.'setup_actors' has the wrong structure 19/1/2016 12:14:522016-01-19T11:14:52.987004Z 0 [ERROR] Native table 'performance_schema'.'setup_consumers' has the wrong structure 19/1/2016 12:14:532016-01-19T11:14:53.397501Z 0 [ERROR] Native table 'performance_schema'.'setup_instruments' has the wrong structure 19/1/2016 12:14:532016-01-19T11:14:53.725422Z 0 [ERROR] Native table 'performance_schema'.'setup_objects' has the wrong structure 19/1/2016 12:14:542016-01-19T11:14:54.052277Z 0 [ERROR] Native table 'performance_schema'.'setup_timers' has the wrong structure 19/1/2016 12:14:542016-01-19T11:14:54.461640Z 0 [ERROR] Native table 'performance_schema'.'table_io_waits_summary_by_index_usage' has the wrong structure 19/1/2016 12:14:542016-01-19T11:14:54.790287Z 0 [ERROR] Native table 'performance_schema'.'table_io_waits_summary_by_table' has the wrong structure 19/1/2016 12:14:552016-01-19T11:14:55.118698Z 0 [ERROR] Native table 'performance_schema'.'table_lock_waits_summary_by_table' has the wrong structure 19/1/2016 12:14:552016-01-19T11:14:55.445721Z 0 [ERROR] Native table 'performance_schema'.'threads' has the wrong structure 19/1/2016 12:14:552016-01-19T11:14:55.857888Z 0 [ERROR] Native table 'performance_schema'.'events_stages_current' has the wrong structure 19/1/2016 12:14:562016-01-19T11:14:56.185598Z 0 [ERROR] Native table 'performance_schema'.'events_stages_history' has the wrong structure 19/1/2016 12:14:562016-01-19T11:14:56.512861Z 0 [ERROR] Native table 'performance_schema'.'events_stages_history_long' has the wrong structure 19/1/2016 12:14:562016-01-19T11:14:56.924452Z 0 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_thread_by_event_name' has the wrong structure 19/1/2016 12:14:572016-01-19T11:14:57.250899Z 0 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_account_by_event_name' has the wrong structure 19/1/2016 12:14:572016-01-19T11:14:57.577356Z 0 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_user_by_event_name' has the wrong structure 19/1/2016 12:14:572016-01-19T11:14:57.903596Z 0 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_host_by_event_name' has the wrong structure 19/1/2016 12:14:582016-01-19T11:14:58.313209Z 0 [ERROR] Native table 'performance_schema'.'events_stages_summary_global_by_event_name' has the wrong structure 19/1/2016 12:14:582016-01-19T11:14:58.641648Z 0 [ERROR] Native table 'performance_schema'.'events_statements_current' has the wrong structure 19/1/2016 12:14:582016-01-19T11:14:58.967896Z 0 [ERROR] Native table 'performance_schema'.'events_statements_history' has the wrong structure 19/1/2016 12:14:592016-01-19T11:14:59.376383Z 0 [ERROR] Native table 'performance_schema'.'events_statements_history_long' has the wrong structure 19/1/2016 12:14:592016-01-19T11:14:59.704241Z 0 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_thread_by_event_name' has the wrong structure 19/1/2016 12:15:002016-01-19T11:15:00.032221Z 0 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_account_by_event_name' has the wrong structure 19/1/2016 12:15:002016-01-19T11:15:00.358302Z 0 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_user_by_event_name' has the wrong structure 19/1/2016 12:15:002016-01-19T11:15:00.768115Z 0 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_host_by_event_name' has the wrong structure 19/1/2016 12:15:012016-01-19T11:15:01.096404Z 0 [ERROR] Native table 'performance_schema'.'events_statements_summary_global_by_event_name' has the wrong structure 19/1/2016 12:15:012016-01-19T11:15:01.423266Z 0 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_digest' has the wrong structure 19/1/2016 12:15:012016-01-19T11:15:01.832823Z 0 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_program' has the wrong structure 19/1/2016 12:15:022016-01-19T11:15:02.162738Z 0 [ERROR] Native table 'performance_schema'.'events_transactions_current' has the wrong structure 19/1/2016 12:15:022016-01-19T11:15:02.489817Z 0 [ERROR] Native table 'performance_schema'.'events_transactions_history' has the wrong structure 19/1/2016 12:15:022016-01-19T11:15:02.815912Z 0 [ERROR] Native table 'performance_schema'.'events_transactions_history_long' has the wrong structure 19/1/2016 12:15:032016-01-19T11:15:03.225098Z 0 [ERROR] Native table 'performance_schema'.'events_transactions_summary_by_thread_by_event_name' has the wrong structure 19/1/2016 12:15:032016-01-19T11:15:03.552768Z 0 [ERROR] Native table 'performance_schema'.'events_transactions_summary_by_account_by_event_name' has the wrong structure 19/1/2016 12:15:032016-01-19T11:15:03.880735Z 0 [ERROR] Native table 'performance_schema'.'events_transactions_summary_by_user_by_event_name' has the wrong structure 19/1/2016 12:15:042016-01-19T11:15:04.292154Z 0 [ERROR] Native table 'performance_schema'.'events_transactions_summary_by_host_by_event_name' has the wrong structure 19/1/2016 12:15:042016-01-19T11:15:04.620118Z 0 [ERROR] Native table 'performance_schema'.'events_transactions_summary_global_by_event_name' has the wrong structure 19/1/2016 12:15:042016-01-19T11:15:04.948917Z 0 [ERROR] Native table 'performance_schema'.'users' has the wrong structure 19/1/2016 12:15:052016-01-19T11:15:05.275926Z 0 [ERROR] Native table 'performance_schema'.'accounts' has the wrong structure 19/1/2016 12:15:052016-01-19T11:15:05.686695Z 0 [ERROR] Native table 'performance_schema'.'hosts' has the wrong structure 19/1/2016 12:15:062016-01-19T11:15:06.014531Z 0 [ERROR] Native table 'performance_schema'.'socket_instances' has the wrong structure 19/1/2016 12:15:062016-01-19T11:15:06.342260Z 0 [ERROR] Native table 'performance_schema'.'socket_summary_by_instance' has the wrong structure 19/1/2016 12:15:062016-01-19T11:15:06.751293Z 0 [ERROR] Native table 'performance_schema'.'socket_summary_by_event_name' has the wrong structure 19/1/2016 12:15:072016-01-19T11:15:07.080204Z 0 [ERROR] Native table 'performance_schema'.'session_connect_attrs' has the wrong structure 19/1/2016 12:15:072016-01-19T11:15:07.407479Z 0 [ERROR] Native table 'performance_schema'.'session_account_connect_attrs' has the wrong structure 19/1/2016 12:15:072016-01-19T11:15:07.735518Z 0 [ERROR] Native table 'performance_schema'.'memory_summary_global_by_event_name' has the wrong structure 19/1/2016 12:15:082016-01-19T11:15:08.144139Z 0 [ERROR] Native table 'performance_schema'.'memory_summary_by_account_by_event_name' has the wrong structure 19/1/2016 12:15:082016-01-19T11:15:08.471517Z 0 [ERROR] Native table 'performance_schema'.'memory_summary_by_host_by_event_name' has the wrong structure 19/1/2016 12:15:082016-01-19T11:15:08.798204Z 0 [ERROR] Native table 'performance_schema'.'memory_summary_by_thread_by_event_name' has the wrong structure 19/1/2016 12:15:092016-01-19T11:15:09.206967Z 0 [ERROR] Native table 'performance_schema'.'memory_summary_by_user_by_event_name' has the wrong structure 19/1/2016 12:15:092016-01-19T11:15:09.534485Z 0 [ERROR] Native table 'performance_schema'.'table_handles' has the wrong structure 19/1/2016 12:15:092016-01-19T11:15:09.861332Z 0 [ERROR] Native table 'performance_schema'.'metadata_locks' has the wrong structure 19/1/2016 12:15:102016-01-19T11:15:10.188137Z 0 [ERROR] Native table 'performance_schema'.'replication_connection_configuration' has the wrong structure 19/1/2016 12:15:102016-01-19T11:15:10.599755Z 0 [ERROR] Native table 'performance_schema'.'replication_group_members' has the wrong structure 19/1/2016 12:15:102016-01-19T11:15:10.927585Z 0 [ERROR] Native table 'performance_schema'.'replication_connection_status' has the wrong structure 19/1/2016 12:15:112016-01-19T11:15:11.254681Z 0 [ERROR] Native table 'performance_schema'.'replication_applier_configuration' has the wrong structure 19/1/2016 12:15:112016-01-19T11:15:11.665063Z 0 [ERROR] Native table 'performance_schema'.'replication_applier_status' has the wrong structure 19/1/2016 12:15:112016-01-19T11:15:11.992926Z 0 [ERROR] Native table 'performance_schema'.'replication_applier_status_by_coordinator' has the wrong structure 19/1/2016 12:15:122016-01-19T11:15:12.320128Z 0 [ERROR] Native table 'performance_schema'.'replication_applier_status_by_worker' has the wrong structure 19/1/2016 12:15:122016-01-19T11:15:12.647609Z 0 [ERROR] Native table 'performance_schema'.'replication_group_member_stats' has the wrong structure 19/1/2016 12:15:132016-01-19T11:15:13.058473Z 0 [ERROR] Native table 'performance_schema'.'prepared_statements_instances' has the wrong structure 19/1/2016 12:15:132016-01-19T11:15:13.385508Z 0 [ERROR] Native table 'performance_schema'.'user_variables_by_thread' has the wrong structure 19/1/2016 12:15:132016-01-19T11:15:13.713013Z 0 [ERROR] Native table 'performance_schema'.'status_by_account' has the wrong structure 19/1/2016 12:15:142016-01-19T11:15:14.122603Z 0 [ERROR] Native table 'performance_schema'.'status_by_host' has the wrong structure 19/1/2016 12:15:142016-01-19T11:15:14.450531Z 0 [ERROR] Native table 'performance_schema'.'status_by_thread' has the wrong structure 19/1/2016 12:15:142016-01-19T11:15:14.777746Z 0 [ERROR] Native table 'performance_schema'.'status_by_user' has the wrong structure 19/1/2016 12:15:152016-01-19T11:15:15.105991Z 0 [ERROR] Native table 'performance_schema'.'global_status' has the wrong structure 19/1/2016 12:15:152016-01-19T11:15:15.516550Z 0 [ERROR] Native table 'performance_schema'.'session_status' has the wrong structure 19/1/2016 12:15:152016-01-19T11:15:15.844737Z 0 [ERROR] Native table 'performance_schema'.'variables_by_thread' has the wrong structure 19/1/2016 12:15:162016-01-19T11:15:16.172724Z 0 [ERROR] Native table 'performance_schema'.'global_variables' has the wrong structure 19/1/2016 12:15:162016-01-19T11:15:16.581286Z 0 [ERROR] Native table 'performance_schema'.'session_variables' has the wrong structure 19/1/2016 12:15:172016-01-19T11:15:17.401799Z 0 [Note] Event Scheduler: Loaded 0 events 19/1/2016 12:15:172016-01-19T11:15:17.402069Z 0 [Note] mysqld: ready for connections. 19/1/2016 12:15:17Version: '5.7.10' socket: '/var/run/mysqld/mysqld.sock' port: 3306 MySQL Community Server (GPL)`

---

<div class="post-metadata">

**Author:** ![seb2411](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/seb2411/32/593_2.png) [@seb2411](https://forums.suse.com/u/seb2411)\
**Post date:** [January 21, 2016, 1:54pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/5 "2016-01-21T13:54:21Z")

</div>

I didn’t try the Gluster Convoy. But for what I understand you have to specify the driver for your volume:  
[http://docs.rancher.com/rancher/rancher-services/storage-service/](http://docs.rancher.com/rancher/rancher-services/storage-service/)

---

<div class="post-metadata">

**Author:** ![samouds](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/samouds/32/658_2.png) [@samouds](https://forums.suse.com/u/samouds)\
**Post date:** [January 22, 2016, 9:02am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/6 "2016-01-22T09:02:40Z")

</div>

@seb2411 Thanks for the answer. the driver is specified for the volume :

> `volumes:
> 
> - volume\_name:/var/lib/mysql  
> volume\_driver: convoy-gluster`

convoy-gluster is the name of the storage\_pool.

---

<div class="post-metadata">

**Author:** ![seb2411](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/seb2411/32/593_2.png) [@seb2411](https://forums.suse.com/u/seb2411)\
**Post date:** [January 22, 2016, 1:07pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/7 "2016-01-22T13:07:44Z")

</div>

So I don’t know. Did you have checked the logs on your glusterfs cluster ?

---

<div class="post-metadata">

**Author:** ![samouds](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/samouds/32/658_2.png) [@samouds](https://forums.suse.com/u/samouds)\
**Post date:** [January 22, 2016, 4:31pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/8 "2016-01-22T16:31:00Z")

</div>

Here the logs :

**GlusterFS Server**

> ame: unrecognized option ‘–first=yes’  
> ame: unrecognized option ‘–version=1’  
> ame: unrecognized option ‘–volume-op=start’  
> ame: unrecognized option ‘–gd-workdir=/var/lib/glusterd’  
> ame: unrecognized option ‘–first=yes’  
> ame: unrecognized option ‘–version=1’  
> ame: unrecognized option ‘–volume-op=start’  
> /var/lib/glusterd/hooks/1/start/post/S30samba-start.sh: line 105: [: =: unary operator expected  
> /var/lib/glusterd/hooks/1/start/post/S30samba-start.sh: line 55: smbd: command not found  
> Samba is not installed  
> ame: unrecognized option ‘–first=yes’  
> ame: unrecognized option ‘–version=1’  
> ame: unrecognized option ‘–volume-op=start’  
> clnt\_create: RPC: Timed out

**Convoy**

> Waiting for metadata.time=“2016-01-22T13:16:08Z” level=info msg=“Execing [/usr/bin/nsenter --mount=/proc/3492/ns/mnt -F – /home/docker/aufs/mnt/00dea216311c40112066634608a63262db25790ee34c2c309ae88ede1f15a22e/var/lib/rancher/convoy-agent/share-mnt --stage2 /var/lib/rancher/convoy/convoy-dc867a34-527e-4621-b276-41ac9c956975 – /launch volume-agent-glusterfs-internal]”  
> Registering convoy socket at /var/run/conoy-convoy.sock  
> time=“2016-01-22T13:16:08Z” level=info msg=“Listening for health checks on 0.0.0.0:10241/healthcheck”  
> time=“2016-01-22T13:16:08Z” level=info msg=“Got: driver-opts [glusterfs.defaultvolumepool=volume\_data glusterfs.servers=glusterfs]”  
> time=“2016-01-22T13:16:08Z” level=info msg=“Got: root /var/lib/rancher/convoy/convoy-dc867a34-527e-4621-b276-41ac9c956975”  
> time=“2016-01-22T13:16:08Z” level=info msg=“Got: drivers [glusterfs]”  
> time=“2016-01-22T13:16:08Z” level=info msg=“Launching convoy with args: [–socket=/host/var/run/conoy-convoy.sock daemon --driver-opts=glusterfs.defaultvolumepool=volume\_data --driver-opts=glusterfs.servers=glusterfs --root=/var/lib/rancher/convoy/convoy-dc867a34-527e-4621-b276-41ac9c956975 --drivers=glusterfs]”  
> time=“2016-01-22T13:16:08Z” level=debug msg=“Found existing config. Ignoring command line opts, loading config from /var/lib/rancher/convoy/convoy-dc867a34-527e-4621-b276-41ac9c956975” pkg=daemon  
> time=“2016-01-22T13:16:08Z” level=debug msg= driver=glusterfs driver\_opts=map[glusterfs.defaultvolumepool:volume\_data glusterfs.servers:glusterfs] event=init pkg=daemon reason=prepare root=“/var/lib/rancher/convoy/convoy-dc867a34-527e-4621-b276-41ac9c956975”  
> time=“2016-01-22T13:16:08Z” level=debug msg=“Umount existing mountpoint /var/lib/rancher/convoy/convoy-dc867a34-527e-4621-b276-41ac9c956975/glusterfs/mounts/volume\_data” pkg=util  
> time=“2016-01-22T13:16:08Z” level=debug msg=“Volume volume\_data is being mounted it to /var/lib/rancher/convoy/convoy-dc867a34-527e-4621-b276-41ac9c956975/glusterfs/mounts/volume\_data, with option [-t glusterfs]” pkg=util  
> time=“2016-01-22T13:16:09Z” level=error msg=“Get http:///host/var/run/conoy-convoy.sock/v1/volumes/list: dial unix /host/var/run/conoy-convoy.sock: connection refused”  
> time=“2016-01-22T13:16:10Z” level=error msg=“Get http:///host/var/run/conoy-convoy.sock/v1/volumes/list: dial unix /host/var/run/conoy-convoy.sock: connection refused”  
> time=“2016-01-22T13:16:11Z” level=debug msg= driver=glusterfs event=init pkg=daemon reason=complete  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering GET, /uuid” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering GET, /volumes/list” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering GET, /volumes/” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering GET, /snapshots/” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering GET, /backups/list” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering GET, /backups/inspect” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering GET, /info” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering POST, /volumes/create” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering POST, /volumes/mount” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering POST, /volumes/umount” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering POST, /snapshots/create” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering POST, /backups/create” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering DELETE, /volumes/” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering DELETE, /snapshots/” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering DELETE, /backups” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering plugin handler POST, /VolumeDriver.Create” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering plugin handler POST, /VolumeDriver.Remove” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering plugin handler POST, /VolumeDriver.Mount” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering plugin handler POST, /VolumeDriver.Unmount” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering plugin handler POST, /VolumeDriver.Path” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=debug msg=“Registering plugin handler POST, /Plugin.Activate” pkg=daemon  
> time=“2016-01-22T13:16:11Z” level=warning msg=“Remove previous sockfile at /host/var/run/conoy-convoy.sock” pkg=daemon

It’s normal getting this error ? **Get http:///host/var/run/conoy-convoy.sock/v1/volumes/list: dial unix /host/var/run/conoy-convoy.sock: connection refused**

---

<div class="post-metadata">

**Author:** ![cjellick](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/cjellick/32/2876_2.png) [@cjellick](https://forums.suse.com/u/cjellick)\
**Post date:** [January 25, 2016, 5:29pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/9 "2016-01-25T17:29:14Z")

</div>

@samouds is this forum topic the same as this github issue? [https://github.com/rancher/rancher/issues/3339](https://github.com/rancher/rancher/issues/3339)  
Or are they separate concerns?

If they’re the same, would you mind if we continued the convo in the github issue? Its easier to track.

---

<div class="post-metadata">

**Author:** ![samouds](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/samouds/32/658_2.png) [@samouds](https://forums.suse.com/u/samouds)\
**Post date:** [February 16, 2016, 4:41pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/10 "2016-02-16T16:41:14Z")

</div>

Yes of course, but i’m still stuck. and any help is very welcome 🙂

---

<div class="post-metadata">

**Author:** ![seb2411](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/seb2411/32/593_2.png) [@seb2411](https://forums.suse.com/u/seb2411)\
**Post date:** [February 17, 2016, 8:55am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/11 "2016-02-17T08:55:59Z")

</div>

I have my Gluster Cluster working now. So I have to test to add containers with volumes to see if it’s working. Do you have the convoy-gluster container active on all your hosts ?

---

<div class="post-metadata">

**Author:** ![samouds](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/samouds/32/658_2.png) [@samouds](https://forums.suse.com/u/samouds)\
**Post date:** [February 17, 2016, 9:55am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/12 "2016-02-17T09:55:10Z")

</div>

Yes.

 ![](https://us1.discourse-cdn.com/flex022/uploads/suse/original/1X/14671e921a8ff991c8f13f6ee34b6b2351453ab7.png)

---

<div class="post-metadata">

**Author:** ![seb2411](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/seb2411/32/593_2.png) [@seb2411](https://forums.suse.com/u/seb2411)\
**Post date:** [February 17, 2016, 10:10am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/13 "2016-02-17T10:10:25Z")

</div>

And is appearing on your storage pool ?  
I will try to test on mine later this week. And I give you my feedback.

---

<div class="post-metadata">

**Author:** ![ApolloDS](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/apollods/32/623_2.png) [@ApolloDS](https://forums.suse.com/u/ApolloDS)\
**Post date:** [February 17, 2016, 10:28am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/14 "2016-02-17T10:28:35Z")

</div>

Hi there,  
I would be very interested in performance of your glusterfs.  
So how fast can be a written file read again on the other hosts.

Thanks.

---

<div class="post-metadata">

**Author:** ![seb2411](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/seb2411/32/593_2.png) [@seb2411](https://forums.suse.com/u/seb2411)\
**Post date:** [February 17, 2016, 10:40am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/15 "2016-02-17T10:40:26Z")

</div>

Do you use some benchmark solution ? So we can compare ?

---

<div class="post-metadata">

**Author:** ![samouds](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/samouds/32/658_2.png) [@samouds](https://forums.suse.com/u/samouds)\
**Post date:** [February 17, 2016, 11:41am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/16 "2016-02-17T11:41:53Z")

</div>

Thanks @seb2411 !

Yes the volume appears in the storage pool and the problem still happens

---

<div class="post-metadata">

**Author:** ![ApolloDS](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/apollods/32/623_2.png) [@ApolloDS](https://forums.suse.com/u/ApolloDS)\
**Post date:** [February 17, 2016, 11:53am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/17 "2016-02-17T11:53:57Z")

</div>

Hi seb2411,  
What I always do is the following:

```
$ dd if=/dev/zero of=test.dd bs=1M count=1024
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 1.4717 s, 730 MB/s

```

Sorry, it was a host on SSD that’s why it is so fast.  
But in general you can see the throughput of storage very fast.

---

<div class="post-metadata">

**Author:** ![seb2411](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/seb2411/32/593_2.png) [@seb2411](https://forums.suse.com/u/seb2411)\
**Post date:** [February 17, 2016, 12:02pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/18 "2016-02-17T12:02:41Z")

</div>

@ApolloDS ok, I will try this command.

---

<div class="post-metadata">

**Author:** ![ApolloDS](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/apollods/32/623_2.png) [@ApolloDS](https://forums.suse.com/u/ApolloDS)\
**Post date:** [February 17, 2016, 12:31pm UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/19 "2016-02-17T12:31:57Z")

</div>

@seb2411, just to be sure, don’t forget to delete test.dd after testing!  
Otherwise you will have a big not used file lying around on your filesystem.

---

<div class="post-metadata">

**Author:** ![seb2411](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/seb2411/32/593_2.png) [@seb2411](https://forums.suse.com/u/seb2411)\
**Post date:** [February 18, 2016, 7:06am UTC](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254/20 "2016-02-18T07:06:04Z")

</div>

@samouds I was thinking about your Mysql problem. Did you try with Mysql 5.5 image. instead of the lastest ? I remember having a similar problem on my PC with a project on Docker. It was working perfectly with Mysql 5.5 but having similar troubles with the 5.6.

[Next page](https://forums.suse.com/t/convoy-gluster-on-specific-storage-hosts/1254.md?page=2)
