# Disabling external authentication

**URL:** <https://forums.suse.com/t/disabling-external-authentication/12932>\
**Category:** SUSE Rancher Prime\
**Created:** [January 9, 2019, 11:55am UTC](https://forums.suse.com/t/disabling-external-authentication/12932 "2019-01-09T11:55:26Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ross\_Golder](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/ross_golder/32/4369_2.png) [@Ross\_Golder](https://forums.suse.com/u/Ross_Golder)\
**Post date:** [January 9, 2019, 11:55am UTC](https://forums.suse.com/t/disabling-external-authentication/12932/1 "2019-01-09T11:55:26Z")

</div>

We have Rancher2 configured to use OpenLDAP auth. Our LDAP server seems to be available to other applications as normal, but our Rancher2 instance has started giving us ‘Server error while authenticating’ when logging in.

How can we further debug the cause of the error, or disable external authentication and manage local users to regain admin access?

–  
Ross

---

<div class="post-metadata">

**Author:** ![Ross\_Golder](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/ross_golder/32/4369_2.png) [@Ross\_Golder](https://forums.suse.com/u/Ross_Golder)\
**Post date:** [January 10, 2019, 1:08pm UTC](https://forums.suse.com/t/disabling-external-authentication/12932/2 "2019-01-10T13:08:54Z")

</div>

I used this to enable debug logging for the Rancher container.

[https://rancher.com/docs/rancher/v2.x/en/faq/technical/#how-can-i-enable-debug-logging](https://rancher.com/docs/rancher/v2.x/en/faq/technical/#how-can-i-enable-debug-logging)

Now I see more information about the authentication failure.

In the end, it turned I was authenticating successfully as far as the back-end logs were concerned, but something in the JS UI was directing me back to the login page with the error. I cleared my cookies and local storage and things started working as usual again.

–  
Ross

---

<div class="post-metadata">

**Author:** ![rossigee](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/rossigee/32/1352_2.png) [@rossigee](https://forums.suse.com/u/rossigee)\
**Post date:** [November 22, 2019, 2:14am UTC](https://forums.suse.com/t/disabling-external-authentication/12932/3 "2019-11-22T02:14:27Z")

</div>

FTR, I still get this regularly, and it seems that this is related to the ‘backTo’ localStorage entry, which somehow gets set to ‘…login?errorMsg=unknown’. So it logs in successfully, but then redirects the user back to the login page (even though they are logged in).

I’ve filed a bug report about it here:

> <https://github.com/rancher/rancher/issues/24197>
>
> What kind of request is this (question/bug/enhancement/feature request):
> bug
> Steps to reproduce (least amount of steps as possible):
> This happens often, but so far...

–  
Ross

---

<div class="post-metadata">

**Author:** ![occasl](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/occasl/32/2168_2.png) [@occasl](https://forums.suse.com/u/occasl)\
**Post date:** [April 22, 2021, 6:14am UTC](https://forums.suse.com/t/disabling-external-authentication/12932/4 "2021-04-22T06:14:34Z")

</div>

I have the same exact issue after a fresh install. Any ideas?
