# Docker error on OS SUSE Linux Enterprise Server 15 SP3

**URL:** <https://forums.suse.com/t/docker-error-on-os-suse-linux-enterprise-server-15-sp3/40369>\
**Category:** SLES Virtualization\
**Created:** [March 28, 2023, 10:46am UTC](https://forums.suse.com/t/docker-error-on-os-suse-linux-enterprise-server-15-sp3/40369 "2023-03-28T10:46:07Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Aditi\_Dukle](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/aditi_dukle/32/10010_2.png) [@Aditi\_Dukle](https://forums.suse.com/u/Aditi_Dukle)\
**Post date:** [March 28, 2023, 10:46am UTC](https://forums.suse.com/t/docker-error-on-os-suse-linux-enterprise-server-15-sp3/40369/1 "2023-03-28T10:46:07Z")

</div>

We have installed docker version **20.10.23-ce** on our **OS SUSE Linux Enterprise Server 15 SP3, arch -x86\_64.** And we are seeing the following issue intermittently when trying to cleanup all the docker containers using “docker ps -aq | xargs docker rm --force” and creating the new containers again.  
Error message:

> ERROR: for auth-service Cannot start service auth: unable to remount dir as readonly: mount tmpfs:/var/lib/docker/containers/727c809d75d8535efd27be0f943e4ffde527ce6d08a92192dc0081c123d8c9a2/mounts/secrets, flags: 0x21, data: uid=0,gid=0: device or resource busy

Also this error message can be seen in docker daemon logs:

> level=error msg=“727c809d75d8535efd27be0f943e4ffde527ce6d08a92192dc0081c123d8c9a2 cleanup: failed to delete container from containerd: no such container”

We also observed that after cleanup of docker containers, no containers can be seen when we run command “docker ps -a”. Also the /var/lib/docker/containers directory is empty. But still we see the mount issue sometimes when trying to recreate containers.
