# Docker-machine starting server

**URL:** <https://forums.suse.com/t/docker-machine-starting-server/7682>\
**Category:** General\
**Created:** [October 30, 2017, 12:30pm UTC](https://forums.suse.com/t/docker-machine-starting-server/7682 "2017-10-30T12:30:00Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![mastermindg](https://avatars.discourse-cdn.com/v4/letter/m/bbe5ce/32.png) [@mastermindg](https://forums.suse.com/u/mastermindg)\
**Post date:** [October 30, 2017, 12:30pm UTC](https://forums.suse.com/t/docker-machine-starting-server/7682/1 "2017-10-30T12:30:00Z")

</div>

I just created a new docker-machine instance running on VirtualBox on Centos 7. Initially I started rancher-server via docker daemon but then saw that there was an available system service. I enabled it and attempted to start it and got this:

ERRO[0000] non-200 http response: 404  
ERRO[0000] Failed to load service(kvm-vm-tools): non-200 http response: 404  
No such service: rancher-server-stable

I didn’t enable or start kvm-vm-tools on this machine. What’s the best way for me to run rancher-server in docker-machine?
