# Error message after removing shutdown node from Rancher2 Cluster

**URL:** <https://forums.suse.com/t/error-message-after-removing-shutdown-node-from-rancher2-cluster/14297>\
**Category:** SUSE Rancher Prime\
**Created:** [May 17, 2019, 9:40am UTC](https://forums.suse.com/t/error-message-after-removing-shutdown-node-from-rancher2-cluster/14297 "2019-05-17T09:40:10Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dan\_Coleman](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/dan_coleman/32/4944_2.png) [@Dan\_Coleman](https://forums.suse.com/u/Dan_Coleman)\
**Post date:** [May 17, 2019, 9:40am UTC](https://forums.suse.com/t/error-message-after-removing-shutdown-node-from-rancher2-cluster/14297/1 "2019-05-17T09:40:10Z")

</div>

Hi, I have a Rancher2.0 k8s cluster (on premise) running and I had drained and shut down one of my 6 nodes.  
I then deleted this node from Rancher (I realise now I should’ve deleted it from Rancher before shutting it down).

The node6 no longer shows in the list of nodes but the following error has been cycling for at least an hour:

This cluster is currently **Updating**.

Failed to delete controlplane node [172.16.1.86] from cluster: Get [https://172.16.1.83:6443/api/v1/nodes?timeout=30s:](https://172.16.1.83:6443/api/v1/nodes?timeout=30s:) can not build dialer to c-hkgb9:m-2bfec108efe4

I have started the machine back up in the hope that Rancher will perform the cleanup but am unable to get the error to stop.
