# Error messages during salt state.apply

**URL:** https://forums.suse.com/t/error-messages-during-salt-state-apply/32069
**Category:** SUSE Multi Linux Manager
**Created:** [February 26, 2018, 3:15pm UTC](https://forums.suse.com/t/error-messages-during-salt-state-apply/32069 "2018-02-26T15:15:05Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Jochen](https://avatars.discourse-cdn.com/v4/letter/j/91b2a8/32.png) [@Jochen](https://forums.suse.com/u/Jochen)
#### Post date: [February 26, 2018, 3:15pm UTC](https://forums.suse.com/t/error-messages-during-salt-state-apply/32069/1 "2018-02-26T15:15:05Z")

</div>

I’m not experienced with salt on suse manager. I noticed this on a sles11-sp4 system after registering it to suse-manager as salt-minion when I execute a ‘salt-call state.apply’

1. what does it mean?
2. any chance to fix this? Where to look for?

The system seems to be good - all repositorys from suse manager are online and available.

Here’s the code

# salt-call state.apply

[ERROR] State ‘service.dead’ was not found in SLS ‘bootstrap.remove\_traditional\_stack’  
Reason: ‘service’ **virtual** returned False: No service execution module loaded: check support for service management on SLES-11

[ERROR] State ‘service.dead’ was not found in SLS ‘bootstrap.remove\_traditional\_stack’  
Reason: ‘service’ **virtual** returned False: No service execution module loaded: check support for service management on SLES-11

[ERROR] State ‘service.dead’ was not found in SLS ‘bootstrap.remove\_traditional\_stack’  
Reason: ‘service’ **virtual** returned False: No service execution module loaded: check support for service management on SLES-11

[ERROR] State ‘service.running’ was not found in SLS ‘services.salt-minion’  
Reason: ‘service’ **virtual** returned False: No service execution module loaded: check support for service management on SLES-11

## local:

```
      ID: mgrchannels_repo
Function: file.managed
    Name: /etc/zypp/repos.d/susemanager:channels.repo
  Result: True
 Comment: File /etc/zypp/repos.d/susemanager:channels.repo is in the correct state
 Started: 14:01:24.965882
Duration: 82.164 ms
 Changes:

```

## [COLOR=“#FF0000”]---------- ID: disable\_spacewalksd Function: service.dead Name: rhnsd Result: False Comment: State ‘service.dead’ was not found in SLS ‘bootstrap.remove\_traditional\_stack’ Reason: ‘service’ **virtual** returned False: No service execution module loaded: check support for service management on SLES-11 Changes:

```
      ID: disable_spacewalk-update-status
Function: service.dead
    Name: spacewalk-update-status
  Result: False
 Comment: State 'service.dead' was not found in SLS 'bootstrap.remove_traditional_stack'
          Reason: 'service' __virtual__ returned False: No service execution module loaded: check support for service management on SLES-11
 Changes:

```

* * *

```
      ID: disable_osad
Function: service.dead
    Name: osad
  Result: False
 Comment: State 'service.dead' was not found in SLS 'bootstrap.remove_traditional_stack'
          Reason: 'service' __virtual__ returned False: No service execution module loaded: check support for service management on SLES-11
 Changes:[/COLOR]

```

## [COLOR=“#00FF00”]---------- ID: remove\_traditional\_stack Function: pkg.removed Result: True Comment: All specified packages are already absent Started: 14:01:25.818665 Duration: 891.037 ms Changes:

```
      ID: mgr_mine_config
Function: file.managed
    Name: /etc/salt/minion.d/susemanager-mine.conf
  Result: True
 Comment: File /etc/salt/minion.d/susemanager-mine.conf is in the correct state
 Started: 14:01:26.710214
Duration: 2.66 ms
 Changes:

```

* * *

```
      ID: /etc/ssl/certs/RHN-ORG-TRUSTED-SSL-CERT.pem
Function: file.managed
  Result: True
 Comment: File /etc/ssl/certs/RHN-ORG-TRUSTED-SSL-CERT.pem is in the correct state
 Started: 14:01:26.713232
Duration: 35.335 ms
 Changes:

```

* * *

```
      ID: salt://certs/update-multi-cert.sh
Function: cmd.wait_script
  Result: True
 Comment:
 Started: 14:01:26.750182
Duration: 0.993 ms
 Changes:

```

* * *

```
      ID: c_rehash
Function: cmd.run
    Name: /usr/bin/c_rehash
  Result: True
 Comment: State was not run because none of the onchanges reqs changed
 Changes:

```

* * *

```
      ID: mgr_do_nothing
Function: test.nop
  Result: True
 Comment: Success!
 Started: 14:01:26.752250
Duration: 0.606 ms
 Changes:

```

* * *

```
      ID: pkg_installed
Function: pkg.installed
  Result: True
 Comment: No packages to install provided
 Started: 14:01:26.774890
Duration: 1.419 ms
 Changes:

```

* * *

```
      ID: pkg_removed
Function: pkg.removed
  Result: True
 Comment: All specified packages are already absent
 Started: 14:01:26.776860
Duration: 58.555 ms
 Changes:

```

* * *

```
      ID: pkg_latest
Function: pkg.latest
  Result: True
 Comment: No packages to install provided
 Started: 14:01:26.836017
Duration: 0.816 ms
 Changes:[/COLOR]

```

[COLOR=“#00FF00”][COLOR=“#FF0000”]----------  
ID: mgr\_salt\_minion  
Function: pkg.installed  
Name: salt-minion  
Result: True  
Comment: Package salt-minion is already installed  
Started: 14:01:26.837083  
Duration: 70.44 ms  
Changes:[/COLOR][/COLOR]  
[COLOR=“#FF0000”]----------  
ID: mgr\_salt\_minion  
Function: service.running  
Name: salt-minion  
Result: False  
Comment: State ‘service.running’ was not found in SLS ‘services.salt-minion’  
Reason: ‘service’ **virtual** returned False: No service execution module loaded: check support for service management on SLES-11  
Changes:[/COLOR]

[COLOR=“#00FFFF”]Summary for local  
-------------[/COLOR]  
[COLOR=“#00FF00”]Succeeded: 11[/COLOR]  
[COLOR=“#FF0000”]Failed: 4[/COLOR]  
[COLOR=“#00FFFF”]-------------  
Total states run: 15  
Total run time: 1.144 s[/COLOR][/QUOTE]

---

<div class="post-metadata">

### Author: ![kwk](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/kwk/32/11997_2.png) [@kwk](https://forums.suse.com/u/kwk)
#### Post date: [February 27, 2018, 8:39am UTC](https://forums.suse.com/t/error-messages-during-salt-state-apply/32069/2 "2018-02-27T08:39:49Z")

</div>

SLES 11 is still based on sysv-init for OS services and not systemctl like SLE12 and later. Looks like Salt does not full support this.

If you think this is a bug, please open a support request and provide the client’s “supportconfig”.

---

<div class="post-metadata">

### Author: ![timstein](https://avatars.discourse-cdn.com/v4/letter/t/96bed5/32.png) [@timstein](https://forums.suse.com/u/timstein)
#### Post date: [March 7, 2018, 3:39pm UTC](https://forums.suse.com/t/error-messages-during-salt-state-apply/32069/3 "2018-03-07T15:39:31Z")

</div>

We had this problem with SLES 11 and SLES 12 Minions last year. After opening a SR it turned out to be a bug. There should be fixed versions in the channel. Therefore patching SUSE Manger and the Minions might solve your issue.

---

<div class="post-metadata">

### Author: ![matthiashinrichs](https://avatars.discourse-cdn.com/v4/letter/m/a88e57/32.png) [@matthiashinrichs](https://forums.suse.com/u/matthiashinrichs)
#### Post date: [March 20, 2018, 8:04pm UTC](https://forums.suse.com/t/error-messages-during-salt-state-apply/32069/4 "2018-03-20T20:04:40Z")

</div>

Hello,

since yesterday after patching to the latest version of salt I am experiencing the same problem. But only on SLES\_SAP-12 machines.

---

<div class="post-metadata">

### Author: ![timstein](https://avatars.discourse-cdn.com/v4/letter/t/96bed5/32.png) [@timstein](https://forums.suse.com/u/timstein)
#### Post date: [March 27, 2018, 3:39pm UTC](https://forums.suse.com/t/error-messages-during-salt-state-apply/32069/5 "2018-03-27T15:39:34Z")

</div>

I suggest opening a service request with SUSE.
