# Error setting permissions for configuration management

**URL:** https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413
**Category:** SUSE Multi Linux Manager
**Created:** [November 24, 2014, 10:15pm UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413 "2014-11-24T22:15:19Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![testacct010171](https://avatars.discourse-cdn.com/v4/letter/t/7993a0/32.png) [@testacct010171](https://forums.suse.com/u/testacct010171)
#### Post date: [November 24, 2014, 10:15pm UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/1 "2014-11-24T22:15:19Z")

</div>

Hello,

this sles11sp3(client) box is registered with SUSE Manager. I then try to schedule a Reboot at 12:30 AM, now its 01:11, but reboot is still pending. Sles11sp3 is not registered with Novell Customer center, but I have registered this machine with SUSE Manager:

> [@](#):
>
> running “curl -Sks [http://susemgr/pub/bootstrap/bootstrap.sles11sp3.sh](http://susemgr/pub/bootstrap/bootstrap.sles11sp3.sh) |/bin/bash” worked on one of SLES 11 SP 3 box, but with following error:
> 
> ## UPDATING RHN\_REGISTER/UP2DATE CONFIGURATION FILES
> 
> - downloading necessary files  
> client\_config\_update.py…  
> 2014-11-24 13:42:18 URL:[http://susemgr.nds.pk/pub/bootstrap/client\_config\_update.py](http://susemgr.nds.pk/pub/bootstrap/client_config_update.py) [6481/6481] → “client\_config\_update.py” [1]  
> FINISHED --2014-11-24 13:42:18–  
> Downloaded: 1 files, 6.3K in 0s (12072 GB/s)  
> client-config-overrides.txt…  
> 2014-11-24 13:42:18 URL:[http://susemgr.nds.pk/pub/bootstrap/client-config-overrides.txt](http://susemgr.nds.pk/pub/bootstrap/client-config-overrides.txt) [616/616] → “client-config-overrides.txt” [1]  
> FINISHED --2014-11-24 13:42:18–  
> Downloaded: 1 files, 616 in 0s (1147 GB/s)
> 
> ## PREPARE GPG KEYS AND CORPORATE PUBLIC CA CERT
> 
> - no organizational GPG keys to import
> 
> - configured not to use SSL: don’t install corporate public CA cert
> 
> ## CHECKING THE REGISTRATION STACK
> 
> - check for necessary packages being installed…
> - client codebase is sle-11-sp3  
> package spacewalk-check is not installed  
> package spacewalk-client-setup is not installed  
> package spacewalk-client-tools is not installed  
> package zypp-plugin-spacewalk is not installed
> - going to install missing packages…  
> WARNING: cannot verify susemgr.nds.pk’s certificate, issued by `/C=PK/ST=Sindh/L=KHI/O=NDS/OU=IT/CN=susemgr.nds.pk’:  
> Unable to locally verify the issuer’s authority.  
> [https://susemgr.nds.pk/pub/repositories/sle/11/3/bootstrap/repodata/repomd.xml:](https://susemgr.nds.pk/pub/repositories/sle/11/3/bootstrap/repodata/repomd.xml:)  
> 2014-11-24 13:42:18 ERROR 404: Not Found.  
> Bootstrap repo ‘[https://susemgr.nds.pk/pub/repositories/sle/11/3/bootstrap](https://susemgr.nds.pk/pub/repositories/sle/11/3/bootstrap)’ does not exist.  
> Loading repository data…  
> Reading installed packages…  
> Resolving package dependencies…
> 
> The following NEW packages are going to be installed:  
> libnewt0\_52 newt python-dmidecode python-ethtool python-newt python-openssl rhnlib slang spacewalk-check spacewalk-client-setup spacewalk-client-tools spacewalksd  
> suseRegisterInfo zypp-plugin-python zypp-plugin-spacewalk
> 
> 15 new packages to install.  
> Overall download size: 1.2 MiB. After the operation, additional 5.3 MiB will be used.  
> Continue? [y/n/?] (y): y  
> .  
> .  
> Installing: python-dmidecode-3.10.11-0.8.43 [done]  
> Installing: python-ethtool-0.7-0.15.15.1 [done]  
> Installing: python-openssl-0.7.0-1.17.2 [done]  
> Installing: slang-2.1.1-58.18 [done]  
> Installing: suseRegisterInfo-1.7.4-0.5.1 [done]  
> Installing: zypp-plugin-python-0.3-2.5.38 [done]  
> Installing: rhnlib-2.5.51.3-0.7.10 [done]  
> Installing: libnewt0\_52-0.52.10-1.35.113 [done]  
> Installing: newt-0.52.10-1.35.113 [done]  
> Installing: python-newt-0.52.10-1.35.113 [done]  
> Installing: spacewalk-client-tools-1.7.14.15-0.5.1 [done]  
> Installing: zypp-plugin-spacewalk-0.9.1-0.7.1 [done]  
> Installing: spacewalk-check-1.7.14.15-0.5.1 [done]  
> Installing: spacewalksd-4.9.15.3-0.5.3 [done]  
> Installing: spacewalk-client-setup-1.7.14.15-0.5.1 [done]
> 
> - running the update scripts  
> . up2date config file
> - /etc/sysconfig/rhn/up2date written
> 
> ## REGISTRATION
> 
> - registering
> 
> \*\*\* this system should now be registered, please verify \*\*\*
> 
> - setting permissions to allow configuration management  
> NOTE: use an activation key to subscribe to the tools  
> channel and zypper install/update rhncfg-actions  
> Error setting permissions for configuration management.  
> Please ensure that the activation key subscribes the  
> system to the tools channel and zypper install/update rhncfg-actions.

Also running “zypper update” on the sles11sp3 box(suse mgr client) returns:

> [@](#):
>
> Refreshing service ‘spacewalk’.  
> Problem retrieving the repository index file for service ‘spacewalk’:  
> [|] This system may not be updated until it is associated with a channel.
> 
> Skipping service ‘spacewalk’ because of the above error.  
> Loading repository data…  
> Reading installed packages…
> 
> Nothing to do.

Running “mgr-ncc-sync -l” on SUSE Mgr returns:

> [@](#):
>
> mgr-ncc-sync -l  
> Listing channels …
> 
> Status:
> 
> - P - channel is installed (provided)
> - . - channel is not installed, but is available
> - X - channel is not available
> 
> [P] suse-manager-server-2.1-pool-x86\_64  
> [P] sle11-sp3-debuginfo-pool-x86\_64-server-2.1  
> [P] sle11-sp3-debuginfo-updates-x86\_64-server-2.1  
> [P] sles11-sp3-pool-x86\_64-server-2.1  
> [P] sles11-sp3-updates-x86\_64-server-2.1  
> [P] suse-manager-server-2.1-updates-x86\_64

---

<div class="post-metadata">

### Author: ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)
#### Post date: [November 24, 2014, 10:33pm UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/2 "2014-11-24T22:33:23Z")

</div>

Hi  
You have to click on the system in question (in the system overview), then Software → Software channels and check they ones you originally configured for the channel are present and selected.

It sounds like you did not configure the primary channel and sub channels linked to it to get all your wanting?

---

<div class="post-metadata">

### Author: ![testacct010171](https://avatars.discourse-cdn.com/v4/letter/t/7993a0/32.png) [@testacct010171](https://forums.suse.com/u/testacct010171)
#### Post date: [November 24, 2014, 10:47pm UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/3 "2014-11-24T22:47:52Z")

</div>

[color=blue]

> You have to click on the system in question (in the system overview), then Software → Software channels and check they ones you originally configured for the channel are present and selected.  
> [/color]  
> under Base Software Channels, there is a Selection Box that has only one entry as [quote]  
> (none, disable service)[/quote]

[color=blue]

> It sounds like you did not configure the primary channel and sub channels linked to it to get all your wanting?  
> [/color]  
> please guide

---

<div class="post-metadata">

### Author: ![testacct010171](https://avatars.discourse-cdn.com/v4/letter/t/7993a0/32.png) [@testacct010171](https://forums.suse.com/u/testacct010171)
#### Post date: [November 24, 2014, 10:53pm UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/4 "2014-11-24T22:53:31Z")

</div>

please note that this suse\_mgr client machine was never registered with Novell Customer Center

---

<div class="post-metadata">

### Author: ![testacct010171](https://avatars.discourse-cdn.com/v4/letter/t/7993a0/32.png) [@testacct010171](https://forums.suse.com/u/testacct010171)
#### Post date: [November 24, 2014, 11:08pm UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/5 "2014-11-24T23:08:53Z")

</div>

on this sles 11 sp3 machine(suse mgr client), running “rhn-channel -l” returns

[quote]  
This system is not associated with any channel.[/quote]

while on the same system running the “rhn-channel -u admin -p password -L” returns nothing… means gives the prompt back without any output

---

<div class="post-metadata">

### Author: ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)
#### Post date: [November 25, 2014, 1:45am UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/6 "2014-11-25T01:45:56Z")

</div>

> [@](#):
>
> On Mon 24 Nov 2014 08:54:02 PM CST, testacct010171 wrote:
> 
> please note that this suse\_mgr client machine was never registered with  
> Novell Customer Center

Hi  
AFAIK, you need to have registered the SUSE Manager instance, I think  
at this point your in limbo in the move from SLE 11 to SLE 12 and well  
as the shift between NCC and SCC. SUSE Manager is not yet ready for SCC  
I believe an update is due soon…

Since you haven’t activated SUSE Manager, the 60 day evaluation period  
doesn’t start until then.

I have some lab notes from last years SUSECon, I need to check if I can  
share them.

–  
Cheers Malcolm Â°Â¿Â° LFCS, SUSE Knowledge Partner (Linux Counter #276890)  
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default  
If you find this post helpful and are logged into the web interface,  
please show your appreciation and click on the star below… Thanks!

---

<div class="post-metadata">

### Author: ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)
#### Post date: [November 25, 2014, 5:35am UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/7 "2014-11-25T05:35:44Z")

</div>

> [@](#):
>
> On Mon 24 Nov 2014 11:45:56 PM CST, malcolmlewis wrote:
> 
> > [@](#):
> >
> > On Mon 24 Nov 2014 08:54:02 PM CST, testacct010171 wrote:
> > 
> > please note that this suse\_mgr client machine was never registered with  
> > Novell Customer Center
> 
> Hi  
> AFAIK, you need to have registered the SUSE Manager instance, I think  
> at this point your in limbo in the move from SLE 11 to SLE 12 and well  
> as the shift between NCC and SCC. SUSE Manager is not yet ready for SCC  
> I believe an update is due soon…
> 
> Since you haven’t activated SUSE Manager, the 60 day evaluation period  
> doesn’t start until then.
> 
> I have some lab notes from last years SUSECon, I need to check if I can  
> share them.

Hi  
There is some info here [TT1636];  
[http://www.susecon.com/archive.html](http://www.susecon.com/archive.html)

Still waiting to hear about lab notes…

–  
Cheers Malcolm Â°Â¿Â° LFCS, SUSE Knowledge Partner (Linux Counter #276890)  
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default  
If you find this post helpful and are logged into the web interface,  
please show your appreciation and click on the star below… Thanks!

---

<div class="post-metadata">

### Author: ![kwk](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/kwk/32/11997_2.png) [@kwk](https://forums.suse.com/u/kwk)
#### Post date: [November 25, 2014, 11:53am UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/8 "2014-11-25T11:53:46Z")

</div>

It seems as if the manager-tools channel for sles11-sp3 is not synced and assigned to the client.

---

<div class="post-metadata">

### Author: ![sharfuddin](https://avatars.discourse-cdn.com/v4/letter/s/e274bd/32.png) [@sharfuddin](https://forums.suse.com/u/sharfuddin)
#### Post date: [December 8, 2014, 1:27pm UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/9 "2014-12-08T13:27:02Z")

</div>

> [@kwk;25080](#):
>
> It seems as if the manager-tools channel for sles11-sp3 is not synced and assigned to the client.

How can I do this ?

---

<div class="post-metadata">

### Author: ![kwk](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/kwk/32/11997_2.png) [@kwk](https://forums.suse.com/u/kwk)
#### Post date: [December 9, 2014, 9:49am UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/10 "2014-12-09T09:49:48Z")

</div>

Select the client in the UI, then choose ‘Alter Channel Subscriptions’ in the ‘Subscribed Channel’ panel on the lower left side. The choose the manager-tools channel.

---

<div class="post-metadata">

### Author: ![sharfuddin](https://avatars.discourse-cdn.com/v4/letter/s/e274bd/32.png) [@sharfuddin](https://forums.suse.com/u/sharfuddin)
#### Post date: [December 9, 2014, 12:33pm UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/11 "2014-12-09T12:33:11Z")

</div>

> [@](#):
>
> Select the client in the UI, then choose ‘Alter Channel Subscriptions’ in the ‘Subscribed Channel’ panel on the lower left side. The choose the manager-tools channel.

I dont find the manager-tools channels and only see the following channels:  
SUSE-Manager-Server-2.1-Pool for x86\_64  
SLE11-SP3-Debuginfo-Pool for x86\_64 Server 2.1  
SLE11-SP3-Debuginfo-Updates for x86\_64 Server 2.1  
SLES11-SP3-Pool for x86\_64 Server 2.1  
SLES11-SP3-Updates for x86\_64 Server 2.1  
SUSE-Manager-Server-2.1-Updates for x86\_64

on SUSE Manager running “mgr-ncc-sync -l” returns following

susemgr:~ # mgr-ncc-sync -l  
Listing channels …  
Status:

- P - channel is installed (provided)
- . - channel is not installed, but is available
- X - channel is not available  
[.] suse-manager-server-2.1-pool-s390x  
[P] suse-manager-server-2.1-pool-x86\_64  
[P] sle11-sp3-debuginfo-pool-x86\_64-server-2.1  
[P] sle11-sp3-debuginfo-updates-x86\_64-server-2.1  
[P] sles11-sp3-pool-x86\_64-server-2.1  
[P] sles11-sp3-updates-x86\_64-server-2.1  
[P] suse-manager-server-2.1-updates-x86\_64  
susemgr:~ #

---

<div class="post-metadata">

### Author: ![kwk](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/kwk/32/11997_2.png) [@kwk](https://forums.suse.com/u/kwk)
#### Post date: [December 10, 2014, 10:24am UTC](https://forums.suse.com/t/error-setting-permissions-for-configuration-management/26413/12 "2014-12-10T10:24:50Z")

</div>

The manager-tools channel is part of the client channels, not the SUSE Manager Server channels. Above list only shows the server channels, not the client channels. Did you enter correct oranization (mirror) credentials in the setup wizard ?
