# Errors after changing registration IP, and back

**URL:** <https://forums.suse.com/t/errors-after-changing-registration-ip-and-back/613>\
**Category:** Rancher 1.x\
**Created:** [October 2, 2015, 1:55pm UTC](https://forums.suse.com/t/errors-after-changing-registration-ip-and-back/613 "2015-10-02T13:55:43Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![sdlarsen](https://avatars.discourse-cdn.com/v4/letter/s/f14d63/32.png) [@sdlarsen](https://forums.suse.com/u/sdlarsen)\
**Post date:** [October 2, 2015, 1:55pm UTC](https://forums.suse.com/t/errors-after-changing-registration-ip-and-back/613/1 "2015-10-02T13:55:43Z")

</div>

Hi.

Another possible connectivity problem? I have changed the registration IP to that of a load balancer (AWS), but reverted to the elastic IP of the rancher again.  
Now, on my hosts I can no longer see the CPU, Memory etc. information. I cannot get to any logs and cannot start a console.

There’s nothing in the ranger-agent logs. On the rancher master i see:

```
time="2015-10-02T13:50:14Z" level=error msg="Error during upgrade: [websocket: could not find connection header with token 'upgrade']" 
2015/10/02 13:50:14 http: multiple response.WriteHeader calls

```

When trying to view logs, and a pair of the multiple response.WriteHeader calls when viewing a host.

I did try to remove the agent on a host and re-register it to no avail. Adding a new host works, but it suffers from the same issue.

So… did I change anything else? Possibly, as I’ve tried all I could think of to make this work…

Where should I look?

---

<div class="post-metadata">

**Author:** ![sdlarsen](https://avatars.discourse-cdn.com/v4/letter/s/f14d63/32.png) [@sdlarsen](https://forums.suse.com/u/sdlarsen)\
**Post date:** [October 5, 2015, 8:40am UTC](https://forums.suse.com/t/errors-after-changing-registration-ip-and-back/613/2 "2015-10-05T08:40:31Z")

</div>

Hmm. Updating to v40 solved it…

---

<div class="post-metadata">

**Author:** ![denise](https://avatars.discourse-cdn.com/v4/letter/d/82dd89/32.png) [@denise](https://forums.suse.com/u/denise)\
**Post date:** [October 6, 2015, 6:32pm UTC](https://forums.suse.com/t/errors-after-changing-registration-ip-and-back/613/3 "2015-10-06T18:32:47Z")

</div>

I’m glad updating helped, but for future reference, we did add some more detailed troubleshooting items. Like how to check that host registration is setup okay.

[http://docs.rancher.com/rancher/faqs/troubleshooting/](http://docs.rancher.com/rancher/faqs/troubleshooting/)

---

<div class="post-metadata">

**Author:** ![cumpsd](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/cumpsd/32/883_2.png) [@cumpsd](https://forums.suse.com/u/cumpsd)\
**Post date:** [March 23, 2016, 10:13am UTC](https://forums.suse.com/t/errors-after-changing-registration-ip-and-back/613/4 "2016-03-23T10:13:51Z")

</div>

The documentation lists this:

`sudo docker run -d -e CATTLE_AGENT_IP=<HOST_IP> --privileged \ -v /var/run/docker.sock:/var/run/docker.sock \ rancher/agent:v0.8.2 http://SERVER_IP:8080/v1/scripts/xxxx`

However, I am trying to figure out what to put for `xxxx` since I didnt save the original registration url.

Is there a place I can retrieve it?

---

<div class="post-metadata">

**Author:** ![denise](https://avatars.discourse-cdn.com/v4/letter/d/82dd89/32.png) [@denise](https://forums.suse.com/u/denise)\
**Post date:** [March 23, 2016, 5:50pm UTC](https://forums.suse.com/t/errors-after-changing-registration-ip-and-back/613/5 "2016-03-23T17:50:26Z")

</div>

If you click on “Add Host”, under the “Custom” option, it always shows what the docker run command would be to launch rancher/agent.
