# Existent persistent volume not found by the container

**URL:** <https://forums.suse.com/t/existent-persistent-volume-not-found-by-the-container/36994>\
**Category:** SUSE Rancher Prime\
**Created:** [February 15, 2022, 4:15pm UTC](https://forums.suse.com/t/existent-persistent-volume-not-found-by-the-container/36994 "2022-02-15T16:15:28Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ioclaudio](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/ioclaudio/32/8828_2.png) [@ioclaudio](https://forums.suse.com/u/ioclaudio)\
**Post date:** [February 15, 2022, 4:15pm UTC](https://forums.suse.com/t/existent-persistent-volume-not-found-by-the-container/36994/1 "2022-02-15T16:15:28Z")

</div>

Hi,  
I’ve a new namespace in which I’ve launched an Helm app that creates some volumes and some containers.  
The containers fail to start with this message:

```auto
Warning	FailedAttachVolume	AttachVolume.Attach failed for volume "library-site-test-mariadb-data" : rpc error: code = NotFound desc = ControllerPublishVolume: the volume library-site-test-mariadb-data not exists	a few seconds ago
Warning	FailedMount	Unable to attach or mount volumes: unmounted volumes=[mariadb-data], unattached volumes=[mariadb-data default-token-fmd87]: timed out waiting for the condition

```

But in the volumes section of this namespace the volume exists.  
Which could be the problem?  
How can I debug this problem?

I’m using Rancher 2.5.6 and Longhorn.

Thank you very much

Claudio

---

<div class="post-metadata">

**Author:** ![ioclaudio](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/ioclaudio/32/8828_2.png) [@ioclaudio](https://forums.suse.com/u/ioclaudio)\
**Post date:** [February 16, 2022, 2:23pm UTC](https://forums.suse.com/t/existent-persistent-volume-not-found-by-the-container/36994/2 "2022-02-16T14:23:07Z")

</div>

I’ve seen that the Helm chart creates the volume on Rancher but not on Longhorn.  
So this is why I have that error.  
I still don’t know why the helm chart doesn’t create the volume on Longhorn.

---

<div class="post-metadata">

**Author:** ![ioclaudio](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/ioclaudio/32/8828_2.png) [@ioclaudio](https://forums.suse.com/u/ioclaudio)\
**Post date:** [February 18, 2022, 8:19am UTC](https://forums.suse.com/t/existent-persistent-volume-not-found-by-the-container/36994/3 "2022-02-18T08:19:31Z")

</div>

I’ve solved adding manually the volume from the Longhorn interface.
