# Fail to restore etcd snapshot

**URL:** <https://forums.suse.com/t/fail-to-restore-etcd-snapshot/18295>\
**Category:** SUSE Rancher Prime\
**Created:** [September 8, 2020, 1:25pm UTC](https://forums.suse.com/t/fail-to-restore-etcd-snapshot/18295 "2020-09-08T13:25:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jagjot](https://avatars.discourse-cdn.com/v4/letter/j/46a35a/32.png) [@Jagjot](https://forums.suse.com/u/Jagjot)\
**Post date:** [September 8, 2020, 1:25pm UTC](https://forums.suse.com/t/fail-to-restore-etcd-snapshot/18295/1 "2020-09-08T13:25:08Z")

</div>

Hello,

I am facing issues while restoring etcd snapshot on my RKE cluster. I have configured automated backups for my cluster by adding the below in cluster-config.yml

services:  
etcd:  
snapshot: true  
creation: 1h  
retention: 6h

The backup is created under “/opt/rke/etcd-snapshots” on all the etcd nodes. When I try to restore this backup on second rke cluster, I get the errors.

When I use the below command, the error is as below:

COMMAND:  
rke etcd snapshot-restore --config ./rancher2-cluster.yml --name backup.zip

ERROR:  
FATA[0030] [etcd] Failed to restore etcd snapshot: Failed to run etcd restore container, exit status is: 1, container logs: {“level”:“info”,“ts”:1599569577.2810502,“caller”:“snapshot/v3\_snapshot.go:287”,“msg”:“restoring snapshot”,“path”:"/opt/rke/etcd-snapshots/backup.zip",“wal-dir”:"/opt/rke/etcd-snapshots-restore/member/wal",“data-dir”:"/opt/rke/etcd-snapshots-restore/",“snap-dir”:"/opt/rke/etcd-snapshots-restore/member/snap"}  
Error: snapshot missing hash but --skip-hash-check=false

And when I use this command:

COMMAND:  
rke etcd snapshot-restore --config ./rancher2-cluster.yml --name backup

ERROR:  
FATA[0031] failed to start backup server on all etcd nodes: [Failed to run backup server container, container logs: time=“2020-09-08T13:02:15Z” level=fatal msg=“File [/backup/backup] not found in file [/backup/backup.zip]”  
Failed to run backup server container, container logs: time=“2020-09-08T13:02:22Z” level=fatal msg=“File [/backup/backup] not found in file [/backup/backup.zip]”  
Failed to run backup server container, container logs: time=“2020-09-08T13:02:28Z” level=fatal msg=“File [/backup/backup] not found in file [/backup/backup.zip]”

I am using the below version of RKE on my cluster  
rke version v1.1.5

Any help will be highly appreciated.

---

<div class="post-metadata">

**Author:** ![mattmattox](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/mattmattox/32/5503_2.png) [@mattmattox](https://forums.suse.com/u/mattmattox)\
**Post date:** [September 11, 2020, 1:21pm UTC](https://forums.suse.com/t/fail-to-restore-etcd-snapshot/18295/2 "2020-09-11T13:21:45Z")

</div>

`rke etcd snapshot-restore --config ./rancher2-cluster.yml --name backup` should be the correct command.

Was the snapshot copied to all etcd nodes in the restored cluster?
