# Failed to execute /usr/sbin/xe-daemon: Exec format error

**URL:** <https://forums.suse.com/t/failed-to-execute-usr-sbin-xe-daemon-exec-format-error/46453>\
**Category:** General\
**Created:** [July 25, 2026, 9:44pm UTC](https://forums.suse.com/t/failed-to-execute-usr-sbin-xe-daemon-exec-format-error/46453 "2026-07-25T21:44:09Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![PeterVarga](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/petervarga/32/10167_2.png) [@PeterVarga](https://forums.suse.com/u/PeterVarga)\
**Post date:** [July 25, 2026, 9:44pm UTC](https://forums.suse.com/t/failed-to-execute-usr-sbin-xe-daemon-exec-format-error/46453/1 "2026-07-25T21:44:09Z")

</div>

When I install the XenServer VM Tools, I see this as the below result for `systemctl status xe-linux-distribution.service` under `SLES 16`. No issue with `SLES 15 SP7`. Did I miss something, is there some breaking change introduced with `SLES 16`?

```auto
× xe-linux-distribution.service - Linux Guest Agent
Loaded: loaded (/usr/lib/systemd/system/xe-linux-distribution.service; enabled; preset: disabled)
Active: failed (Result: exit-code) since Sat 2026-07-25 16:32:56 CEST; 6h ago
Duration: 246ms
Invocation: 48b6c11950174ece97556e6acee69a91
Process: 1174 ExecStartPre=/usr/sbin/xe-linux-distribution /var/cache/xe-linux-distribution (code=exited, status=0/SUCCESS)
Process: 1188 ExecStart=/usr/sbin/xe-daemon (code=exited, status=203/EXEC)
Main PID: 1188 (code=exited, status=203/EXEC)
CPU: 39ms

* systemd[1]: Starting Linux Guest Agent...
* systemd[1]: Started Linux Guest Agent.
* (e-daemon)[1188]: xe-linux-distribution.service: Failed to execute /usr/sbin/xe-daemon: Exec format error
* (e-daemon)[1188]: xe-linux-distribution.service: Failed at step EXEC spawning /usr/sbin/xe-daemon: Exec format error
* systemd[1]: xe-linux-distribution.service: Main process exited, code=exited, status=203/EXEC
* systemd[1]: xe-linux-distribution.service: Failed with result 'exit-code'.

```

_This is the result for `file /usr/sbin/xe-daemon` executed under SLES 16:_

`/usr/sbin/xe-daemon: ELF 32-bit LSB executable, Intel i386, version 1 (SYSV), statically linked, Go BuildID=rjnmd1Do8YIFpuehd0Cr/KIV2LHLK3LTej1D2qeYr/Saf0_ddsnZ6bwywpbIYE/36PiZCSjp8cVvrN5LDXh, stripped`

_SLES 15 SP7 returns:_

`/usr/sbin/xe-daemon: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), statically linked, stripped`

The only difference is that SLES 16 adds the tag ‘`Go BuildID`’. Any idea what I can do, how I can fix this issue?

These versions are available - I selected `xe-guest-utilities-10.0.0-1.x86_64.rpm`:

`xe-guest-utilities-10.0.0-1.i386.rpm*`  
`xe-guest-utilities-10.0.0-1.x86_64.rpm*`  
`xe-guest-utilities-xenstore-10.0.0-1.i386.rpm*`  
`xe-guest-utilities-xenstore-10.0.0-1.x86_64.rpm*`  
`xe-guest-utilities_10.0.0-1_all.tgz*`  
`xe-guest-utilities_10.0.0-1_amd64.deb*`  
`xe-guest-utilities_10.0.0-1_i386.deb*`

---

<div class="post-metadata">

**Author:** ![PeterVarga](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/petervarga/32/10167_2.png) [@PeterVarga](https://forums.suse.com/u/PeterVarga)\
**Post date:** [July 25, 2026, 10:04pm UTC](https://forums.suse.com/t/failed-to-execute-usr-sbin-xe-daemon-exec-format-error/46453/2 "2026-07-25T22:04:17Z")

</div>

Well, I could fix it. I keep this question so it may help others. The problem was that the install.sh script didn’t recognise correctly the Linux distribution - SLES 16 - and the 32-bit support was not installed.

_ **Steps how I fixed it:** _

1. Enable `SUSE Package Hub 16.0 x86_64` in `yast`.
2. Add the 32-bit support `zypper install grub2-compat-ia32`.
3. Run the script `./xe-linux-distribution` which returns the output at the end of this post.
4. According to the output I provided to the install script the parameters like this: `./install.sh -d sles -m 16`.
5. The XenServer VM Tools have been installed successfully and work properly.

_**Output for 1)**_

`os_distro="sles"`  
`os_majorver="16"`  
`os_minorver="0"`  
`os_uname="6.12.0-160000.35-default"`  
`os_name="SUSE Linux Enterprise Server 16.0"`
