# FailedMount - Error attaching RWX Volume

**URL:** <https://forums.suse.com/t/failedmount-error-attaching-rwx-volume/37204>\
**Category:** SUSE Storage\
**Created:** [March 8, 2022, 1:50pm UTC](https://forums.suse.com/t/failedmount-error-attaching-rwx-volume/37204 "2022-03-08T13:50:56Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Andrew\_Prowse](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/andrew_prowse/32/7444_2.png) [@Andrew\_Prowse](https://forums.suse.com/u/Andrew_Prowse)\
**Post date:** [March 8, 2022, 1:50pm UTC](https://forums.suse.com/t/failedmount-error-attaching-rwx-volume/37204/1 "2022-03-08T13:50:57Z")

</div>

Pod fails to attach to existing RWX volume, although several other pods connected.

We have 20 namespaces, each have a RWX volume shared amongst 5 pods 19 are stable, 1 gets the below error, consistently… This is the only one where the volume is over 80GB of data. The rest are 5-10GB.

Events:

```auto
  Type Reason Age From Message
  ---- ------ ---- ---- -------
  Normal Scheduled 10m default-scheduler Successfully assigned technica-prod/bastion-6c5f845599-wtjrb to k8s-devworker2
  Warning FailedMount 3m59s (x3 over 8m30s) kubelet Unable to attach or mount volumes: unmounted volumes=[attachments], unattached volumes=[attachments default-token-z9fsh]: timed out waiting for the condition
  Warning FailedMount 102s kubelet Unable to attach or mount volumes: unmounted volumes=[attachments], unattached volumes=[default-token-z9fsh attachments]: timed out waiting for the condition
  Warning FailedMount 26s (x5 over 8m33s) kubelet MountVolume.SetUp failed for volume "pvc-7e292083-314d-4e5a-9e8b-d64a27783918" : rpc error: code = DeadlineExceeded desc = context deadline exceeded

```

---

<div class="post-metadata">

**Author:** ![JenTing](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jenting/32/7290_2.png) [@JenTing](https://forums.suse.com/u/JenTing)\
**Post date:** [March 10, 2022, 8:54am UTC](https://forums.suse.com/t/failedmount-error-attaching-rwx-volume/37204/2 "2022-03-10T08:54:40Z")

</div>

Would you please provide the support bundle and kubelet log if possible.  
And send to [longhorn-support-bundle@suse.com](mailto:longhorn-support-bundle@suse.com), thx.

---

<div class="post-metadata">

**Author:** ![Andrew\_Prowse](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/andrew_prowse/32/7444_2.png) [@Andrew\_Prowse](https://forums.suse.com/u/Andrew_Prowse)\
**Post date:** [March 10, 2022, 1:48pm UTC](https://forums.suse.com/t/failedmount-error-attaching-rwx-volume/37204/3 "2022-03-10T13:48:54Z")

</div>

JenTing, we purchased a support bundle and have opened case 00339301, and have uploaded information there.

Thank you.

---

<div class="post-metadata">

**Author:** ![MAREESKANNAN\_RAJENDR](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/mareeskannan_rajendr/32/9026_2.png) [@MAREESKANNAN\_RAJENDR](https://forums.suse.com/u/MAREESKANNAN_RAJENDR)\
**Post date:** [May 23, 2022, 7:18am UTC](https://forums.suse.com/t/failedmount-error-attaching-rwx-volume/37204/4 "2022-05-23T07:18:52Z")

</div>

Hello @Andrew_Prowse ,

I also facing similar issue. Did you able to resolved this?. If so, Can you guide me on this.

Best Regards,  
Mareeskannan Rajendran.

---

<div class="post-metadata">

**Author:** ![Andrew\_Prowse](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/andrew_prowse/32/7444_2.png) [@Andrew\_Prowse](https://forums.suse.com/u/Andrew_Prowse)\
**Post date:** [May 24, 2022, 1:24pm UTC](https://forums.suse.com/t/failedmount-error-attaching-rwx-volume/37204/5 "2022-05-24T13:24:10Z")

</div>

Unfortunately we were never able to fix reliably.

We were able to recover some volumes by mounting the longhorn volume  
file locally on the worker node, and copying the data off.

We ended up moving all RWX volumes off longhorn and on to an NFS  
server. No more problems after that.

---

<div class="post-metadata">

**Author:** ![guillez](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/guillez/32/9454_2.png) [@guillez](https://forums.suse.com/u/guillez)\
**Post date:** [September 21, 2022, 12:14pm UTC](https://forums.suse.com/t/failedmount-error-attaching-rwx-volume/37204/6 "2022-09-21T12:14:58Z")

</div>

I have volume of 5Gb with longhorn and the pod show Bound , without in sistems describe not connect to database. I kill the pod and not connect to volume and message is  
Unable to attach or mount volumes: unmounted volumes=[db-storage], unattached volumes=[kube-api-access-6mn6g db-storage]: timed out waiting for the condition

and

MountVolume.MountDevice failed for volume “pv-db-storage” : rpc error: code = Internal desc = format of disk “/dev/longhorn/pv-db-storage” failed: type:(“ext4”) target:(“/var/lib/kubelet/plugins/kubernetes.io/csi/pv/pv-db-storage/globalmount”) options:(“defaults”) errcode:(exit status 1) output:(mke2fs 1.45.5 (07-Jan-2020) /dev/longhorn/pv-db-storage is apparently in use by the system; will not make a filesystem here! )

This problem init for low level storage and I extend space in te server. in time te pod return in ready, 30 and 60 min lost.
