# Fresh Install - Agents Connection Time out

**URL:** <https://forums.suse.com/t/fresh-install-agents-connection-time-out/15518>\
**Category:** SUSE Rancher Prime\
**Created:** [October 11, 2019, 2:02pm UTC](https://forums.suse.com/t/fresh-install-agents-connection-time-out/15518 "2019-10-11T14:02:27Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![eternalyperplxed](https://avatars.discourse-cdn.com/v4/letter/e/85f322/32.png) [@eternalyperplxed](https://forums.suse.com/u/eternalyperplxed)\
**Post date:** [October 11, 2019, 2:02pm UTC](https://forums.suse.com/t/fresh-install-agents-connection-time-out/15518/1 "2019-10-11T14:02:27Z")

</div>

I am attempting to deploy Rancher HA(v2.3.0) to 3 nodes on RancherOS(1.5.4) in an AWS VPC using certificates generate by our internal CA. We are using a layer 4 NLB to loadbalance access to RancherHA. RKE deployment and Rancher installation proceed with no issues, however the cattle-cluster-agent and cattle-node-agent pods go into crashloops. The only error message from the cluster-agent pods is

```
INFO: Environment: CATTLE_ADDRESS=10.42.2.4 CATTLE_CA_CHECKSUM=64e928b78c0904a2093075305fad43749c91e33b391c651f2404361a4ecaf178 CATTLE_CLUSTER=true CATTLE_INTERNAL_ADDRESS= CATTLE_K8S_MANAGED=true CATTLE_NODE_NAME=cattle-cluster-agent-84bfd8c8f9-c6h9r CATTLE_SERVER=https://*redacted*.*redacted*.com

```

INFO: Using resolv.conf: nameserver 10.43.0.10 search cattle-system.svc.cluster.local svc.cluster.local cluster.local options ndots:5  
ERROR: https://_redacted_._redacted_.com/ping is not accessible (Failed to connect to _redacted_._redacted_.com port 443: Connection timed out)

Node-agent pods show a similar error using the VPC name server. DNS resolution is successful since we have a Route53 resolver pointing to our internal DNS servers.

AWS security groups are set to allow all egress traffic from these nodes as well as ingress from the NLB over port 80/443 and all traffic from the nodes themselves.

Any ideas on why the connection is timing out? Apologies if the above formatting is not correct.

UPDATE: This also happens with Rancher v2.2.8

---

<div class="post-metadata">

**Author:** ![equallypuzzled](https://avatars.discourse-cdn.com/v4/letter/e/d07c76/32.png) [@equallypuzzled](https://forums.suse.com/u/equallypuzzled)\
**Post date:** [November 18, 2019, 11:40pm UTC](https://forums.suse.com/t/fresh-install-agents-connection-time-out/15518/2 "2019-11-18T23:40:36Z")

</div>

I’m having the same issues. It’s a happening on v2.3.2.  
I’m not sure what i can do to troubleshoot/fix this.
