# Glusterfs catalog service

**URL:** <https://forums.suse.com/t/glusterfs-catalog-service/1047>\
**Category:** Rancher 1.x\
**Created:** [November 23, 2015, 2:08pm UTC](https://forums.suse.com/t/glusterfs-catalog-service/1047 "2015-11-23T14:08:05Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![hwaastad](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/hwaastad/32/225_2.png) [@hwaastad](https://forums.suse.com/u/hwaastad)\
**Post date:** [November 23, 2015, 2:08pm UTC](https://forums.suse.com/t/glusterfs-catalog-service/1047/1 "2015-11-23T14:08:05Z")

</div>

Hi,  
i did a try on deploying a glusterfs service from catalog using the os-vagrant project and the last version of rancher (0.46) and hit a couple of issues:

1. By default fuse module is not loaded in RancherOS

2. Install fails with:  
`Traceback (most recent call last): File "/var/lib/cattle/pyagent/cattle/utils.py", line 280, in get_command_output return check_output(*args, **kw) File "/var/lib/cattle/pyagent/cattle/utils.py", line 337, in check_output raise e1 CalledProcessError: Command '['/var/lib/cattle/config.sh', u'host-iptables', u'host-routes']' returned non-zero exit status 28 2015-11-23 14:01:45,476 ERROR root [140513824353328] [_logging.py:54] error from callback <function on_error at 0x7fcbec6402a8>: ('Received websocket error: [%s]', error(110, 'Connection timed out'))`

Any recommendations on how to resolve this?

br hw

---

<div class="post-metadata">

**Author:** ![MichaelF25](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/michaelf25/32/556_2.png) [@MichaelF25](https://forums.suse.com/u/MichaelF25)\
**Post date:** [November 23, 2015, 4:05pm UTC](https://forums.suse.com/t/glusterfs-catalog-service/1047/2 "2015-11-23T16:05:04Z")

</div>

Similar problem here. Deployed latest Rancher to a vSphere environment tother with 2 host VMs. Creating a new Stack with the GlusterFS service from the catalog succeeds but it seems that something fails during container creation.

---

<div class="post-metadata">

**Author:** ![denise](https://avatars.discourse-cdn.com/v4/letter/d/82dd89/32.png) [@denise](https://forums.suse.com/u/denise)\
**Post date:** [December 3, 2015, 7:12pm UTC](https://forums.suse.com/t/glusterfs-catalog-service/1047/3 "2015-12-03T19:12:02Z")

</div>

FYI, we’ve made a fix for GlusterFS catalog item so it works on RancherOS and is compatible with systems that don’t have fuse loaded.

@MichaelF25 Can you confirm it would work for your setup?

> <https://github.com/rancher/rancher/issues/2866>
>
> From http://forums.suse.com/t/glusterfs-catalog-continually-restarting-0-47-0-using-catalog-template-3-7-5-rancher1/1085/10
> Attempting to run the GlusterFS catalog entry on RancherOS hosts results in an error.
> time="2015-11-27T08:17:05.956478206Z" level=error msg="HTTP Error" err="Cannot start container...
