# HA Rancher and transition to https

**URL:** <https://forums.suse.com/t/ha-rancher-and-transition-to-https/4025>\
**Category:** Rancher 1.x\
**Created:** [September 16, 2016, 1:26am UTC](https://forums.suse.com/t/ha-rancher-and-transition-to-https/4025 "2016-09-16T01:26:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![dindurthy](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/dindurthy/32/1537_2.png) [@dindurthy](https://forums.suse.com/u/dindurthy)\
**Post date:** [September 16, 2016, 1:26am UTC](https://forums.suse.com/t/ha-rancher-and-transition-to-https/4025/1 "2016-09-16T01:26:47Z")

</div>

We created an HA Rancher some time ago, but recently we added an HAPROXY to terminate SSL in front of Rancher. So, previously we would access rancher over http, and now it’s https. Updating the hostname seemed to solve most of our problems, but we are hitting failures with a few management services, namely management\_rancher-compose-executor and management\_go-machine-service. The logs show that these services are failing to connect to the http endpoint. Looks to me like this in turn is causing other operations to fail.

I tried updating the CATTLE\_HA\_HOST\_REGISTRATION\_URL in the rancher\_server with the https endpoing and re-running with `rancher-ha-start.sh rancher/server`, but to avail. I do not want to build it all again from scratch, so any help would be appreciated.

---

<div class="post-metadata">

**Author:** ![dindurthy](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/dindurthy/32/1537_2.png) [@dindurthy](https://forums.suse.com/u/dindurthy)\
**Post date:** [September 19, 2016, 8:00pm UTC](https://forums.suse.com/t/ha-rancher-and-transition-to-https/4025/2 "2016-09-19T20:00:29Z")

</div>

Any thoughts on this?
