# HAProxy with StartSSL Certs

**URL:** <https://forums.suse.com/t/haproxy-with-startssl-certs/2160>\
**Category:** Rancher 1.x\
**Created:** [March 25, 2016, 2:45am UTC](https://forums.suse.com/t/haproxy-with-startssl-certs/2160 "2016-03-25T02:45:12Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Michael\_Draper](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/michael_draper/32/1183_2.png) [@Michael\_Draper](https://forums.suse.com/u/Michael_Draper)\
**Post date:** [March 25, 2016, 2:45am UTC](https://forums.suse.com/t/haproxy-with-startssl-certs/2160/1 "2016-03-25T02:45:12Z")

</div>

I’ve tried every combination with the certs that StartSSL provided, and for some reason I am getting

unable to load SSL private key from PEM file ‘/etc/haproxy/certs/default.pem’.  
unable to load SSL private key from PEM file ‘/etc/haproxy/certs/server.pem’.

What am I doing wrong?

If anyone is familiar with the certs that StartSSL supplies us with? Which cert goes where??
