# install-suse-cloud Error: Could not create default proposal

**URL:** <https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260>\
**Category:** SUSE OpenStack Cloud\
**Created:** [January 19, 2017, 9:24pm UTC](https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260 "2017-01-19T21:24:30Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![romz169](https://avatars.discourse-cdn.com/v4/letter/r/ebca7d/32.png) [@romz169](https://forums.suse.com/u/romz169)\
**Post date:** [January 19, 2017, 9:24pm UTC](https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260/1 "2017-01-19T21:24:30Z")

</div>

So when I ran the script the first time it gave me this error. In the log it looks like everything it working but the Chef seems to be failing.

[2017-01-18T17:18:06-06:00] INFO: Processing directory[/etc/chef/ohai\_plugins] action nothing (ohai::default line 35)  
[2017-01-18T17:18:06-06:00] INFO: Processing remote\_directory[/etc/chef/ohai\_plugins] action nothing (ohai::default line 46)  
[2017-01-18T17:18:06-06:00] INFO: Processing directory[create /etc/sysctl.d for reboot-on-panic] action create (kernel-panic::default line 11)  
[2017-01-18T17:18:06-06:00] INFO: Processing template[sysctl-reboot-on-panic.conf] action create (kernel-panic::default line 16)  
[2017-01-18T17:18:06-06:00] INFO: Processing bash[reload reboot-on-panic-sysctl] action nothing (kernel-panic::default line 22)  
[2017-01-18T17:18:06-06:00] INFO: Chef Run complete in 6.509901106 seconds  
[2017-01-18T17:18:06-06:00] INFO: Running report handlers  
[2017-01-18T17:18:06-06:00] INFO: Report handlers complete  
crowbar is already running - no need to start.  
=== 2017-01-18 17:18:06 -0600: Applying Crowbar configuration for Administration Server  
Using custom crowbar configuration from /etc/crowbar/crowbar.json  
Using custom network configuration from /etc/crowbar/network.json  
Will use America/Chicago timezone for node installation  
bind will use the following DNS forwarders: “10.2.106.7”,“10.22.2.6”,“10.22.6.80”  
Auto-detecting existing ntp servers from /etc/ntp.conf …  
ntp will use the following servers: “10.2.104.144”, “timesource.kumc.edu”, “timesource2.kumc.edu”  
Failed to talk to service proposal create: 500: {“status”:“500”,“error”:“Internal Server Error”}  
Proposal create failed, pass 1. Will kick Chef and try again.  
[2017-01-18T17:18:10-06:00] INFO: \*\*\* Chef 10.32.2 \*\*\*  
[2017-01-18T17:18:11-06:00] INFO: Run List is [role[crowbar], role[deployer-client], role[crowbar-admin\_cloud\_kumc\_edu]]  
[2017-01-18T17:18:11-06:00] INFO: Run List expands to [utils, crowbar, barclamp, repos, crowbar-hacks, ohai, kernel-panic]  
[2017-01-18T17:18:11-06:00] INFO: Starting Chef Run for admin.cloud.kumc.edu  
[2017-01-18T17:18:11-06:00] INFO: Running start handlers  
[2017-01-18T17:18:11-06:00] INFO: Start handlers complete.  
[2017-01-18T17:18:12-06:00] INFO: Loading cookbooks [apache2, barclamp, bluepill, crowbar, crowbar-hacks, kernel-panic, ohai, repos, utils]  
[2017-01-18T17:18:12-06:00] WARN: Cloning resource attributes for service[apache2] from prior resource (CHEF-3694)  
[2017-01-18T17:18:12-06:00] WARN: Previous service[apache2]: /var/chef/cache/cookbooks/apache2/recipes/default.rb:32:in `from_file' [2017-01-18T17:18:12-06:00] WARN: Current service[apache2]: /var/chef/cache/cookbooks/apache2/recipes/default.rb:224:in `from\_file’  
[2017-01-18T17:18:12-06:00] INFO: Running on suse-12.1 / x86\_64

this will try multiple times and then it just fails with Error: Could not create default proposal.

the install-suse-cloud script says it can be run mutiple times, but that does not seem to be the case. I attempt to run it again and the logs complain about overwriting a file. I manual delete the file and it complains that is user is already created.

PTF (12.1 / x86\_64) repository is already signed  
=== 2017-01-19 13:17:28 -0600: Starting required services  
rabbitmq-server is already running - no need to start.  
couchdb is already running - no need to start.  
chef-solr is already running - no need to start.  
chef-expander is already running - no need to start.  
chef-server is already running - no need to start.  
=== 2017-01-19 13:17:29 -0600: Performing initial chef-client run  
WARNING: No knife configuration file found  
Where should I put the config file? [/root/.chef/knife.rb] Please enter the chef server URL: [[http://admin.cloud.kumc.edu:4000]](http://admin.cloud.kumc.edu:4000%5D) Please enter a clientname for the new client: [netdev] Please enter the existing admin clientname: [chef-webui] Please enter the location of the existing admin client’s private key: [/etc/chef/webui.pem] Please enter the validation clientname: [chef-validator] Please enter the location of the validation key: [/etc/chef/validation.pem] Please enter the path to a chef repository (or leave blank): Creating initial API user…  
ERROR: Client ‘netdev’ already exists

How do I fix chef, and delete the user the already exists so i can run the script again?

---

<div class="post-metadata">

**Author:** ![romz169](https://avatars.discourse-cdn.com/v4/letter/r/ebca7d/32.png) [@romz169](https://forums.suse.com/u/romz169)\
**Post date:** [January 20, 2017, 4:43am UTC](https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260/2 "2017-01-20T04:43:15Z")

</div>

looking into more logs, /var/log/crowbar/production.log i am getting permission issues.

I, [2017-01-19T20:37:02.811771 #9085:0x000000053a2690] INFO – Started PUT “/crowbar/crowbar/1.0/proposals” for 127.0.0.1 at 2017-01-19 20:37:02 -0600  
I, [2017-01-19T20:37:02.815663 #9085:0x000000053a2690] INFO – Processing by CrowbarController#proposal\_create as JSON  
I, [2017-01-19T20:37:02.815777 #9085:0x000000053a2690] INFO – Parameters: {“attributes”=\>{“crowbar”=\>{“realm”=\>“SUSE OpenStack Cloud Admin Server”, “users”=\>{“crowbar”=\>{“password”=\>"[FILTERED]"}, “machine-install”=\>{“password”=\>"[FILTERED]"}}, “instances”=\>{“ganglia”=\>[], “nagios”=\>[], “dns”=\>["/var/lib/crowbar/config/dns.json"], “network”=\>["/var/lib/crowbar/config/network.json"], “provisioner”=\>["/var/lib/crowbar/config/provisioner.json"], “ntp”=\>["/var/lib/crowbar/config/ntp.json"]}}}, “id”=\>“default”, “crowbar-deep-merge-template”=\>true}  
I, [2017-01-19T20:37:02.816449 #9085:0x000000053a2690] INFO – Completed 500 Internal Server Error in 1ms (ActiveRecord: 0.0ms)  
F, [2017-01-19T20:37:02.817489 #9085:0x000000053a2690] FATAL –  
Errno::EACCES (Permission denied @ rb\_sysopen - /var/lib/crowbar/install/installation\_steps):  
lib/crowbar/installer.rb:95:in `readlines' lib/crowbar/installer.rb:95:in `readlines’  
lib/crowbar/installer.rb:95:in `steps_done' lib/crowbar/installer.rb:84:in `initial\_chef\_client?’  
app/controllers/barclamp\_controller.rb:24:in `block in class:BarclampController’

I am running the install as root though

---

<div class="post-metadata">

**Author:** ![bmwiedemann](https://avatars.discourse-cdn.com/v4/letter/b/46a35a/32.png) [@bmwiedemann](https://forums.suse.com/u/bmwiedemann)\
**Post date:** [January 20, 2017, 9:05am UTC](https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260/3 "2017-01-20T09:05:19Z")

</div>

the crowbar rails application is running as crowbar user  
some chef server components are running as chef user  
so permission problems can occur

but there is probably still a bug in there worth investigating

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [January 20, 2017, 6:29pm UTC](https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260/4 "2017-01-20T18:29:23Z")

</div>

On 19/01/17 19:34, romz169 wrote:  
[color=blue]

> So when I ran the script the first time it gave me this error. In the  
> log it looks like everything it working but the Chef seems to be  
> failing.
> 
> [2017-01-18T17:18:06-06:00] INFO: Processing  
> directory[/etc/chef/ohai\_plugins] action nothing (ohai::default line  
> 35)  
> [2017-01-18T17:18:06-06:00] INFO: Processing  
> remote\_directory[/etc/chef/ohai\_plugins] action nothing (ohai::default  
> line 46)  
> [2017-01-18T17:18:06-06:00] INFO: Processing directory[create  
> /etc/sysctl.d for reboot-on-panic] action create (kernel-panic::default  
> line 11)  
> [2017-01-18T17:18:06-06:00] INFO: Processing  
> template[sysctl-reboot-on-panic.conf] action create  
> (kernel-panic::default line 16)  
> [2017-01-18T17:18:06-06:00] INFO: Processing bash[reload  
> reboot-on-panic-sysctl] action nothing (kernel-panic::default line 22)  
> [2017-01-18T17:18:06-06:00] INFO: Chef Run complete in 6.509901106  
> seconds  
> [2017-01-18T17:18:06-06:00] INFO: Running report handlers  
> [2017-01-18T17:18:06-06:00] INFO: Report handlers complete  
> crowbar is already running - no need to start.  
> === 2017-01-18 17:18:06 -0600: Applying Crowbar configuration for  
> Administration Server  
> Using custom crowbar configuration from /etc/crowbar/crowbar.json  
> Using custom network configuration from /etc/crowbar/network.json  
> Will use America/Chicago timezone for node installation  
> bind will use the following DNS forwarders:  
> “10.2.106.7”,“10.22.2.6”,“10.22.6.80”  
> Auto-detecting existing ntp servers from /etc/ntp.conf …  
> ntp will use the following servers: “10.2.104.144”,  
> “timesource.kumc.edu”, “timesource2.kumc.edu”  
> Failed to talk to service proposal create: 500:  
> {“status”:“500”,“error”:“Internal Server Error”}  
> Proposal create failed, pass 1. Will kick Chef and try again.  
> [2017-01-18T17:18:10-06:00] INFO: \*\*\* Chef 10.32.2 \*\*\*  
> [2017-01-18T17:18:11-06:00] INFO: Run List is [role[crowbar],  
> role[deployer-client], role[crowbar-admin\_cloud\_kumc\_edu]]  
> [2017-01-18T17:18:11-06:00] INFO: Run List expands to [utils, crowbar,  
> barclamp, repos, crowbar-hacks, ohai, kernel-panic]  
> [2017-01-18T17:18:11-06:00] INFO: Starting Chef Run for  
> admin.cloud.kumc.edu  
> [2017-01-18T17:18:11-06:00] INFO: Running start handlers  
> [2017-01-18T17:18:11-06:00] INFO: Start handlers complete.  
> [2017-01-18T17:18:12-06:00] INFO: Loading cookbooks [apache2, barclamp,  
> bluepill, crowbar, crowbar-hacks, kernel-panic, ohai, repos, utils]  
> [2017-01-18T17:18:12-06:00] WARN: Cloning resource attributes for  
> service[apache2] from prior resource (CHEF-3694)  
> [2017-01-18T17:18:12-06:00] WARN: Previous service[apache2]:  
> /var/chef/cache/cookbooks/apache2/recipes/default.rb:32:in `from_file' [2017-01-18T17:18:12-06:00] WARN: Current service[apache2]: /var/chef/cache/cookbooks/apache2/recipes/default.rb:224:in `from\_file’  
> [2017-01-18T17:18:12-06:00] INFO: Running on suse-12.1 / x86\_64
> 
> this will try multiple times and then it just fails with Error: Could  
> not create default proposal.
> 
> the install-suse-cloud script says it can be run mutiple times, but that  
> does not seem to be the case. I attempt to run it again and the logs  
> complain about overwriting a file. I manual delete the file and it  
> complains that is user is already created.
> 
> PTF (12.1 / x86\_64) repository is already signed  
> === 2017-01-19 13:17:28 -0600: Starting required services  
> rabbitmq-server is already running - no need to start.  
> couchdb is already running - no need to start.  
> chef-solr is already running - no need to start.  
> chef-expander is already running - no need to start.  
> chef-server is already running - no need to start.  
> === 2017-01-19 13:17:29 -0600: Performing initial chef-client run  
> WARNING: No knife configuration file found  
> Where should I put the config file? [/root/.chef/knife.rb] Please enter  
> the chef server URL: [[http://admin.cloud.kumc.edu:4000]](http://admin.cloud.kumc.edu:4000) Please enter a  
> clientname for the new client: [netdev] Please enter the existing admin  
> clientname: [chef-webui] Please enter the location of the existing admin  
> client’s private key: [/etc/chef/webui.pem] Please enter the validation  
> clientname: [chef-validator] Please enter the location of the validation  
> key: [/etc/chef/validation.pem] Please enter the path to a chef  
> repository (or leave blank): Creating initial API user…  
> ERROR: Client ‘netdev’ already exists
> 
> How do I fix chef, and delete the user the already exists so i can run  
> the script again?[/color]

From the first log excerpt I can see you’re using SLES12 SP1 but which  
version of SUSE (OpenStack) Cloud?

I’ve seen an error when creating admin node and/or client for which I  
had to use the knife command to delete.

Given the references to 10.x.x.x networks in the first log excerpt can I  
check which IP network(s) you’re using? The install (and documentation)  
assumes 192.168.12[3-6].x - see  
[https://www.suse.com/documentation/suse-openstack-cloud-6/book\_cloud\_deploy/data/sec\_depl\_req\_network.html](https://www.suse.com/documentation/suse-openstack-cloud-6/book_cloud_deploy/data/sec_depl_req_network.html)

## HTH.

Simon  
SUSE Knowledge Partner

* * *

## If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below. Thanks.

---

<div class="post-metadata">

**Author:** ![romz169](https://avatars.discourse-cdn.com/v4/letter/r/ebca7d/32.png) [@romz169](https://forums.suse.com/u/romz169)\
**Post date:** [January 20, 2017, 9:19pm UTC](https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260/5 "2017-01-20T21:19:06Z")

</div>

I have changed the networks in yast2 crowbar to match what i have in my environment.  
i am installed SuSE Cloud 6.

So it was looking like permission issues so i did a fresh install instead of off my image (It has the CIS standards applied to it) and it got past the permission issues but now i am getting the following error.

# ================================================================================ Recipe Compile Error in /var/chef/cache/cookbooks/network/recipes/default.rb

## ArgumentError

Conduit mapping “intf0” for network “admin” is not sane: [“eth0”, nil]

## Cookbook Trace:

/var/chef/cache/cookbooks/network/recipes/default.rb:161:in `block in from_file' /var/chef/cache/cookbooks/network/recipes/default.rb:147:in `each’  
/var/chef/cache/cookbooks/network/recipes/default.rb:147:in `from\_file’

## Relevant File Content:

/var/chef/cache/cookbooks/network/recipes/default.rb:

154: else  
155: nil  
156: end  
157: conduit = network[“conduit”]  
158: base\_ifs = conduit\_map[conduit][“if\_list”]  
159: # Error out if we were handed an invalid conduit mapping.  
160: unless base\_ifs.all?{ |i|i.is\_a?(String) && ::Nic.exists?(i) }  
161\>\> raise ::ArgumentError.new(“Conduit mapping "#{conduit}" for network "#{name}" is not sane: #{base\_ifs.inspect}”)  
162: end  
163: base\_ifs = base\_ifs.map{ |i| ::Nic.new(i) }  
164: Chef::Log.info(“Using base interfaces #{base\_ifs.map{ |i|i.name }.inspect} for network #{name}”)  
165: base\_ifs.each do |i|  
166: ifs[i.name] ||= Hash.new  
167: ifs[i.name][“addresses”] ||= Array.new  
168: ifs[i.name][“type”] = “physical”  
169: end  
170: case base\_ifs.length

[2017-01-20T12:49:12-06:00] ERROR: Running exception handlers  
[2017-01-20T12:49:12-06:00] FATAL: Saving node information to /var/chef/cache/failed-run-data.json  
[2017-01-20T12:49:12-06:00] ERROR: Exception handlers complete  
[2017-01-20T12:49:12-06:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out  
[2017-01-20T12:49:12-06:00] FATAL: ArgumentError: Conduit mapping “intf0” for network “admin” is not sane: [“eth0”, nil]

---

<div class="post-metadata">

**Author:** ![bmwiedemann](https://avatars.discourse-cdn.com/v4/letter/b/46a35a/32.png) [@bmwiedemann](https://forums.suse.com/u/bmwiedemann)\
**Post date:** [January 21, 2017, 8:01pm UTC](https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260/6 "2017-01-21T20:01:05Z")

</div>

> [@romz169;36174](#):
>
> Conduit mapping “intf0” for network “admin” is not sane: [“eth0”, nil]

that tells that you need to fix your network.json  
crowbar thinks you want two interfaces bonded for your admin network  
but then it only finds one eth0 and nothing else

---

<div class="post-metadata">

**Author:** ![romz169](https://avatars.discourse-cdn.com/v4/letter/r/ebca7d/32.png) [@romz169](https://forums.suse.com/u/romz169)\
**Post date:** [January 24, 2017, 9:10pm UTC](https://forums.suse.com/t/install-suse-cloud-error-could-not-create-default-proposal/29260/7 "2017-01-24T21:10:34Z")

</div>

[QUOTE=bmwiedemann;36176]that tells that you need to fix your network.json  
crowbar thinks you want two interfaces bonded for your admin network  
but then it only finds one eth0 and nothing else[/QUOTE]

Thanks for pointing this out, you are correct, i was able to get the admin server up and running with a fresh install of SuSE12.1 and setting up 2 network cards in team mode.
