# install-suse-cloud failure

**URL:** <https://forums.suse.com/t/install-suse-cloud-failure/28166>\
**Category:** SUSE OpenStack Cloud\
**Created:** [May 15, 2016, 11:20pm UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166 "2016-05-15T23:20:59Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![jfonseca](https://avatars.discourse-cdn.com/v4/letter/j/e68b1a/32.png) [@jfonseca](https://forums.suse.com/u/jfonseca)\
**Post date:** [May 15, 2016, 11:20pm UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/1 "2016-05-15T23:20:59Z")

</div>

Hi,

While deploying SUSE OpenStack Cloud 6, I got stuck with the following error:

# ================================================================================ Error executing action `install` on resource ‘package[ruby2.1-rubygem-cstruct]’

## Chef::Exceptions::Package

zypper failed - #\<Process::Status: pid 9711 exit 4\>!

## Cookbook Trace:

/var/chef/cache/cookbooks/ohai/recipes/default.rb:70:in `from\_file’

## Resource Declaration:

# In /var/chef/cache/cookbooks/ohai/recipes/default.rb

70: package(pkg).run\_action(:install)  
71:

## Compiled Resource:

# Declared in /var/chef/cache/cookbooks/ohai/recipes/default.rb:70:in `from\_file’

package(“ruby2.1-rubygem-cstruct”) do  
action :install  
retries 0  
retry\_delay 2  
package\_name “ruby2.1-rubygem-cstruct”  
cookbook\_name “ohai”  
recipe\_name “default”  
end

# ================================================================================ Recipe Compile Error in /var/chef/cache/cookbooks/ohai/recipes/default.rb

## Chef::Exceptions::Package

package[ruby2.1-rubygem-cstruct] (ohai::default line 70) had an error: Chef::Exceptions:📦 zypper failed - #\<Process::Status: pid 9711 exit 4\>!

## Cookbook Trace:

/var/chef/cache/cookbooks/ohai/recipes/default.rb:70:in `from\_file’

## Relevant File Content:

/var/chef/cache/cookbooks/ohai/recipes/default.rb:

63: # ruby&rails), we need to run the new cookbook with the old ruby&rails once,  
64: # so we need to support this  
65: if node[“languages”][“ruby”][“version”].to\_f == 1.8  
66: pkg = “rubygem-cstruct”  
67: else  
68: pkg = “ruby#{node[“languages”][“ruby”][“version”].to\_f}-rubygem-cstruct”  
69: end  
70\>\> package(pkg).run\_action(:install)  
71:  
72: begin  
73: require “cstruct”  
74: rescue LoadError  
75: # After installation of the gem, we have a new path for the new gem, so  
76: # we need to reset the paths if we can’t load cstruct  
77: Gem.clear\_paths  
78: end  
79:

[2016-05-15T22:14:26+02:00] ERROR: Running exception handlers  
[2016-05-15T22:14:26+02:00] FATAL: Saving node information to /var/chef/cache/failed-run-data.json  
[2016-05-15T22:14:26+02:00] ERROR: Exception handlers complete  
[2016-05-15T22:14:26+02:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out  
[2016-05-15T22:14:26+02:00] FATAL: Chef::Exceptions:📦 package[ruby2.1-rubygem-cstruct] (ohai::default line 70) had an error: Chef::Exceptions:📦 zypper failed - #\<Process::Status: pid 9711 exit 4\>!

Any idea?

Thanks in advance!

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [May 15, 2016, 11:53pm UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/2 "2016-05-15T23:53:50Z")

</div>

jfonseca Wrote in message:  
[color=blue]

> While deploying SUSE OpenStack Cloud 6, I got stuck with the following  
> error:
> 
> # ================================================================================ Error executing action `install` on resource ‘package[ruby2.1-rubygem-cstruct]’
> 
> ## Chef::Exceptions::Package
> 
> zypper failed - #\<Process::Status: pid 9711 exit 4\>!
> 
> ## Cookbook Trace:
> 
> /var/chef/cache/cookbooks/ohai/recipes/default.rb:70:in `from\_file’
> 
> ## Resource Declaration:
> 
> # In /var/chef/cache/cookbooks/ohai/recipes/default.rb
> 
> 70: package(pkg).run\_action(:install)  
> 71:
> 
> ## Compiled Resource:
> 
> # Declared in /var/chef/cache/cookbooks/ohai/recipes/default.rb:70:in
> 
> `from\_file’
> 
> package(“ruby2.1-rubygem-cstruct”) do  
> action :install  
> retries 0  
> retry\_delay 2  
> package\_name “ruby2.1-rubygem-cstruct”  
> cookbook\_name “ohai”  
> recipe\_name “default”  
> end
> 
> # ================================================================================ Recipe Compile Error in /var/chef/cache/cookbooks/ohai/recipes/default.rb
> 
> ## Chef::Exceptions::Package
> 
> package[ruby2.1-rubygem-cstruct] (ohai::default line 70) had an error:  
> Chef::Exceptions:📦 zypper failed - #\<Process::Status: pid 9711  
> exit 4\>!
> 
> ## Cookbook Trace:
> 
> /var/chef/cache/cookbooks/ohai/recipes/default.rb:70:in `from\_file’
> 
> ## Relevant File Content:
> 
> /var/chef/cache/cookbooks/ohai/recipes/default.rb:
> 
> 63: # ruby&rails), we need to run the new cookbook with the old  
> ruby&rails once,  
> 64: # so we need to support this  
> 65: if node[“languages”][“ruby”][“version”].to\_f == 1.8  
> 66: pkg = “rubygem-cstruct”  
> 67: else  
> 68: pkg =  
> “ruby#{node[“languages”][“ruby”][“version”].to\_f}-rubygem-cstruct”  
> 69: end  
> 70\>\> package(pkg).run\_action(:install)  
> 71:  
> 72: begin  
> 73: require “cstruct”  
> 74: rescue LoadError  
> 75: # After installation of the gem, we have a new path for the  
> new gem, so  
> 76: # we need to reset the paths if we can’t load cstruct  
> 77: Gem.clear\_paths  
> 78: end  
> 79:
> 
> [2016-05-15T22:14:26+02:00] ERROR: Running exception handlers  
> [2016-05-15T22:14:26+02:00] FATAL: Saving node information to  
> /var/chef/cache/failed-run-data.json  
> [2016-05-15T22:14:26+02:00] ERROR: Exception handlers complete  
> [2016-05-15T22:14:26+02:00] FATAL: Stacktrace dumped to  
> /var/chef/cache/chef-stacktrace.out  
> [2016-05-15T22:14:26+02:00] FATAL: Chef::Exceptions:📦  
> package[ruby2.1-rubygem-cstruct] (ohai::default line 70) had an error:  
> Chef::Exceptions:📦 zypper failed - #\<Process::Status: pid 9711  
> exit 4\>!
> 
> Any idea?[/color]

Can I check that you’re deploying SUSE OpenStack Cloud 6 (SOC6) on  
SLES12 SP1 and not on another version/release? Also, have you  
added SOC6 to an existing setup or are you installing the server  
afresh with SLES12 SP1 plus SOC6? If adding SOC6 to an existing  
server is that server already patched?

The reference to “zypper” and “ruby2.1-rubygem-cstruct” makes me  
think is related to that particular package. Is it already  
installed (if so what version?) or available in one of the  
configured software repos?

## HTH.

Simon Flood  
SUSE Knowledge Partner

----Android NewsGroup Reader----  
[http://usenet.sinaapp.com/](http://usenet.sinaapp.com/)

---

<div class="post-metadata">

**Author:** ![jfonseca](https://avatars.discourse-cdn.com/v4/letter/j/e68b1a/32.png) [@jfonseca](https://forums.suse.com/u/jfonseca)\
**Post date:** [May 16, 2016, 12:26am UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/3 "2016-05-16T00:26:43Z")

</div>

Thanks for the quick reply!

It is a fresh SLES12 SP1 plus SOC6:

# cat /etc/os-release

NAME=“SLES”  
VERSION=“12-SP1”  
VERSION\_ID=“12.1”  
PRETTY\_NAME=“SUSE Linux Enterprise Server 12 SP1”  
ID=“sles”  
ANSI\_COLOR=“0;32”  
CPE\_NAME=“cpe:/o:suse:sles:12:sp1”

The installation script goes ahead after manually installing ruby2.1-rubygem-cstruct, but it is failing on the installation of several other packages.

For example, from the /var/log/crowbar/install.log:  
[2016-05-15T23:09:25+02:00] ERROR: Running exception handlers  
[2016-05-15T23:09:25+02:00] FATAL: Saving node information to /var/chef/cache/failed-run-data.json  
[2016-05-15T23:09:25+02:00] ERROR: Exception handlers complete  
[2016-05-15T23:09:25+02:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out  
[2016-05-15T23:09:25+02:00] FATAL: Mixlib::ShellOut::ShellCommandFailed: package[dnsmasq] (resolver::default line 37) had an error: Mixlib::ShellOut::ShellCommandFailed: Expected process to exit with [0], but received ‘8’  
---- Begin output of zypper-retry --non-interactive install --auto-agree-with-licenses dnsmasq=2.71-10.1 ----  
STDOUT: Refreshing service ‘SUSE\_Enterprise\_Storage\_2.1\_x86\_64’.  
Refreshing service ‘SUSE\_Linux\_Enterprise\_Server\_12\_SP1\_x86\_64’.  
Refreshing service ‘SUSE\_OpenStack\_Cloud\_6\_x86\_64’.  
Loading repository data…  
Reading installed packages…  
Resolving package dependencies…

The following NEW package is going to be installed:  
dnsmasq

1 new package to install.  
Overall download size: 424.9 KiB. Already cached: 0 B. After the operation, additional 1.1 MiB will be used.  
Continue? [y/n/? shows all options] (y): y  
Retrieving package dnsmasq-2.71-10.1.x86\_64 (1/1), 424.9 KiB ( 1.1 MiB unpacked)  
Retrieving: dnsmasq-2.71-10.1.x86\_64.rpm [error]  
Retrying in 30 seconds…  
Retrieving: dnsmasq-2.71-10.1.x86\_64.rpm [error]  
Retrying in 30 seconds…  
Retrieving: dnsmasq-2.71-10.1.x86\_64.rpm [error]  
Retrying in 30 seconds…  
Retrieving: dnsmasq-2.71-10.1.x86\_64.rpm [error]  
Retrying in 30 seconds…  
STDERR: Timeout exceeded when accessing ‘[https://updates.suse.com/SUSE/Updates/SLE-SERVER/12-SP1/x86\_64/update/x86\_64/dnsmasq-2.71-10.1.x86\_64.rpm?0sLKBynI9ucR1FRb-Ljj3FyFmaj1Dzi90qeSk5nZCwwXmyh1eiruizwdj9mPCGi8JWg9cFm2wfKR6QBVtnwc3Dzv\_INJ09vCKVpT3Z0aX4FSCgOhMQvevqg-jlFkrcYgoBDunkKbeUGqZmk](https://updates.suse.com/SUSE/Updates/SLE-SERVER/12-SP1/x86_64/update/x86_64/dnsmasq-2.71-10.1.x86_64.rpm?0sLKBynI9ucR1FRb-Ljj3FyFmaj1Dzi90qeSk5nZCwwXmyh1eiruizwdj9mPCGi8JWg9cFm2wfKR6QBVtnwc3Dzv_INJ09vCKVpT3Z0aX4FSCgOhMQvevqg-jlFkrcYgoBDunkKbeUGqZmk)’.

Manual installation:

# zypper install dnsmasq

Actualizando el servicio SUSE\_Enterprise\_Storage\_2.1\_x86\_64.  
Actualizando el servicio SUSE\_Linux\_Enterprise\_Server\_12\_SP1\_x86\_64.  
Actualizando el servicio SUSE\_OpenStack\_Cloud\_6\_x86\_64.  
Cargando datos del repositorio…  
Leyendo los paquetes instalados…  
Resolviendo dependencias de paquete…

The following NEW package is going to be installed:  
dnsmasq

1 new package to install.  
Tamaño total de descarga: 424,9 KiB. Ya en caché: 0 B. Después de la operación, se utilizarán 1,1 MiB adicionales.  
¿Desea continuar? [s/n/? mostrar todas las opciones] (s): s  
Recuperando package dnsmasq-2.71-10.1.x86\_64 (1/1), 424,9 KiB ( 1,1 MiB desempaquetado)  
Recuperando: dnsmasq-2.71-10.1.x86\_64.rpm …[TERMINADO]  
Buscando conflictos de archivos: …[TERMINADO]  
(1/1) Instalando: dnsmasq-2.71-10.1.x86\_64 …[TERMINADO]

Then, after running the installation script again, it fails in a different package (same timeout error).

I am wondering why the installation script cannot install the packages successfully. I am using a proxy, being the Admin server IP in the exclusion list.

Thanks!

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [May 16, 2016, 12:56pm UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/4 "2016-05-16T12:56:22Z")

</div>

On 15/05/16 22:34, jfonseca wrote:  
[color=blue]

> Thanks for the quick reply!
> 
> It is a fresh SLES12 SP1 plus SOC6:
> 
> # cat /etc/os-release
> 
> NAME=“SLES”  
> VERSION=“12-SP1”  
> VERSION\_ID=“12.1”  
> PRETTY\_NAME=“SUSE Linux Enterprise Server 12 SP1”  
> ID=“sles”  
> ANSI\_COLOR=“0;32”  
> CPE\_NAME=“cpe:/o:suse:sles:12:sp1”
> 
> The installation script goes ahead after manually installing  
> ruby2.1-rubygem-cstruct, but it is failing on the installation of  
> several other packages.
> 
> For example, from the /var/log/crowbar/install.log:  
> [2016-05-15T23:09:25+02:00] ERROR: Running exception handlers  
> [2016-05-15T23:09:25+02:00] FATAL: Saving node information to  
> /var/chef/cache/failed-run-data.json  
> [2016-05-15T23:09:25+02:00] ERROR: Exception handlers complete  
> [2016-05-15T23:09:25+02:00] FATAL: Stacktrace dumped to  
> /var/chef/cache/chef-stacktrace.out  
> [2016-05-15T23:09:25+02:00] FATAL: Mixlib::ShellOut::ShellCommandFailed:  
> package[dnsmasq] (resolver::default line 37) had an error:  
> Mixlib::ShellOut::ShellCommandFailed: Expected process to exit with [0],  
> but received ‘8’  
> ---- Begin output of zypper-retry --non-interactive install  
> –auto-agree-with-licenses dnsmasq=2.71-10.1 ----  
> STDOUT: Refreshing service ‘SUSE\_Enterprise\_Storage\_2.1\_x86\_64’.  
> Refreshing service ‘SUSE\_Linux\_Enterprise\_Server\_12\_SP1\_x86\_64’.  
> Refreshing service ‘SUSE\_OpenStack\_Cloud\_6\_x86\_64’.  
> Loading repository data…  
> Reading installed packages…  
> Resolving package dependencies…
> 
> The following NEW package is going to be installed:  
> dnsmasq
> 
> 1 new package to install.  
> Overall download size: 424.9 KiB. Already cached: 0 B. After the  
> operation, additional 1.1 MiB will be used.  
> Continue? [y/n/? shows all options] (y): y  
> Retrieving package dnsmasq-2.71-10.1.x86\_64 (1/1), 424.9 KiB ( 1.1 MiB  
> unpacked)  
> Retrieving: dnsmasq-2.71-10.1.x86\_64.rpm [error]  
> Retrying in 30 seconds…  
> Retrieving: dnsmasq-2.71-10.1.x86\_64.rpm [error]  
> Retrying in 30 seconds…  
> Retrieving: dnsmasq-2.71-10.1.x86\_64.rpm [error]  
> Retrying in 30 seconds…  
> Retrieving: dnsmasq-2.71-10.1.x86\_64.rpm [error]  
> Retrying in 30 seconds…  
> STDERR: Timeout exceeded when accessing  
> ‘[https://updates.suse.com/SUSE/Updates/SLE-SERVER/12-SP1/x86\_64/update/x86\_64/dnsmasq-2.71-10.1.x86\_64.rpm?0sLKBynI9ucR1FRb-Ljj3FyFmaj1Dzi90qeSk5nZCwwXmyh1eiruizwdj9mPCGi8JWg9cFm2wfKR6QBVtnwc3Dzv\_INJ09vCKVpT3Z0aX4FSCgOhMQvevqg-jlFkrcYgoBDunkKbeUGqZmk](https://updates.suse.com/SUSE/Updates/SLE-SERVER/12-SP1/x86_64/update/x86_64/dnsmasq-2.71-10.1.x86_64.rpm?0sLKBynI9ucR1FRb-Ljj3FyFmaj1Dzi90qeSk5nZCwwXmyh1eiruizwdj9mPCGi8JWg9cFm2wfKR6QBVtnwc3Dzv_INJ09vCKVpT3Z0aX4FSCgOhMQvevqg-jlFkrcYgoBDunkKbeUGqZmk)’.
> 
> Manual installation:
> 
> # zypper install dnsmasq
> 
> Actualizando el servicio SUSE\_Enterprise\_Storage\_2.1\_x86\_64.  
> Actualizando el servicio SUSE\_Linux\_Enterprise\_Server\_12\_SP1\_x86\_64.  
> Actualizando el servicio SUSE\_OpenStack\_Cloud\_6\_x86\_64.  
> Cargando datos del repositorio…  
> Leyendo los paquetes instalados…  
> Resolviendo dependencias de paquete…
> 
> The following NEW package is going to be installed:  
> dnsmasq
> 
> 1 new package to install.  
> Tamaï¿½o total de descarga: 424,9 KiB. Ya en cachï¿½: 0 B. Despuï¿½s de la  
> operaciï¿½n, se utilizarï¿½n 1,1 MiB adicionales.  
> ï¿½Desea continuar? [s/n/? mostrar todas las opciones] (s): s  
> Recuperando package dnsmasq-2.71-10.1.x86\_64
> 
> (1/1), 424,9 KiB ( 1,1  
> MiB desempaquetado)  
> Recuperando: dnsmasq-2.71-10.1.x86\_64.rpm  
> …[TERMINADO]  
> Buscando conflictos de archivos:  
> …[TERMINADO]  
> (1/1) Instalando: dnsmasq-2.71-10.1.x86\_64  
> …[TERMINADO]
> 
> Then, after running the installation script again, it fails in a  
> different package (same timeout error).
> 
> I am wondering why the installation script cannot install the packages  
> successfully. I am using a proxy, being the Admin server IP in the  
> exclusion list.[/color]

Since the ruby2.1-rubygem-cstruct package is part of the SOC6 media/pool  
I’m wondering whether you’ve set up the local repo(s) or access to  
remote ones as per  
[https://www.suse.com/documentation/suse-openstack-cloud-6/book\_cloud\_deploy/data/sec\_depl\_adm\_conf\_repos\_product.html](https://www.suse.com/documentation/suse-openstack-cloud-6/book_cloud_deploy/data/sec_depl_adm_conf_repos_product.html)  
although install-suse-cloud should complain if not.

I’ve certainly had no issues installing a test cloud setup using just  
the SLES12 SP1 and SOC6 media (i.e. no updates applied).

Are you using the media to install SOC6 or a network source? It’s  
possible the SOC6 media is faulty (did you verify the MD5 checksum?) as  
I’ve seen that cause odd things with plain SLES installs.

## HTH.

Simon  
SUSE Knowledge Partner

* * *

## If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below. Thanks.

---

<div class="post-metadata">

**Author:** ![HvdHeuvel](https://avatars.discourse-cdn.com/v4/letter/h/3da27b/32.png) [@HvdHeuvel](https://forums.suse.com/u/HvdHeuvel)\
**Post date:** [May 18, 2016, 12:47pm UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/5 "2016-05-18T12:47:23Z")

</div>

On Sun, 15 May 2016 21:34:01 +0000, jfonseca wrote:

Hi Jfonseca[color=blue]

> It is a fresh SLES12 SP1 plus SOC6:[/color]  
> […][color=blue]  
> The installation script goes ahead after manually installing  
> ruby2.1-rubygem-cstruct, but it is failing on the installation of  
> several other packages.[/color]

[…]  
[color=blue]

> Then, after running the installation script again, it fails in a  
> different package (same timeout error).[/color]

yes, after installing this manually, I presume the next one missing was  
bridge-utils, than dhcp-server etc ?  
[color=blue]

> I am wondering why the installation script cannot install the packages  
> successfully. I am using a proxy, being the Admin server IP in the  
> exclusion list.[/color]

I think I have run into this exact same problem earlier this week. In my  
case the problem was that during the install, my repositories were no  
longer accessible, and these must be available as additional packages are  
installed.

## It is an educated guess, that earlier in the log file, you will also see for example the following messages : — cut here — Mixlib::ShellOut::ShellCommandFailed

Expected process to exit with [0], but received ‘104’  
---- Begin output of zypper-retry --non-interactive install --auto-agree-  
with-licenses ruby2.1-rubygem-cstruct ----  
— cut here —

Fortunately, I was running the setup in a VM, and I just added two CDROMS  
devices, one for the SLE12 SP1 iso, and one for the ClOUD6 iso.

After this, installation run through just fine.

Thanks  
Hans

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [May 19, 2016, 1:06am UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/6 "2016-05-19T01:06:12Z")

</div>

On 18/05/2016 10:47, Hans van den Heuvel wrote:  
[color=blue]

> I think I have run into this exact same problem earlier this week. In my  
> case the problem was that during the install, my repositories were no  
> longer accessible, and these must be available as additional packages are  
> installed.
> 
> ## It is an educated guess, that earlier in the log file, you will also see for example the following messages : — cut here — Mixlib::ShellOut::ShellCommandFailed
> 
> Expected process to exit with [0], but received ‘104’  
> ---- Begin output of zypper-retry --non-interactive install --auto-agree-  
> with-licenses ruby2.1-rubygem-cstruct ----  
> — cut here —
> 
> Fortunately, I was running the setup in a VM, and I just added two CDROMS  
> devices, one for the SLE12 SP1 iso, and one for the ClOUD6 iso.
> 
> After this, installation run through just fine.[/color]

Do you recall whether you had copied the contents of the attached media  
as per section 5.1 of the SUSE OpenStack Cloud 6 Deployment Guide[1]?

I did then pointed YaST/zypper at those directories in preference to the  
attached media so that I could then detach them.

HTH.

## [1] [https://www.suse.com/documentation/suse-openstack-cloud-6/book\_cloud\_deploy/data/sec\_depl\_adm\_conf\_repos\_product.html](https://www.suse.com/documentation/suse-openstack-cloud-6/book_cloud_deploy/data/sec_depl_adm_conf_repos_product.html)

Simon  
SUSE Knowledge Partner

---

<div class="post-metadata">

**Author:** ![HvdHeuvel](https://avatars.discourse-cdn.com/v4/letter/h/3da27b/32.png) [@HvdHeuvel](https://forums.suse.com/u/HvdHeuvel)\
**Post date:** [May 19, 2016, 9:40am UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/7 "2016-05-19T09:40:28Z")

</div>

On Wed, 18 May 2016 22:06:12 +0000, Simon Flood wrote:

[…][color=blue]

> Do you recall whether you had copied the contents of the attached media  
> as per section 5.1 of the SUSE OpenStack Cloud 6 Deployment Guide[1]?
> 
> I did then pointed YaST/zypper at those directories in preference to the  
> attached media so that I could then detach them.[/color]

Yes, I did most definitely follow the Deployment guide 🙂  
Just donÂ´t recall any more if I modified the repo preferences.

But I am convinced the problems for jfonseca will be resolved if the  
repositories are properly available during Â´install-suse-cloudÂ´

[…]

Thanks  
Hans

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [May 19, 2016, 11:03am UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/8 "2016-05-19T11:03:08Z")

</div>

On 19/05/16 07:40, Hans van den Heuvel wrote:  
[color=blue]

> Yes, I did most definitely follow the Deployment guide 🙂  
> Just donÂ´t recall any more if I modified the repo preferences.[/color]

I may be able to test that myself.  
[color=blue]

> But I am convinced the problems for jfonseca will be resolved if the  
> repositories are properly available during Â´install-suse-cloudÂ´[/color]

That was also my thought.

## Thanks.

Simon  
SUSE Knowledge Partner

* * *

## If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below. Thanks.

---

<div class="post-metadata">

**Author:** ![jfonseca](https://avatars.discourse-cdn.com/v4/letter/j/e68b1a/32.png) [@jfonseca](https://forums.suse.com/u/jfonseca)\
**Post date:** [May 20, 2016, 6:18pm UTC](https://forums.suse.com/t/install-suse-cloud-failure/28166/9 "2016-05-20T18:18:53Z")

</div>

As per you comments, I have probably missed any steps. I tried to follow the guide and I recall to copy the media. I will repeat the installation to see if there is any difference.

Thanks,

Juanjo.
