# Issue with registering custom aws host

**URL:** https://forums.suse.com/t/issue-with-registering-custom-aws-host/10274
**Category:** Rancher 2.0 Tech Preview
**Created:** [May 3, 2018, 11:06pm UTC](https://forums.suse.com/t/issue-with-registering-custom-aws-host/10274 "2018-05-03T23:06:25Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![jlee](https://avatars.discourse-cdn.com/v4/letter/j/898d66/32.png) [@jlee](https://forums.suse.com/u/jlee)
#### Post date: [May 3, 2018, 11:06pm UTC](https://forums.suse.com/t/issue-with-registering-custom-aws-host/10274/1 "2018-05-03T23:06:25Z")

</div>

seeing following error in logs.

I0503 22:49:19.395980 18850 mount\_linux.go:196] Detected OS without systemd  
W0503 22:49:19.396164 18850 cni.go:171] Unable to update cni config: No networks found in /etc/cni/net.d  
I0503 22:49:19.399496 18850 server.go:376] Version: v1.10.1  
I0503 22:49:19.399532 18850 feature\_gate.go:226] feature gates: &{{} map[MountPropagation:false]}  
I0503 22:49:19.399684 18850 aws.go:1026] Building AWS cloudprovider  
I0503 22:49:19.399773 18850 aws.go:988] Zone not specified in configuration file; querying AWS metadata service  
F0503 22:49:19.402206 18850 server.go:233] failed to run Kubelet: could not init cloud provider “aws”: error finding instance i-0a44d84b17829a286: “error listing AWS instances: “NoCredentialProviders: no valid providers in chain. Deprecated.\n\tFor verbose messaging see aws.Config.CredentialsChainVerboseErrors””

---

<div class="post-metadata">

### Author: ![jlee](https://avatars.discourse-cdn.com/v4/letter/j/898d66/32.png) [@jlee](https://forums.suse.com/u/jlee)
#### Post date: [May 4, 2018, 4:33pm UTC](https://forums.suse.com/t/issue-with-registering-custom-aws-host/10274/2 "2018-05-04T16:33:22Z")

</div>

oh, some of port required was blocking… RTFM.  
I was able to bring up aws custom cluster through UI,

[https://rancher.com/docs/rancher/v2.0/en/quick-start-guide/#host-and-node-requirements](https://rancher.com/docs/rancher/v2.0/en/quick-start-guide/#host-and-node-requirements)

thanks for awesome job guys.
