# jabberd service faild

**URL:** <https://forums.suse.com/t/jabberd-service-faild/30453>\
**Category:** SUSE Multi Linux Manager\
**Created:** [October 18, 2017, 5:04pm UTC](https://forums.suse.com/t/jabberd-service-faild/30453 "2017-10-18T17:04:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mayas](https://avatars.discourse-cdn.com/v4/letter/m/ee7513/32.png) [@mayas](https://forums.suse.com/u/mayas)\
**Post date:** [October 18, 2017, 5:04pm UTC](https://forums.suse.com/t/jabberd-service-faild/30453/1 "2017-10-18T17:04:53Z")

</div>

Hi,  
on my Suma Proxy the jabberd.service failed

sumaproxyserver:~ # systemctl status jabberd.service  
● jabberd.service - Jabber Server  
Loaded: loaded (/usr/lib/systemd/system/jabberd.service; enabled; vendor preset: disabled)  
[COLOR="#FF0000"][/COLOR][B] Active: inactive /B since Tue 2017-10-17 11:15:17 CEST; 1 day 4h ago  
Process: 5884 ExecStart=/bin/true (code=exited, status=0/SUCCESS)  
Main PID: 5884 (code=exited, status=0/SUCCESS)

Oct 17 11:15:17 sumaproxyserver systemd[1]: Starting Jabber Server…  
Oct 17 11:15:17 sumaproxyserver systemd[1]: Started Jabber Server.  
Oct 17 11:15:17 sumaproxyserver systemd[1]: jabberd.service: Unit is bound to inactive unit jabberd-sm.service. Stopping, too.  
Oct 17 11:15:17 sumaproxyserver systemd[1]: Stopped Jabber Server.

I have this problem at a other suma proxy and the solution was, i configure the proxy again and its works but in this time it not works

Do you have any idee?

Thanks

Murat

---

<div class="post-metadata">

**Author:** ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)\
**Post date:** [October 18, 2017, 5:35pm UTC](https://forums.suse.com/t/jabberd-service-faild/30453/2 "2017-10-18T17:35:58Z")

</div>

Hi  
If you grep the journal/logs;

```auto
journalctl -x --no-pager |grep jabberd
```

Do you see;

```auto
jabberd/c2s[2145]: db: corruption detected! close all jabberd processes and run db_recover
```

Run db\_recover and restart the services and see how that goes.

---

<div class="post-metadata">

**Author:** ![mayas](https://avatars.discourse-cdn.com/v4/letter/m/ee7513/32.png) [@mayas](https://forums.suse.com/u/mayas)\
**Post date:** [October 19, 2017, 7:51am UTC](https://forums.suse.com/t/jabberd-service-faild/30453/3 "2017-10-19T07:51:23Z")

</div>

Hi,  
i have this on my logs:

Oct 19 06:43:28 sumaproxyserver jabberd/router[27606]: starting up  
Oct 19 06:43:28 sumaproxyserver jabberd/router[27606]: process id is 27606, written to /var/lib/jabberd/pid/router.pid  
Oct 19 06:43:28 sumaproxyserver jabberd/router[27606]: loaded user table (1 users)  
Oct 19 06:43:28 sumaproxyserver jabberd/router[27606]: loaded filters (0 rules)  
Oct 19 06:43:28 sumaproxyserver jabberd/sm[27603]: starting up  
Oct 19 06:43:28 sumaproxyserver jabberd/router[27606]: [0.0.0.0, port=5347] listening for incoming connections  
Oct 19 06:43:28 sumaproxyserver jabberd/sm[27603]: couldn’t open /var/run/jabberd/jabberd-sm.pid for writing: No such file or directory  
Oct 19 06:43:28 sumaproxyserver systemd[1]: jabberd-sm.service: Main process exited, code=exited, status=1/FAILURE  
Oct 19 06:43:28 sumaproxyserver jabberd/sm[27603]: loading ‘sqlite’ storage module  
Oct 19 06:43:28 sumaproxyserver jabberd/sm[27603]: sqlite: invalid driver config  
Oct 19 06:43:28 sumaproxyserver jabberd/sm[27603]: initialisation of storage driver ‘sqlite’ failed  
Oct 19 06:43:28 sumaproxyserver systemd[1]: jabberd-sm.service: Unit entered failed state.  
Oct 19 06:43:28 sumaproxyserver jabberd/sm[27603]: failed to initialise one or more storage drivers, aborting  
Oct 19 06:43:28 sumaproxyserver systemd[1]: jabberd-sm.service: Failed with result ‘exit-code’.  
– Subject: Unit jabberd-router.service has finished start-up  
– Unit jabberd-router.service has finished starting up.  
– Subject: Unit jabberd-s2s.service has finished start-up  
– Unit jabberd-s2s.service has finished starting up.  
– Subject: Unit jabberd-c2s.service has finished start-up  
– Unit jabberd-c2s.service has finished starting up.  
– Subject: Unit jabberd.service has begun start-up  
– Unit jabberd.service has begun starting up.  
Oct 19 06:43:29 sumaproxyserver jabberd/s2s[27612]: starting up (interval=3, queue=60, keepalive=0, idle=86400)  
Oct 19 06:43:29 sumaproxyserver jabberd/s2s[27612]: process id is 27612, written to /var/lib/jabberd/pid/s2s.pid  
Oct 19 06:43:29 sumaproxyserver jabberd/s2s[27612]: attempting connection to router at 127.0.0.1, port=5347  
Oct 19 06:43:29 sumaproxyserver jabberd/router[27606]: [127.0.0.1, port=46896] connect  
– Subject: Unit jabberd.service has finished start-up  
– Unit jabberd.service has finished starting up.  
Oct 19 06:43:29 sumaproxyserver systemd[1]: jabberd.service: Unit is bound to inactive unit jabberd-sm.service. Stopping, too.  
Oct 19 06:43:29 sumaproxyserver jabberd/router[27606]: [127.0.0.1, port=46896] authenticated as jabberd@jabberd-router  
Oct 19 06:43:29 sumaproxyserver jabberd/s2s[27612]: connection to router established  
Oct 19 06:43:29 sumaproxyserver jabberd/router[27606]: [s2s] set as default route  
Oct 19 06:43:29 sumaproxyserver jabberd/router[27606]: [s2s] online (bound to 127.0.0.1, port 46896)  
Oct 19 06:43:29 sumaproxyserver jabberd/c2s[27615]: modules search path undefined, using default: /usr/lib64/jabberd  
Oct 19 06:43:29 sumaproxyserver jabberd/c2s[27615]: loading ‘sqlite’ authreg module  
Oct 19 06:43:29 sumaproxyserver jabberd/c2s[27615]: sqlite (authreg): invalid driver config.  
Oct 19 06:43:29 sumaproxyserver jabberd/c2s[27615]: failed to initialize auth module ‘sqlite’  
Oct 19 06:43:29 sumaproxyserver systemd[1]: jabberd-c2s.service: Main process exited, code=exited, status=1/FAILURE  
– Subject: Unit jabberd-c2s.service has finished shutting down  
– Unit jabberd-c2s.service has finished shutting down.  
Oct 19 06:43:29 sumaproxyserver systemd[1]: jabberd-c2s.service: Unit entered failed state.  
Oct 19 06:43:29 sumaproxyserver systemd[1]: jabberd-c2s.service: Failed with result ‘exit-code’.  
– Subject: Unit jabberd.service has finished shutting down  
– Unit jabberd.service has finished shutting down.  
– Subject: Unit jabberd-s2s.service has begun shutting down  
– Unit jabberd-s2s.service has begun shutting down.  
Oct 19 06:43:29 sumaproxyserver jabberd/s2s[27612]: shutting down  
Oct 19 06:43:29 sumaproxyserver jabberd/s2s[27612]: connection to router closed  
Oct 19 06:43:29 sumaproxyserver jabberd/router[27606]: [127.0.0.1, port=46896] disconnect  
Oct 19 06:43:29 sumaproxyserver jabberd/router[27606]: [s2s] default route offline  
Oct 19 06:43:29 sumaproxyserver jabberd/router[27606]: [s2s] offline  
– Subject: Unit jabberd-s2s.service has finished shutting down  
– Unit jabberd-s2s.service has finished shutting down.  
Oct 19 06:43:29 sumaproxyserver jabberd/router[27606]: shutting down  
– Subject: Unit jabberd-router.service has begun shutting down  
– Unit jabberd-router.service has begun shutting down.  
– Subject: Unit jabberd-router.service has finished shutting down  
– Unit jabberd-router.service has finished shutting down.

---

<div class="post-metadata">

**Author:** ![kwk](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/kwk/32/11997_2.png) [@kwk](https://forums.suse.com/u/kwk)\
**Post date:** [October 19, 2017, 8:53am UTC](https://forums.suse.com/t/jabberd-service-faild/30453/4 "2017-10-19T08:53:21Z")

</div>

[QUOTE=mayas;39942]…  
Oct 19 06:43:28 sumaproxyserver jabberd/sm[27603]: sqlite: invalid driver config  
Oct 19 06:43:28 sumaproxyserver jabberd/sm[27603]: initialisation of storage driver ‘sqlite’ failed  
…[/QUOTE]

Uhm, I’d suggest to open a service request and provide a supportconfig. Something’s weird with your proxy installation/configuration.
