# K3s on ubuntu vm

**URL:** <https://forums.suse.com/t/k3s-on-ubuntu-vm/37951>\
**Category:** Rancher 1.x\
**Created:** [May 20, 2022, 3:44pm UTC](https://forums.suse.com/t/k3s-on-ubuntu-vm/37951 "2022-05-20T15:44:01Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![slakkur](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/slakkur/32/9020_2.png) [@slakkur](https://forums.suse.com/u/slakkur)\
**Post date:** [May 20, 2022, 3:44pm UTC](https://forums.suse.com/t/k3s-on-ubuntu-vm/37951/1 "2022-05-20T15:44:01Z")

</div>

Hello Everyone,

I have installed k3s on a ubuntu vm.  
Is it possible to have k3s server and k3s agent on the same machine?  
If so, what steps are required to configure?

I tried installing k3s agent on the same machine. When I start to service, it is failing?  
Error is “Address already in use”  
Please help.

Regards,  
SL

---

<div class="post-metadata">

**Author:** ![mattmattox](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/mattmattox/32/5503_2.png) [@mattmattox](https://forums.suse.com/u/mattmattox)\
**Post date:** [May 20, 2022, 3:59pm UTC](https://forums.suse.com/t/k3s-on-ubuntu-vm/37951/2 "2022-05-20T15:59:05Z")

</div>

K3s and RKE2 master nodes are worker node by default unless you taint them. The agent flag mainly just sets the node role to worker instead of master/control-plane/etcd. So you only need to run the k3s installer on the node once.

---

<div class="post-metadata">

**Author:** ![slakkur](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/slakkur/32/9020_2.png) [@slakkur](https://forums.suse.com/u/slakkur)\
**Post date:** [May 20, 2022, 4:18pm UTC](https://forums.suse.com/t/k3s-on-ubuntu-vm/37951/3 "2022-05-20T16:18:20Z")

</div>

When I list the nodes, I see only master role. Is it fine? can we deploy pods ?  
seeing following error

Failed to bind volumes: timed out waiting for the condition

---

<div class="post-metadata">

**Author:** ![mattmattox](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/mattmattox/32/5503_2.png) [@mattmattox](https://forums.suse.com/u/mattmattox)\
**Post date:** [May 21, 2022, 10:58am UTC](https://forums.suse.com/t/k3s-on-ubuntu-vm/37951/4 "2022-05-21T10:58:48Z")

</div>

Yes, you should be fine to deploy your pods. The error your getting about the volume is a different issue.

Would you mind sharing your deployment YAML? I’m guessing it’s trying to bind mount to a directory on the host that doesn’t exist or something like that.

---

<div class="post-metadata">

**Author:** ![slakkur](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/slakkur/32/9020_2.png) [@slakkur](https://forums.suse.com/u/slakkur)\
**Post date:** [May 21, 2022, 4:06pm UTC](https://forums.suse.com/t/k3s-on-ubuntu-vm/37951/5 "2022-05-21T16:06:26Z")

</div>

![image](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/c/cbd7039cf250857cfa0e700e5c4393b543a18764.png)  
Seeing error while describing pvc name
