# K3sup join unable to get token

**URL:** <https://forums.suse.com/t/k3sup-join-unable-to-get-token/43885>\
**Category:** k3s, k3OS, and k3d\
**Created:** [August 20, 2024, 4:29pm UTC](https://forums.suse.com/t/k3sup-join-unable-to-get-token/43885 "2024-08-20T16:29:01Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![uek67](https://avatars.discourse-cdn.com/v4/letter/u/919ad9/32.png) [@uek67](https://forums.suse.com/u/uek67)\
**Post date:** [August 20, 2024, 4:29pm UTC](https://forums.suse.com/t/k3sup-join-unable-to-get-token/43885/1 "2024-08-20T16:29:01Z")

</div>

Hi folks,

after I fixed my ssh problem with k3sup install setting PasswordAthentication on no and PermitRootLogin without-password in the destination node sshd\_config I have another similar problem with the k3s join command as it seems.

192.168.10.xx is my master-node 192.168.10.yy the remote host on which I would like to install k3s on.

Trying: `k3sup join --ip 192.168.10.59 --user root --server-user root --server-ip 192.168.10.48 --server`  
I get:

```auto
Running: k3sup join
Joining 192.168.10.59 => 192.168.10.48
Error: unable to get join-token from server: Process exited

```

SSHD\_CONFIG is the same as with k3sup install - changing it didn´t solved the problem. So what do I have to change or add to make k3sup join running?

Many thanks in Advance  
Uli
