# Let's Encrypt failed to start

**URL:** <https://forums.suse.com/t/lets-encrypt-failed-to-start/3219>\
**Category:** Rancher 1.x\
**Created:** [June 27, 2016, 2:03am UTC](https://forums.suse.com/t/lets-encrypt-failed-to-start/3219 "2016-06-27T02:03:23Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![younes](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/younes/32/1448_2.png) [@younes](https://forums.suse.com/u/younes)\
**Post date:** [June 27, 2016, 2:03am UTC](https://forums.suse.com/t/lets-encrypt-failed-to-start/3219/1 "2016-06-27T02:03:24Z")

</div>

Hi,  
I tried to use the Let’s Encrypt service from the Rancher Catalog but it ended with the error :

`27/06/2016 01:56:48level=info msg="Starting Let's Encrypt Certificate Manager v0.3.0 f8965f6" 27/06/2016 01:56:48level=fatal msg="Required environment variable not set: CATTLE_URL"`

Any idea why the CATTLE\_URL is not set, I’m using the Cattle environment by the way.  
Thanks in advance.  
/Y

---

<div class="post-metadata">

**Author:** ![younes](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/younes/32/1448_2.png) [@younes](https://forums.suse.com/u/younes)\
**Post date:** [June 29, 2016, 2:33pm UTC](https://forums.suse.com/t/lets-encrypt-failed-to-start/3219/2 "2016-06-29T14:33:42Z")

</div>

To answer my own question, it does seem to work when resetting the labels :  
io.rancher.container.create\_agent: 'true’  
io.rancher.container.agent.role: environment  
Sometimes, Rancher loses this labels after a container upgrade.

---

<div class="post-metadata">

**Author:** ![denise](https://avatars.discourse-cdn.com/v4/letter/d/82dd89/32.png) [@denise](https://forums.suse.com/u/denise)\
**Post date:** [July 1, 2016, 5:50pm UTC](https://forums.suse.com/t/lets-encrypt-failed-to-start/3219/3 "2016-07-01T17:50:42Z")

</div>

Created this issue to address waht you’re seeing. Long story short, we don’t automatically copy over any `io.container` labels, they need some kind of UI equivalent for them to be upgraded/cloned.

> <https://github.com/rancher/rancher/issues/5286>

---

<div class="post-metadata">

**Author:** ![younes](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/younes/32/1448_2.png) [@younes](https://forums.suse.com/u/younes)\
**Post date:** [July 2, 2016, 6:55pm UTC](https://forums.suse.com/t/lets-encrypt-failed-to-start/3219/4 "2016-07-02T18:55:51Z")

</div>

Hi @denise,  
I didn’t notice that those labels wasn’t automatically added after a upgrade.  
Thanks for the issue on github.  
Cheers,  
/Y
