# mount.nfs: access denied by server while mounting

**URL:** <https://forums.suse.com/t/mount-nfs-access-denied-by-server-while-mounting/21914>\
**Category:** SLES Configure-Administer\
**Created:** [December 28, 2011, 10:36am UTC](https://forums.suse.com/t/mount-nfs-access-denied-by-server-while-mounting/21914 "2011-12-28T10:36:02Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![System1](https://avatars.discourse-cdn.com/v4/letter/s/51bf81/32.png) [@System1](https://forums.suse.com/u/System1)\
**Post date:** [December 28, 2011, 10:36am UTC](https://forums.suse.com/t/mount-nfs-access-denied-by-server-while-mounting/21914/1 "2011-12-28T10:36:02Z")

</div>

server A name:crmprd1  
server B name:crmprd2

now server B is NFS server and severA is NFS client.

crmprd1:/# mount -t nfs crmprd2:/nfs\_out /sapmnt-----------------OK ,no  
problem.

but

crmprd2:~ # mount -t nfs crmprd2:/nfs\_out /sapmnt  
mount.nfs: access denied by server while mounting  
crmprd2:/nfs\_out---------can’t mount.

i think maybe NFS server and client on the same compter.

somebody know how to config enable the NFS server and client on the  
same compter is OK.

## – hunterworf

hunterworf’s Profile: [http://forums.novell.com/member.php?userid=121823](http://forums.novell.com/member.php?userid=121823)  
View this thread: [http://forums.novell.com/showthread.php?t=450051](http://forums.novell.com/showthread.php?t=450051)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [January 3, 2012, 10:22pm UTC](https://forums.suse.com/t/mount-nfs-access-denied-by-server-while-mounting/21914/2 "2012-01-03T22:22:15Z")

</div>

hunterworf,

It appears that in the past few days you have not received a response to your  
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit [http://support.novell.com](http://support.novell.com) and search the knowledgebase and/or check all  
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the  
correct newsgroup. ([http://forums.novell.com](http://forums.novell.com))

Be sure to read the forum FAQ about what to expect in the way of responses:  
[http://forums.novell.com/faq.php](http://forums.novell.com/faq.php)

If this is a reply to a duplicate posting, please ignore and accept our apologies  
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team  
[http://forums.novell.com/](http://forums.novell.com/)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [January 4, 2012, 1:26am UTC](https://forums.suse.com/t/mount-nfs-access-denied-by-server-while-mounting/21914/3 "2012-01-04T01:26:01Z")

</div>

[color=blue]

> somebody know how to config enable the NFS server and client on the[/color]  
> same compter is OK.

Normally that should be okay to do without any unusual configuration.

Can you supply the /etc/exports file from crmprd2 which shows how it is  
exported? Maybe it shared with syntax to allow crmprd1 but not  
crmprd2?

Does crmprd2 have an entry for itself in /etc/hosts?

What version of SLES is this? If this is SLES 11 SP2 beta then there  
were some known issue doing ‘local’ mounts during beta.  
And besides SLES version, give SP level and kernel version.

## – dpartrid

dpartrid’s Profile: [http://forums.novell.com/member.php?userid=18260](http://forums.novell.com/member.php?userid=18260)  
View this thread: [http://forums.novell.com/showthread.php?t=450051](http://forums.novell.com/showthread.php?t=450051)
