# MountVolume.MountDevice failed after Node restart

**URL:** <https://forums.suse.com/t/mountvolume-mountdevice-failed-after-node-restart/44863>\
**Category:** SUSE Storage\
**Created:** [December 27, 2024, 1:51pm UTC](https://forums.suse.com/t/mountvolume-mountdevice-failed-after-node-restart/44863 "2024-12-27T13:51:48Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![gunther\_alfred](https://avatars.discourse-cdn.com/v4/letter/g/7bcc69/32.png) [@gunther\_alfred](https://forums.suse.com/u/gunther_alfred)\
**Post date:** [December 27, 2024, 1:51pm UTC](https://forums.suse.com/t/mountvolume-mountdevice-failed-after-node-restart/44863/1 "2024-12-27T13:51:48Z")

</div>

Hello together,

I hope I can find some help here:  
Every once and then I stumble upon the issue, that a pod can not mount a longhorn volume (encrypted) after a node restart / update of a node. I receive the following message:

`MountVolume.MountDevice failed for volume "pvc-592bb0e6-42b9-43f5-a3b2-638a5444479b" : rpc error: code = Internal desc = failed to execute: /usr/bin/nsenter [nsenter --mount=/host/proc/5038/ns/mnt --ipc=/host/proc/5038/ns/ipc cryptsetup luksOpen /dev/longhorn/pvc-592bb0e6-42b9-43f5-a3b2-638a5444479b pvc-592bb0e6-42b9-43f5-a3b2-638a5444479b -d /dev/stdin], output , stderr Cannot use device /dev/longhorn/pvc-592bb0e6-42b9-43f5-a3b2-638a5444479b which is in use (already mapped or mounted). : exit status 5`

I already checked everywhere, but this volume is not used by any other pod / process.  
I use 4 nodes with rke2 (v1.30.6+rke2r1) and longhorn (v1.7.2).  
I already tried to close the cryptsetup with no success (cryptsetup close pvc-592bb0e6-42b9-43f5-a3b2-638a5444479b).  
I also tried to restart the pod - no effect.

Has anybody discovered the same issue and can help me out?  
Thank you in advance.

---

<div class="post-metadata">

**Author:** ![shuo-wu](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/shuo-wu/32/6426_2.png) [@shuo-wu](https://forums.suse.com/u/shuo-wu)\
**Post date:** [January 3, 2025, 7:21pm UTC](https://forums.suse.com/t/mountvolume-mountdevice-failed-after-node-restart/44863/2 "2025-01-03T19:21:13Z")

</div>

Would you check if it is caused by multipathd?

> **[Longhorn | Troubleshooting: \`MountVolume.SetUp failed for volume\` due to...](https://longhorn.io/kb/troubleshooting-volume-with-multipath/)**

---

<div class="post-metadata">

**Author:** ![gunther\_alfred](https://avatars.discourse-cdn.com/v4/letter/g/7bcc69/32.png) [@gunther\_alfred](https://forums.suse.com/u/gunther_alfred)\
**Post date:** [January 15, 2025, 11:09am UTC](https://forums.suse.com/t/mountvolume-mountdevice-failed-after-node-restart/44863/3 "2025-01-15T11:09:19Z")

</div>

Thank you for the answer. As this is a sporadic issue, it is hard to test, but I will apply the solution of your link and check if it happens again.

---

<div class="post-metadata">

**Author:** ![gunther\_alfred](https://avatars.discourse-cdn.com/v4/letter/g/7bcc69/32.png) [@gunther\_alfred](https://forums.suse.com/u/gunther_alfred)\
**Post date:** [January 27, 2025, 9:35am UTC](https://forums.suse.com/t/mountvolume-mountdevice-failed-after-node-restart/44863/4 "2025-01-27T09:35:53Z")

</div>

Since I deactivated multipathd, I did not discover a problem like that again. I hope this fix solved it forever. Thank you.
