# MS SQL Server on SLES 12 SP4 - Error code 0x2746

**URL:** https://forums.suse.com/t/ms-sql-server-on-sles-12-sp4-error-code-0x2746/34319
**Category:** SLES Configure-Administer
**Created:** [August 28, 2019, 5:22pm UTC](https://forums.suse.com/t/ms-sql-server-on-sles-12-sp4-error-code-0x2746/34319 "2019-08-28T17:22:13Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![AndersG](https://avatars.discourse-cdn.com/v4/letter/a/54ee81/32.png) [@AndersG](https://forums.suse.com/u/AndersG)
#### Post date: [August 28, 2019, 5:22pm UTC](https://forums.suse.com/t/ms-sql-server-on-sles-12-sp4-error-code-0x2746/34319/1 "2019-08-28T17:22:13Z")

</div>

Has anyone succeded in getting it to work? I get as far as it starting but cannot connect:

sle12sql2017:/opt/mssql/lib # sqlcmd -S 1.1.1.1 -U sa -P \*\*\*\*\*\*\*  
Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : TCP Provider: Error code 0x2746.  
Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : Client unable to establish connection.

Other info on the web hint to openssl incompatibilities and suggest installing an older version, but it does not help. Above command CAN connet to other SQL Servers running on other machines.

---

<div class="post-metadata">

### Author: ![AndersG](https://avatars.discourse-cdn.com/v4/letter/a/54ee81/32.png) [@AndersG](https://forums.suse.com/u/AndersG)
#### Post date: [August 28, 2019, 7:25pm UTC](https://forums.suse.com/t/ms-sql-server-on-sles-12-sp4-error-code-0x2746/34319/2 "2019-08-28T19:25:55Z")

</div>

[QUOTE=AndersG;58380]Has anyone succeded in getting it to work? I get as far as it starting but cannot connect:

sle12sql2017:/opt/mssql/lib # sqlcmd -S 1.1.1.1 -U sa -P \*\*\*\*\*\*\*  
Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : TCP Provider: Error code 0x2746.  
Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : Client unable to establish connection.

Other info on the web hint to openssl incompatibilities and suggest installing an older version, but it does not help. Above command CAN connet to other SQL Servers running on other machines.[/QUOTE]

FWIW. Installing an older version on SLES 12 SP2 seems to work though?

`sudo zypper addrepo -fc https://packages.microsoft.com/config/sles/12/mssql-server-2017.repo
sudo zypper --gpg-auto-import-keys refresh 
sudo zypper install -y mssql-server=14.0.3192.2-2
sudo /opt/mssql/bin/mssql-conf setup`

then install the tools as per: [https://docs.microsoft.com/sv-se/sql/linux/quickstart-install-connect-suse?view=sql-server-2017](https://docs.microsoft.com/sv-se/sql/linux/quickstart-install-connect-suse?view=sql-server-2017)

Then:

```auto
sqlcmd -S 10.10.10.10 -U SA -P password
```

localhost will not work

---

<div class="post-metadata">

### Author: ![strahil-nikolov-dxc](https://avatars.discourse-cdn.com/v4/letter/s/58956e/32.png) [@strahil-nikolov-dxc](https://forums.suse.com/u/strahil-nikolov-dxc)
#### Post date: [September 17, 2019, 8:35am UTC](https://forums.suse.com/t/ms-sql-server-on-sles-12-sp4-error-code-0x2746/34319/3 "2019-09-17T08:35:10Z")

</div>

According to [this one](https://stackoverflow.com/questions/57265913/error-tcp-provider-error-code-0x2746-during-the-sql-setup-in-linux-through-te) you can try to downgrade the openssl package.

---

<div class="post-metadata">

### Author: ![cisaksen](https://avatars.discourse-cdn.com/v4/letter/c/49beb7/32.png) [@cisaksen](https://forums.suse.com/u/cisaksen)
#### Post date: [September 26, 2019, 11:23pm UTC](https://forums.suse.com/t/ms-sql-server-on-sles-12-sp4-error-code-0x2746/34319/4 "2019-09-26T23:23:00Z")

</div>

I don’t believe Microsoft has gone beyond SUSE 12 SP2 for a supported platform yet. [https://docs.microsoft.com/en-us/sql/linux/quickstart-install-connect-suse?view=sql-server-2017](https://docs.microsoft.com/en-us/sql/linux/quickstart-install-connect-suse?view=sql-server-2017)

I know there were packages for MS authentication in SUSE12 SP2 that were removed in SUSE12 SP3. Not sure if that was resolved.  
[https://docs.microsoft.com/en-us/sql/linux/sql-server-linux-active-directory-authentication?view=sql-server-2017](https://docs.microsoft.com/en-us/sql/linux/sql-server-linux-active-directory-authentication?view=sql-server-2017)
