# Multi-container stack

**URL:** <https://forums.suse.com/t/multi-container-stack/10676>\
**Category:** Rancher 1.x\
**Created:** [June 6, 2018, 1:39pm UTC](https://forums.suse.com/t/multi-container-stack/10676 "2018-06-06T13:39:19Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![sigfrid](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/sigfrid/32/2205_2.png) [@sigfrid](https://forums.suse.com/u/sigfrid)\
**Post date:** [June 7, 2018, 9:35am UTC](https://forums.suse.com/t/multi-container-stack/10676/5 "2018-06-07T09:35:13Z")

</div>

@cjellick you are right, I could have multiple hosts with the same label but I don’t. There is only 1 host with the `newapp` label.

the two errors I get are the following.

> thx-app-1 | 2018-06-07T09:22:52.063050743Z PG::ConnectionBad: could not translate host name “db” to address: Name or service not known
> 
> th-proxy-1 | 2018-06-07T08:45:07.965236834Z 2018/06/07 08:45:07 [emerg] 1#1: host not found in upstream “app” in /etc/nginx/conf.d/default.conf:38

if I drop `network_mode: bridge` nothing starts

> INFO[0000] Existing volume template found for postgres-data-volume  
> INFO[0000] [0/3] [db]: Creating  
> INFO[0000] Creating service db  
> INFO[0001] [0/3] [db]: Created  
> INFO[0001] [0/3] [app]: Creating  
> INFO[0001] Creating service app  
> INFO[0002] [0/3] [app]: Created  
> INFO[0002] [0/3] [proxy]: Creating  
> INFO[0002] Creating service proxy  
> INFO[0002] [0/3] [proxy]: Created  
> INFO[0002] Existing volume template found for postgres-data-volume  
> INFO[0002] [0/3] [db]: Starting

until it times out.

I have also tried `io.rancher.container.network: true` but it seems this is ignored. See [Docker compose and managed network](http://forums.suse.com/t/docker-compose-and-managed-network/10665)

Thanks.

---

_[View the full topic](https://forums.suse.com/t/multi-container-stack/10676)._
