# Multinode setup and instance on one compute does'nt get IP

**URL:** <https://forums.suse.com/t/multinode-setup-and-instance-on-one-compute-doesnt-get-ip/27223>\
**Category:** SUSE OpenStack Cloud\
**Created:** [July 8, 2015, 4:44pm UTC](https://forums.suse.com/t/multinode-setup-and-instance-on-one-compute-doesnt-get-ip/27223 "2015-07-08T16:44:05Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![subha](https://avatars.discourse-cdn.com/v4/letter/s/b9e5f3/32.png) [@subha](https://forums.suse.com/u/subha)\
**Post date:** [July 8, 2015, 4:44pm UTC](https://forums.suse.com/t/multinode-setup-and-instance-on-one-compute-doesnt-get-ip/27223/1 "2015-07-08T16:44:05Z")

</div>

Hi,

We have setup SUSE Openstack cloud 5 on three nodes(SLES-11 SP3) configured as below

1. Exclusive admin node (SUSE Crowbar)
2. Compute node - 1 (nova, cinder and neutron services are deployed on this node)
3. Compute node - 2 (nova, cinder are deployed on the node)

We have deployed the services and able to launch instances. But the instances hosted on compute node -2 do not get any IP, but we can see from the dashboard the IP being assigned is  
192.168.123.5. We haved used openvswitch and gre for neutron deployment through openstack barclamps.

## so in brief:

d3c-1e-04-46-f0-3e(Compute node -1) : This node has controller ,cinder ,nova and neutron-server and neutron l3.  
We have launched instance and the instance got an ip 192.168.123.6 successfully.

db8-ca-3a-78-d8-62(Compute node -2) : This node has nova and cinder. We are able to launch instance but no IP so far, but dashboard show the as IP 192.168.123.5

# neutron agent list:

d3c-1e-04-46-f0-3e is controller-compute-cinder-neutron  
db8-ca-3a-78-d8-62 is compute-cinder

root@d3c-1e-04-46-f0-3e:/var/log/neutron # neutron agent-list  
±-------------------------------------±-------------------±-------------------±------±---------------±--------------------------+  
| id | agent\_type | host | alive | admin\_state\_up | binary |  
±-------------------------------------±-------------------±-------------------±------±---------------±--------------------------+  
| 48f53d56-0df9-4245-bcd2-3a484a74ef21 | Open vSwitch agent | db8-ca-3a-78-d8-62 | 🙂 | True | neutron-openvswitch-agent |  
| 3a555579-b31e-4893-bb44-f5871a1e966f | Open vSwitch agent | d3c-1e-04-46-f0-3e | 🙂 | True | neutron-openvswitch-agent |  
| 4dac44cf-5ff6-40c0-a643-ded4ad798282 | L3 agent | d3c-1e-04-46-f0-3e | 🙂 | True | neutron-l3-agent |  
| 7977a63d-d4b4-4436-823d-3fcd0f191c44 | Metering agent | d3c-1e-04-46-f0-3e | 🙂 | True | neutron-metering-agent |  
| 73a34949-9188-474d-86c0-606d30ec7e78 | Loadbalancer agent | d3c-1e-04-46-f0-3e | 🙂 | True | neutron-lbaas-agent |  
| a5617553-525e-4e62-9281-c8290dc74d06 | DHCP agent | d3c-1e-04-46-f0-3e | 🙂 | True | neutron-dhcp-agent |  
| 8fa37573-6b15-4a56-bb3f-e8988a907d91 | Metadata agent | d3c-1e-04-46-f0-3e | 🙂 | True | neutron-metadata-agent |  
±-------------------------------------±-------------------±-------------------±------±---------------±--------------------------+

Here is the output of ifconfig and ovs-vsctl show

## Command on the controller-compute-cinder-neutron node (d3c-1e-04-46-f0-3e):

root@d3c-1e-04-46-f0-3e:/var/log/neutron # ifconfig  
br-int Link encap:Ethernet HWaddr 5A:6C:9C:50:46:41  
inet6 addr: fe80::dc82:f8ff:fe05:6bba/64 Scope:Link  
UP BROADCAST RUNNING MTU:1500 Metric:1  
RX packets:69 errors:0 dropped:0 overruns:0 frame:0  
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:5570 (5.4 Kb) TX bytes:180 (180.0 b)

br-public Link encap:Ethernet HWaddr 3C:1E:04:46:F0:3E  
inet addr:192.168.126.2 Bcast:0.0.0.0 Mask:255.255.255.0  
inet6 addr: fe80::d802:c2ff:fe1f:b14f/64 Scope:Link  
UP BROADCAST RUNNING MTU:1500 Metric:1  
RX packets:75 errors:0 dropped:0 overruns:0 frame:0  
TX packets:83 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:6218 (6.0 Kb) TX bytes:6214 (6.0 Kb)

br-tunnel Link encap:Ethernet HWaddr 36:1B:D7:95:B1:44  
inet6 addr: fe80::5c6a:c3ff:feca:a38f/64 Scope:Link  
UP BROADCAST RUNNING MTU:1500 Metric:1  
RX packets:0 errors:0 dropped:0 overruns:0 frame:0  
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:0 (0.0 b) TX bytes:180 (180.0 b)

eth0 Link encap:Ethernet HWaddr 3C:1E:04:46:F0:3E  
inet addr:192.168.124.82 Bcast:192.168.124.255 Mask:255.255.255.0  
inet6 addr: fe80::3e1e:4ff:fe46:f03e/64 Scope:Link  
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
RX packets:1213179 errors:0 dropped:0 overruns:0 frame:0  
TX packets:1049455 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:1000  
RX bytes:1060292784 (1011.1 Mb) TX bytes:688253405 (656.3 Mb)  
Interrupt:16 Base address:0x8000

eth0.300 Link encap:Ethernet HWaddr 3C:1E:04:46:F0:3E  
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
RX packets:0 errors:0 dropped:0 overruns:0 frame:0  
TX packets:55 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:0 (0.0 b) TX bytes:2758 (2.6 Kb)

eth0.400 Link encap:Ethernet HWaddr 3C:1E:04:46:F0:3E  
inet addr:192.168.130.10 Bcast:0.0.0.0 Mask:255.255.255.0  
inet6 addr: fe80::3e1e:4ff:fe46:f03e/64 Scope:Link  
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
RX packets:0 errors:0 dropped:0 overruns:0 frame:0  
TX packets:63 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:0 (0.0 b) TX bytes:2862 (2.7 Kb)

lo Link encap:Local Loopback  
inet addr:127.0.0.1 Mask:255.0.0.0  
inet6 addr: ::1/128 Scope:Host  
UP LOOPBACK RUNNING MTU:16436 Metric:1  
RX packets:4271974 errors:0 dropped:0 overruns:0 frame:0  
TX packets:4271974 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:2388305793 (2277.6 Mb) TX bytes:2388305793 (2277.6 Mb)

qbr34a229 Link encap:Ethernet HWaddr 2A:AB:18:98:41:01  
inet6 addr: fe80::746c:b2ff:feeb:119/64 Scope:Link  
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
RX packets:18 errors:0 dropped:0 overruns:0 frame:0  
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:1508 (1.4 Kb) TX bytes:468 (468.0 b)

qvb34a229 Link encap:Ethernet HWaddr 2A:AB:18:98:41:01  
inet6 addr: fe80::28ab:18ff:fe98:4101/64 Scope:Link  
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1  
RX packets:8 errors:0 dropped:0 overruns:0 frame:0  
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:1000  
RX bytes:1181 (1.1 Kb) TX bytes:2228 (2.1 Kb)

qvo34a229 Link encap:Ethernet HWaddr 06:E8:90:2B:5B:7E  
inet6 addr: fe80::4e8:90ff:fe2b:5b7e/64 Scope:Link  
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1  
RX packets:24 errors:0 dropped:0 overruns:0 frame:0  
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:1000  
RX bytes:2228 (2.1 Kb) TX bytes:1181 (1.1 Kb)

tap34a229 Link encap:Ethernet HWaddr FE:16:3E:4F:65:8B  
inet6 addr: fe80::fc16:3eff:fe4f:658b/64 Scope:Link  
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
RX packets:13 errors:0 dropped:0 overruns:0 frame:0  
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:500  
RX bytes:1382 (1.3 Kb) TX bytes:1719 (1.6 Kb)

root@d3c-1e-04-46-f0-3e:/var/log/neutron # ovs-vsctl show  
829be784-67e8-4165-baf6-9c3c8cb2d99e  
Bridge br-public  
Port “eth0.300”  
Interface “eth0.300”  
Port br-public  
Interface br-public  
type: internal  
Port “qg-98c2153e-d4”  
Interface “qg-98c2153e-d4”  
type: internal  
Bridge br-int  
fail\_mode: secure  
Port “qr-fc612562-17”  
tag: 1  
Interface “qr-fc612562-17”  
type: internal  
Port patch-tun  
Interface patch-tun  
type: patch  
options: {peer=patch-int}  
Port br-int  
Interface br-int  
type: internal  
Port “qvo34a229d1-a7”  
tag: 1  
Interface “qvo34a229d1-a7”  
Port “tapea878ad9-b4”  
tag: 1  
Interface “tapea878ad9-b4”  
type: internal  
Bridge br-tunnel  
Port patch-int  
Interface patch-int  
type: patch  
options: {peer=patch-tun}  
Port br-tunnel  
Interface br-tunnel  
type: internal  
Port “gre-c0a8820b”  
Interface “gre-c0a8820b”  
type: gre  
options: {df\_default=“true”, in\_key=flow, local\_ip=“192.168.130.10”, out\_key=flow, remote\_ip=“192.168.130.11”}  
ovs\_version: “2.1.2”

## Here is the output of ifconfig and ovs-vsctl show on the other node db8-ca-3a-78-d8-62 (nova and cinder):

br-int Link encap:Ethernet HWaddr 52:28:86:CA:DA:4A  
inet6 addr: fe80::4caf:dff:fef1:43ad/64 Scope:Link  
UP BROADCAST RUNNING MTU:1500 Metric:1  
RX packets:0 errors:0 dropped:0 overruns:0 frame:0  
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:0 (0.0 b) TX bytes:180 (180.0 b)

br-tunnel Link encap:Ethernet HWaddr 2A:FA:10:09:59:44  
inet6 addr: fe80::68f6:b5ff:fe34:e36e/64 Scope:Link  
UP BROADCAST RUNNING MTU:1500 Metric:1  
RX packets:0 errors:0 dropped:0 overruns:0 frame:0  
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:0 (0.0 b) TX bytes:180 (180.0 b)

eth0 Link encap:Ethernet HWaddr B8:CA:3A:78:D8:62  
inet addr:192.168.124.81 Bcast:192.168.124.255 Mask:255.255.255.0  
inet6 addr: fe80::baca:3aff:fe78:d862/64 Scope:Link  
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
RX packets:8012 errors:0 dropped:0 overruns:0 frame:0  
TX packets:6997 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:1000  
RX bytes:8057034 (7.6 Mb) TX bytes:2043520 (1.9 Mb)  
Interrupt:20 Memory:fbf00000-fbf20000

eth0.400 Link encap:Ethernet HWaddr B8:CA:3A:78:D8:62  
inet addr:192.168.130.11 Bcast:192.168.130.255 Mask:255.255.255.0  
inet6 addr: fe80::baca:3aff:fe78:d862/64 Scope:Link  
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
RX packets:0 errors:0 dropped:0 overruns:0 frame:0  
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:0 (0.0 b) TX bytes:648 (648.0 b)

lo Link encap:Local Loopback  
inet addr:127.0.0.1 Mask:255.0.0.0  
inet6 addr: ::1/128 Scope:Host  
UP LOOPBACK RUNNING MTU:16436 Metric:1  
RX packets:2506 errors:0 dropped:0 overruns:0 frame:0  
TX packets:2506 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:140113 (136.8 Kb) TX bytes:140113 (136.8 Kb)

qbr57f122 Link encap:Ethernet HWaddr C2:A0:DD:18:39:93  
inet6 addr: fe80::8c9a:b6ff:fe3f:f8a4/64 Scope:Link  
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
RX packets:5 errors:0 dropped:0 overruns:0 frame:0  
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:0  
RX bytes:308 (308.0 b) TX bytes:468 (468.0 b)

qvb57f122 Link encap:Ethernet HWaddr C2:A0:DD:18:39:93  
inet6 addr: fe80::c0a0:ddff:fe18:3993/64 Scope:Link  
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1  
RX packets:6 errors:0 dropped:0 overruns:0 frame:0  
TX packets:11 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:1000  
RX bytes:468 (468.0 b) TX bytes:846 (846.0 b)

qvo57f122 Link encap:Ethernet HWaddr DE:E6:00:B8:B7:9D  
inet6 addr: fe80::dce6:ff:feb8:b79d/64 Scope:Link  
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1  
RX packets:11 errors:0 dropped:0 overruns:0 frame:0  
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0  
collisions:0 txqueuelen:1000  
RX bytes:846 (846.0 b) TX bytes:468 (468.0 b)

root@db8-ca-3a-78-d8-62:/var/log/neutron # ovs-vsctl show

1a4534bb-7d54-4961-83cb-0f591c424bb7  
Bridge br-tunnel  
Port br-tunnel  
Interface br-tunnel  
type: internal  
Port “gre-c0a8820a”  
Interface “gre-c0a8820a”  
type: gre  
options: {df\_default=“true”, in\_key=flow, local\_ip=“192.168.130.11”, out\_key=flow, remote\_ip=“192.168.130.10”}  
Port patch-int  
Interface patch-int  
type: patch  
options: {peer=patch-tun}  
Bridge br-int  
fail\_mode: secure  
Port patch-tun  
Interface patch-tun  
type: patch  
options: {peer=patch-int}  
Port “qvo57f122ff-90”  
tag: 1  
Interface “qvo57f122ff-90”  
Port br-int  
Interface br-int  
type: internal  
ovs\_version: “2.1.2”

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [July 13, 2015, 7:30am UTC](https://forums.suse.com/t/multinode-setup-and-instance-on-one-compute-doesnt-get-ip/27223/2 "2015-07-13T07:30:19Z")

</div>

subha,

It appears that in the past few days you have not received a response to your  
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit [http://www.suse.com/support](http://www.suse.com/support) and search the knowledgebase and/or check all  
the other support options available.
- You could also try posting your message again. Make sure it is posted in the  
correct newsgroup. ([http://forums.suse.com](http://forums.suse.com))

Be sure to read the forum FAQ about what to expect in the way of responses:  
[http://forums.suse.com/faq.php](http://forums.suse.com/faq.php)

If this is a reply to a duplicate posting, please ignore and accept our apologies  
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team  
[http://forums.suse.com](http://forums.suse.com)

---

<div class="post-metadata">

**Author:** ![Eugen](https://avatars.discourse-cdn.com/v4/letter/e/ebca7d/32.png) [@Eugen](https://forums.suse.com/u/Eugen)\
**Post date:** [August 12, 2015, 2:41pm UTC](https://forums.suse.com/t/multinode-setup-and-instance-on-one-compute-doesnt-get-ip/27223/3 "2015-08-12T14:41:27Z")

</div>

Hi,

I’m not sure I get your configuration, but I am experimenting with suse cloud 5, too. I’m kind of missing a control node in your environment. Did you follow the deployment guide? The section on barclamp deployment ([https://www.suse.com/documentation/suse-cloud-5/singlehtml/book\_cloud\_deploy/book\_cloud\_deploy.html#sec.depl.ostack.cinder](https://www.suse.com/documentation/suse-cloud-5/singlehtml/book_cloud_deploy/book_cloud_deploy.html#sec.depl.ostack.cinder)) says:

> [@](#):
>
> Installing cinder-controller on a Control Node is recommended.

I have tried two different setups, both with three nodes like you do. First was with admin and control node (where most of the services run, such as cinder, neutron, nova-controller, etc.) running on SLES11 and compute node running on SLES12. I’ve tried with openvswitch and with linuxbridge, I don’t get the cloud working until now. SUSE Support recommended to stick with linuxbridge, by the way.  
Then I tried to install compute node with SLES11, too. Using linuxbridge, I had no troubles at all, everything worked perfectly fine!  
So I can’t really say what’s wrong with your configuration, but if you follow the deployment guide, you should get it working, at least if you run compute node with SLES11.

> [@](#):
>
> But the instances hosted on compute node -2 do not get any IP, but we can see from the dashboard the IP being assigned is 192.168.123.5.

This is a fixed IP, automatically assigned to the instance, but it doesn’t mean that eth0 of your instance really has an IP. Try to login to your instance and see if it has assigned an IP. I have still the same issue with SLES12 on compute node. If the IP injection works, your instance should have the IP in its username already (depending on the image you are using, I use SLES11-SP3 here, too), so it would look something like this: `host-192-168-123-27:~ #`  
I hope this helps.

Regards,  
Eugen
