# New Update Infrastructure

**URL:** <https://forums.suse.com/t/new-update-infrastructure/26370>\
**Category:** Azure\
**Created:** [November 15, 2014, 3:14am UTC](https://forums.suse.com/t/new-update-infrastructure/26370 "2014-11-15T03:14:05Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![rjschwei](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/rjschwei/32/8937_2.png) [@rjschwei](https://forums.suse.com/u/rjschwei)\
**Post date:** [November 15, 2014, 3:14am UTC](https://forums.suse.com/t/new-update-infrastructure/26370/1 "2014-11-15T03:14:05Z")

</div>

We are happy to announce that a new SUSE update infrastructure is in place in Microsoft Azure. The update infrastructure operated and maintained by SUSE provides updates to instances launched from SUSE released SUSE Linux Enterprise Server on demand images in Microsoft Azure.

Those using the latest images, released on 2014-11-06 or thereafter, will automatically connect to the new infrastructure. Those that have running instances started from images released prior to this date need to switch the instances to the new infrastructure. To switch a running instance follow these simple steps:

→ wget [http://104.45.147.201/instanceInfraUpgrade.noarch.rpm](http://104.45.147.201/instanceInfraUpgrade.noarch.rpm)

Then as root

# zypper --no-refresh --non-interactive in instanceInfraUpgrade.noarch.rpm

# instanceInfraUpgrade

# rm instanceInfraUpgrade.noarch.rpm

After the update to the new infrastructure “zypper lr” will point to repositories starting with “SMT”

The old infrastructure server will be disabled on June 30, 2015.

– July 29, 2015 –  
I added the ‘–no-refresh’ option to the zypper command to prevent zypper from trying to refresh the repositories. The old update infrastructure was removed on June 30th, as announced. Anyone trying to follow the procedure that still has the old update infrastructure configured will run into issues if the ‘–no-refresh’ option is not used.

---

<div class="post-metadata">

**Author:** ![bear454](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/bear454/32/9125_2.png) [@bear454](https://forums.suse.com/u/bear454)\
**Post date:** [June 30, 2015, 6:43pm UTC](https://forums.suse.com/t/new-update-infrastructure/26370/2 "2015-06-30T18:43:01Z")

</div>

> [@rjschwei;24920](#):
>
> The old infrastructure server will be disabled on June 30, 2015.

The legacy infrastructure server is now offline. _If_ you are experiencing any issues receiving updates, please check the procedure outlined above, for migrating to the new infrastructure, or start a new instance.

---

<div class="post-metadata">

**Author:** ![ericcwk](https://avatars.discourse-cdn.com/v4/letter/e/ecccb3/32.png) [@ericcwk](https://forums.suse.com/u/ericcwk)\
**Post date:** [July 27, 2015, 1:12pm UTC](https://forums.suse.com/t/new-update-infrastructure/26370/3 "2015-07-27T13:12:58Z")

</div>

> [@bear454;28587](#):
>
> The legacy infrastructure server is now offline. _If_ you are experiencing any issues receiving updates, please check the procedure outlined above, for migrating to the new infrastructure, or start a new instance.

Is there something i missed? I can’t install the rpm with the following errors

zypper --non-interactive in instanceInfraUpgrade.noarch.rpm

Refreshing service ‘susecloud’.  
Problem retrieving the repository index file for service ‘susecloud’:  
Download (curl) error for ‘[http://azure-update.susecloud.net/repo/repoindex.xml?cookies=0](http://azure-update.susecloud.net/repo/repoindex.xml?cookies=0)’:  
Error code: Connection failed  
Error message: Couldn’t resolve host ‘[azure-update.susecloud.net](http://azure-update.susecloud.net)’

Check if the URI is valid and accessible.  
Retrieving repository ‘SLE11-Security-Module’ metadata [\]  
Download (curl) error for ‘[http://azure-update.susecloud.net/repo/$RCE/SLE11-Security-Module/sle-11-x86\_64/repodata/repomd.xml](http://azure-update.susecloud.net/repo/$RCE/SLE11-Security-Module/sle-11-x86_64/repodata/repomd.xml)’:  
Error code: Connection failed  
Error message: Couldn’t resolve host ‘[azure-update.susecloud.net](http://azure-update.susecloud.net)’

---

<div class="post-metadata">

**Author:** ![bear454](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/bear454/32/9125_2.png) [@bear454](https://forums.suse.com/u/bear454)\
**Post date:** [July 28, 2015, 9:17pm UTC](https://forums.suse.com/t/new-update-infrastructure/26370/4 "2015-07-28T21:17:27Z")

</div>

[QUOTE=ericcwk;28884]Is there something i missed?[/QUOTE]

Please paste back the output of the following two commands (as root):

[CODE]# dd if=/dev/sda bs=1c count=16 skip=65536 | hexdump

# dd if=/dev/sda bs=1c count=16 skip=16384 | hexdump[/CODE]

---

<div class="post-metadata">

**Author:** ![rjschwei](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/rjschwei/32/8937_2.png) [@rjschwei](https://forums.suse.com/u/rjschwei)\
**Post date:** [July 29, 2015, 3:20am UTC](https://forums.suse.com/t/new-update-infrastructure/26370/5 "2015-07-29T03:20:09Z")

</div>

zypper is trying to refresh the existing repo, which fails. thus the whole process falls over. Run

rm -rf /etc/zypp/repos.d/\*

first, then run

zypper --non-interactive in instanceInfraUpgrade.noarch.rpm

---

<div class="post-metadata">

**Author:** ![ericcwk](https://avatars.discourse-cdn.com/v4/letter/e/ecccb3/32.png) [@ericcwk](https://forums.suse.com/u/ericcwk)\
**Post date:** [July 29, 2015, 6:02am UTC](https://forums.suse.com/t/new-update-infrastructure/26370/6 "2015-07-29T06:02:14Z")

</div>

[QUOTE=rjschwei;28902]zypper is trying to refresh the existing repo, which fails. thus the whole process falls over. Run

rm -rf /etc/zypp/repos.d/\*

first, then run

zypper --non-interactive in instanceInfraUpgrade.noarch.rpm[/QUOTE]

hi rjschwei

After removing the existing repos, the command return similar response

# zypper --non-interactive in instanceInfraUpgrade.noarch.rpm

Refreshing service ‘susecloud’.  
Problem retrieving the repository index file for service ‘susecloud’:  
Download (curl) error for ‘[http://azure-update.susecloud.net/repo/repoindex.xml?cookies=0](http://azure-update.susecloud.net/repo/repoindex.xml?cookies=0)’:  
Error code: Connection failed  
Error message: Couldn’t resolve host ‘[azure-update.susecloud.net](http://azure-update.susecloud.net)’

Check if the URI is valid and accessible.

And i try to nslookup [azure-update.susecloud.net](http://azure-update.susecloud.net)  
it return to Server: 168.63.129.16  
Is it normal one ?

---

<div class="post-metadata">

**Author:** ![rjschwei](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/rjschwei/32/8937_2.png) [@rjschwei](https://forums.suse.com/u/rjschwei)\
**Post date:** [July 29, 2015, 2:37pm UTC](https://forums.suse.com/t/new-update-infrastructure/26370/7 "2015-07-29T14:37:21Z")

</div>

Sorry, the given command only removes the repo, but leaves the service, which also needs to be removed:

zypper rs susecloud

We forgot to remove the DNS entry, that has now been taken care of.

---

<div class="post-metadata">

**Author:** ![simon\_2001](https://avatars.discourse-cdn.com/v4/letter/s/82dd89/32.png) [@simon\_2001](https://forums.suse.com/u/simon_2001)\
**Post date:** [February 10, 2016, 2:00pm UTC](https://forums.suse.com/t/new-update-infrastructure/26370/8 "2016-02-10T14:00:21Z")

</div>

Hello, a question about this new update infrastructure (OK not so new now).

Is this service hosted in the Azure DC for each region? We are operating from the North Europe (Dublin) region, and deploying the new SLES 11 SP4 images. Are there now SLES update servers deployed into North Europe for this purpose?

We found that the SLES image has the registercloudguest script which executes when a new VM is deploying. This script tries to connect to SMT servers from /etc/regionserverclnt.cfg file by https protocol:

# cat /etc/regionserverclnt.cfg

[server]  
api = regionInfo  
certLocation = /var/lib/regionService/certs  
regionsrv = 104.45.154.114,104.45.31.195,191.237.254.253,23.100.36.229,23.101.26.184

We are wondering where these IP addresses are hosted? We can see they are registered to Microsoft (via whois) but they are not listed in the published Microsoft range for North Europe.

We need to conform to company IT Security policies, and so we need to understand where these servers are hosted, who is managing them.

Many thanks!

---

<div class="post-metadata">

**Author:** ![bear454](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/bear454/32/9125_2.png) [@bear454](https://forums.suse.com/u/bear454)\
**Post date:** [February 11, 2016, 2:50am UTC](https://forums.suse.com/t/new-update-infrastructure/26370/9 "2016-02-11T02:50:32Z")

</div>

Those IP addresses are our geodistributed region servers. regionsrvclnt will request from (at least) one of the region servers, and it will respond with information about your local SMT servers, which, yes, run in each region.

The IP addresses of all our servers are available via the `pint` command line tool; e.g. :

`
$ pint microsoft servers`

will return a list of the IP addresses for both the region servers and all SMT servers; you probably want

```auto
$ pint microsoft servers --regionserver
$ pint microsoft servers --smt --region 'North Europe'[/CODE]

in order to give you the global region servers (same as the list in the config file) and your region-local SMT servers.

Just for reference, here's the current output:

[CODE]$ pint microsoft servers --regionserver
<?xml version='1.0' encoding='UTF-8'?>
<servers>
  <server ip="23.101.26.184" name="" region="Southeast Asia" type="regionserver"/>
  <server ip="191.237.254.253" name="" region="Brazil South" type="regionserver"/>
  <server ip="104.45.31.195" name="" region="West Europe" type="regionserver"/>
  <server ip="104.45.154.114" name="" region="East US" type="regionserver"/>
  <server ip="23.100.36.229" name="" region="West US" type="regionserver"/>
</servers>

$ pint microsoft servers --smt --region 'North Europe'
<?xml version='1.0' encoding='UTF-8'?>
<servers>
  <server ip="104.45.85.11" name="smt-azure.susecloud.net" region="North Europe" type="smt"/>
  <server ip="104.45.85.45" name="smt-azure.susecloud.net" region="North Europe" type="smt"/>
</servers>
```

Have a lot of fun!

---

<div class="post-metadata">

**Author:** ![Hikerguy88](https://avatars.discourse-cdn.com/v4/letter/h/dec6dc/32.png) [@Hikerguy88](https://forums.suse.com/u/Hikerguy88)\
**Post date:** [May 15, 2017, 5:36pm UTC](https://forums.suse.com/t/new-update-infrastructure/26370/10 "2017-05-15T17:36:24Z")

</div>

Hi,

I realize this is from 3 years ago, but is this still the current update infrastructure?

I have inherited a few servers that are SLES 11 SP2 and I am getting the following error for all repositories that use “[default-ec2-update.susecloud.net](http://default-ec2-update.susecloud.net)”. I think the update script has not been run on the affected servers, would it still work or have there been additional changes, etc?

"  
Warning: Disabling repository ‘{insert repo name}’ because of the above error.  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/](http://default-ec2-update.susecloud.net/repo/update/){insert repo name}/sle-11-x86\_64/repodata/repomd.xml’:  
Error code: Connection failed  
Error message: Couldn’t resolve host ‘[default-ec2-update.susecloud.net](http://default-ec2-update.susecloud.net)’  
"

Third party repositories refresh ok – Nvidia ([http://download.nvidia.com/novell/sle11sp2](http://download.nvidia.com/novell/sle11sp2)) and the “server-monitoring” ([http://download.opensuse.org/repositories/server:/monitoring/SLE\_11\_SP3/](http://download.opensuse.org/repositories/server:/monitoring/SLE_11_SP3/))

repos with error:  
SLE11-SDK-SP1  
SLE11-SDK-SP1-Pool  
SLE11-SDK-SP1-Updates  
SLE11-SDK-SP2-Core  
SLE11-SDK-SP2-Updates  
SLE11-SDK-SP3-Pool  
SLE11-SDK-SP3-Updates  
SLE11-SP1-Debuginfo-Pool  
SLE11-SP1-Debuginfo-Updates  
SLE11-SP2-Debuginfo-Core  
SLE11-SP2-Debuginfo-Updates  
SLE11-SP2-WebYaST-13-Pool  
SLE11-SP2-WebYaST-13-Updates  
SLE11-SP3-Debuginfo-Pool  
SLE11-SP3-Debuginfo-Updates  
SLE11-WebYaST-SP1  
SLE11-WebYaST-SP1-Updates  
SLE11-WebYaST-SP2-Pool  
SLE11-WebYaST-SP2-Updates  
SLES11-Extras  
SLES11-SP1  
SLES11-SP1-Pool  
SLES11-SP1-Updates  
SLES11-SP2-Core  
SLES11-SP2-Extension-Store  
SLES11-SP2-Updates  
SLES11-SP3-Extension-Store  
SLES11-SP3-Pool  
SLES11-SP3-Updates

Repo location  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/install/SLE11-SDK-SP1/sle-11-x86\_64/media.1/media](http://default-ec2-update.susecloud.net/repo/install/SLE11-SDK-SP1/sle-11-x86_64/media.1/media)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP2-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP2-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP1-Debuginfo-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP1-Debuginfo-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP1-Debuginfo-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP1-Debuginfo-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-Debuginfo-Core/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-Debuginfo-Core/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-Debuginfo-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-Debuginfo-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-WebYaST-1.3-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-WebYaST-1.3-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-WebYaST-1.3-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-WebYaST-1.3-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP3-Debuginfo-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP3-Debuginfo-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP3-Debuginfo-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP3-Debuginfo-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/install/SLE11-WebYaST-SP1/sle-11-x86\_64/media.1/media](http://default-ec2-update.susecloud.net/repo/install/SLE11-WebYaST-SP1/sle-11-x86_64/media.1/media)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP1-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP1-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP2-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP2-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP2-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP2-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-Extras/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-Extras/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/install/SLES11-SP1/sle-11-x86\_64/media.1/media](http://default-ec2-update.susecloud.net/repo/install/SLES11-SP1/sle-11-x86_64/media.1/media)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP1-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP1-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP1-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP1-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Core/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Core/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Extension-Store/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Extension-Store/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Extension-Store/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Extension-Store/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Updates/sle-11-x86_64/repodata/repomd.xml)’:

[QUOTE=rjschwei;24920]We are happy to announce that a new SUSE update infrastructure is in place in Microsoft Azure. The update infrastructure operated and maintained by SUSE provides updates to instances launched from SUSE released SUSE Linux Enterprise Server on demand images in Microsoft Azure.

Those using the latest images, released on 2014-11-06 or thereafter, will automatically connect to the new infrastructure. Those that have running instances started from images released prior to this date need to switch the instances to the new infrastructure. To switch a running instance follow these simple steps:

→ wget [http://104.45.147.201/instanceInfraUpgrade.noarch.rpm](http://104.45.147.201/instanceInfraUpgrade.noarch.rpm)

Then as root

# zypper --no-refresh --non-interactive in instanceInfraUpgrade.noarch.rpm

# instanceInfraUpgrade

# rm instanceInfraUpgrade.noarch.rpm

After the update to the new infrastructure “zypper lr” will point to repositories starting with “SMT”

The old infrastructure server will be disabled on June 30, 2015.

– July 29, 2015 –  
I added the ‘–no-refresh’ option to the zypper command to prevent zypper from trying to refresh the repositories. The old update infrastructure was removed on June 30th, as announced. Anyone trying to follow the procedure that still has the old update infrastructure configured will run into issues if the ‘–no-refresh’ option is not used.[/QUOTE]

---

<div class="post-metadata">

**Author:** ![Hikerguy88](https://avatars.discourse-cdn.com/v4/letter/h/dec6dc/32.png) [@Hikerguy88](https://forums.suse.com/u/Hikerguy88)\
**Post date:** [May 18, 2017, 3:22pm UTC](https://forums.suse.com/t/new-update-infrastructure/26370/11 "2017-05-18T15:22:14Z")

</div>

[QUOTE=Hikerguy88;37859]Hi,

I realize this is from 3 years ago, but is this still the current update infrastructure?

I have inherited a few servers that are SLES 11 SP2 and I am getting the following error for all repositories that use “[default-ec2-update.susecloud.net](http://default-ec2-update.susecloud.net)”. I think the update script has not been run on the affected servers, would it still work or have there been additional changes, etc?

"  
Warning: Disabling repository ‘{insert repo name}’ because of the above error.  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/](http://default-ec2-update.susecloud.net/repo/update/){insert repo name}/sle-11-x86\_64/repodata/repomd.xml’:  
Error code: Connection failed  
Error message: Couldn’t resolve host ‘[default-ec2-update.susecloud.net](http://default-ec2-update.susecloud.net)’  
"

Third party repositories refresh ok – Nvidia ([http://download.nvidia.com/novell/sle11sp2](http://download.nvidia.com/novell/sle11sp2)) and the “server-monitoring” ([http://download.opensuse.org/repositories/server:/monitoring/SLE\_11\_SP3/](http://download.opensuse.org/repositories/server:/monitoring/SLE_11_SP3/))

repos with error:  
SLE11-SDK-SP1  
SLE11-SDK-SP1-Pool  
SLE11-SDK-SP1-Updates  
SLE11-SDK-SP2-Core  
SLE11-SDK-SP2-Updates  
SLE11-SDK-SP3-Pool  
SLE11-SDK-SP3-Updates  
SLE11-SP1-Debuginfo-Pool  
SLE11-SP1-Debuginfo-Updates  
SLE11-SP2-Debuginfo-Core  
SLE11-SP2-Debuginfo-Updates  
SLE11-SP2-WebYaST-13-Pool  
SLE11-SP2-WebYaST-13-Updates  
SLE11-SP3-Debuginfo-Pool  
SLE11-SP3-Debuginfo-Updates  
SLE11-WebYaST-SP1  
SLE11-WebYaST-SP1-Updates  
SLE11-WebYaST-SP2-Pool  
SLE11-WebYaST-SP2-Updates  
SLES11-Extras  
SLES11-SP1  
SLES11-SP1-Pool  
SLES11-SP1-Updates  
SLES11-SP2-Core  
SLES11-SP2-Extension-Store  
SLES11-SP2-Updates  
SLES11-SP3-Extension-Store  
SLES11-SP3-Pool  
SLES11-SP3-Updates

Repo location  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/install/SLE11-SDK-SP1/sle-11-x86\_64/media.1/media](http://default-ec2-update.susecloud.net/repo/install/SLE11-SDK-SP1/sle-11-x86_64/media.1/media)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP2-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP2-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP1-Debuginfo-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP1-Debuginfo-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP1-Debuginfo-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP1-Debuginfo-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-Debuginfo-Core/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-Debuginfo-Core/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-Debuginfo-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-Debuginfo-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-WebYaST-1.3-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-WebYaST-1.3-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-WebYaST-1.3-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP2-WebYaST-1.3-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP3-Debuginfo-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP3-Debuginfo-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-SP3-Debuginfo-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-SP3-Debuginfo-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/install/SLE11-WebYaST-SP1/sle-11-x86\_64/media.1/media](http://default-ec2-update.susecloud.net/repo/install/SLE11-WebYaST-SP1/sle-11-x86_64/media.1/media)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP1-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP1-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP2-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP2-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP2-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLE11-WebYaST-SP2-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-Extras/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-Extras/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/install/SLES11-SP1/sle-11-x86\_64/media.1/media](http://default-ec2-update.susecloud.net/repo/install/SLES11-SP1/sle-11-x86_64/media.1/media)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP1-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP1-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP1-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP1-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Core/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Core/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Extension-Store/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Extension-Store/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP2-Updates/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Extension-Store/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Extension-Store/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Pool/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Pool/sle-11-x86_64/repodata/repomd.xml)’:  
Download (curl) error for ‘[http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Updates/sle-11-x86\_64/repodata/repomd.xml](http://default-ec2-update.susecloud.net/repo/update/SLES11-SP3-Updates/sle-11-x86_64/repodata/repomd.xml)’:[/QUOTE]

I tried running this and recieved errors so I followed the directions here [https://forums.aws.amazon.com/thread.jspa?messageID=784491&tstart=0#784491](https://forums.aws.amazon.com/thread.jspa?messageID=784491&tstart=0#784491). Essentially moving some of the directories and files in /etc/zypp into /etc/zypp/old and then re-running the upgrade.

however the upgrade still fails with the following error:

instanceInfraUpgrade  
Adding repository ‘tmp\_instance\_infrastructure\_upgrade’ [done]  
Repository ‘tmp\_instance\_infrastructure\_upgrade’ successfully added  
Enabled: Yes  
Autorefresh: No  
GPG check: Yes  
URI: dir:///usr/share/instance\_infrastructure\_upgrade/repo

Repository ‘tmp\_instance\_infrastructure\_upgrade’ priority has been set to 1.  
Retrieving repository ‘tmp\_instance\_infrastructure\_upgrade’ metadata [done]  
Building repository ‘tmp\_instance\_infrastructure\_upgrade’ cache [done]  
Specified repositories have been refreshed.  
Loading repository data…  
Reading installed packages…  
‘python-argparse’ is already installed.  
No update candidate for ‘python-argparse-1.2.1-2.5.65.x86\_64’. The highest available version is already installed.  
Resolving package dependencies…

Problem: nothing provides python-m2crypto needed by cloud-regionsrv-client-6.3.8-22.2.x86\_64  
Solution 1: do not install cloud-regionsrv-client-6.3.8-22.2.x86\_64  
Solution 2: break cloud-regionsrv-client-6.3.8-22.2.x86\_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): c  
Removing repository ‘tmp\_instance\_infrastructure\_upgrade’ [done]  
Repository ‘tmp\_instance\_infrastructure\_upgrade’ has been removed.

How do I fix this? is this infraupgrade still viable?
