# Nfs driver problem

**URL:** <https://forums.suse.com/t/nfs-driver-problem/7888>\
**Category:** Rancher 1.x\
**Created:** [November 23, 2017, 4:12pm UTC](https://forums.suse.com/t/nfs-driver-problem/7888 "2017-11-23T16:12:14Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mike\_Niemaz](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/mike_niemaz/32/3099_2.png) [@Mike\_Niemaz](https://forums.suse.com/u/Mike_Niemaz)\
**Post date:** [November 23, 2017, 4:12pm UTC](https://forums.suse.com/t/nfs-driver-problem/7888/1 "2017-11-23T16:12:14Z")

</div>

Hi,  
I’m having trouble to use the nfs storage driver added via Rancher UI.  
When I try to use it via docker-compose, it does not work :

time=“2017-11-23T15:03:40Z” level=error msg=create.response error=“Failed mount -o ,nfsvers=4 mob-1:/xxx/xxx/xxx /tmp/vvxiz” message=“Failed mount -o ,nfsvers=4 mob-1:/xxx/xxx/xxx /tmp/vvxiz” name=“XXX” status=Failure  
time=“2017-11-23T15:04:35Z” level=info msg=create.request name=“XXX”

Any idea?

---

<div class="post-metadata">

**Author:** ![superseb](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/superseb/32/2424_2.png) [@superseb](https://forums.suse.com/u/superseb)\
**Post date:** [November 25, 2017, 9:45am UTC](https://forums.suse.com/t/nfs-driver-problem/7888/2 "2017-11-25T09:45:27Z")

</div>

What version of Rancher and the nfs-driver are you using? Can you manually mount shares on the host? Is mob-1 resolvable within the containers? Does the server support NFS version 4?

---

<div class="post-metadata">

**Author:** ![pwFoo](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/pwfoo/32/2884_2.png) [@pwFoo](https://forums.suse.com/u/pwFoo)\
**Post date:** [November 28, 2017, 5:47pm UTC](https://forums.suse.com/t/nfs-driver-problem/7888/3 "2017-11-28T17:47:24Z")

</div>

I don’t know the error message I got, but maybe it’s the same.  
nfs volume will fail if a named docker volume with the same name exists.

That was my problem during start with rancher nfs

---

<div class="post-metadata">

**Author:** ![Mike\_Niemaz](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/mike_niemaz/32/3099_2.png) [@Mike\_Niemaz](https://forums.suse.com/u/Mike_Niemaz)\
**Post date:** [November 30, 2017, 10:47pm UTC](https://forums.suse.com/t/nfs-driver-problem/7888/4 "2017-11-30T22:47:31Z")

</div>

@superseb, I’m using rancher 1.6.11, the nfs driver from the catalog and yes, I can share directly on the host. mob-1 resolvable from containers? probably.  
Not sure about server supporting nfs 4.
