# NFS4 Issues SLES1 11

**URL:** <https://forums.suse.com/t/nfs4-issues-sles1-11/23276>\
**Category:** SLES Configure-Administer\
**Created:** [November 6, 2012, 7:31pm UTC](https://forums.suse.com/t/nfs4-issues-sles1-11/23276 "2012-11-06T19:31:03Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![acunacha](https://avatars.discourse-cdn.com/v4/letter/a/87869e/32.png) [@acunacha](https://forums.suse.com/u/acunacha)\
**Post date:** [November 6, 2012, 7:31pm UTC](https://forums.suse.com/t/nfs4-issues-sles1-11/23276/1 "2012-11-06T19:31:03Z")

</div>

Hi all,

I am sure this post will be pretty easy for most of you, but I am a beginner and I can’t seem to find the fix.

I am setting up a couple of NFSv4 shares, here it is the environment:

In my NFS server (S2), I open the NFS Server module from Yast, select to start the server, open port in firewall, I check the “Enable NFSv4” option, I enter my domain name and hit next.

There, add a Directory, I browse my /nfs\_exports dir, host will card=\*, and in this order the options= fsid=0,crossmnt,rw,root\_squash,sync,no\_subtree\_check.

Then, I also export\> /nfs\_exports/home, host=\*, options=rw,root\_squash,sync,no\_subtree\_check,bind=/export/home. Then I click on finish and everything looks good.

/etc/exports:

/nfs\_exports \*(fsid=0,crossmnt,rw,root\_squash,sync,no\_subtree\_check)  
/nfs\_exports/home \*(rw,root\_squash,sync,no\_subtree\_check,bind=/export/home)

server2:~/Desktop # showmount -e localhost  
Export list for localhost:  
/nfs\_exports \*  
/nfs\_exports/home \*

Line from mount command:

/export/home on /nfs\_exports/home type none (rw,bind,nfsexp)

Everything looks good to me, so from there I jump to my NFS client (S1).

server1:~ # grep -i nfs4 /etc/sysconfig/nfs  
NFS4\_SUPPORT=“yes”

I open the NFS client module, go to the NFS Settings tab, enable NFSv4 and enter my domain name (NFSv4 Domain), open por in firewall. Then, back in the NFS shares tab, add, NFS server Host=server2, remote directory=/nfs\_exports/home, mount point=/imports/nfs/home, I check the NFSv4 share option, options=defaults,soft and then hit ok. Then I hit ok and guess what: “Error. Unable to mount the NFS entries from /etc/fstab.”

If I uncheck the nfsv4 share option from the nfs client module, it will work just fine, no errors at all:

/etc/fstab:  
server2:/nfs\_exports/home /import/nfs/home nfs defaults,soft 0 0

If I try to mount the NFS4 share manually, this is what I get:

server1:~ # mount -t nfs4 s2:/nfs\_exports/home /import/nfs/home/  
mount.nfs4: mounting s2:/nfs\_exports/home failed, reason given by server:  
No such file or directory

Which is completely weird, I just don’t get it.

If I manually edit /etc/fstab and add the line:

server2:/nfs\_exports/home /import/nfs/home nfs4 defaults,soft 0 0

I get the same mount error as before:

server1:~ # mount -a  
mount.nfs4: mounting server2:/nfs\_exports/home failed, reason given by server:  
No such file or directory

Then, just for testing, I tried mounting the pseudo root directory manually, and this attempt was succesfull:

server1:~ # mount -t nfs4 s2:/ /import/nfs/home/

server1:~ # mount  
s2:/ on /import/nfs/home type nfs4 (rw,clientaddr=192.168.1.2,addr=192.168.1.3)

If I check the /import/nfs/home, the pseudo file system is all there, I can access the /nfs\_export/home dir:

server1:~ # ls /import/nfs/home/  
home

It will work fine also if I add the following line to /etc/fstab:

server2:/ /import/nfs/home nfs4 defaults,soft 0 0

So in summary, I can only mount server2:/. I can not mount say server2:/nfs\_exports/home separately.

However, what I want to do is that, mount /nfs\_exports/home to /imports/nfs/home, and a future share /nfs\_exports/projects to /imports/nfs/projects, mounting the whole pseudo file system to a single directory will not work for me.

Do you guys know if this is possible? If it is, would you help me? I tried to include all relevant information, if you’d like me to send you anything else just let me know.

Warm Regards,

Diego

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [November 15, 2012, 3:30pm UTC](https://forums.suse.com/t/nfs4-issues-sles1-11/23276/2 "2012-11-15T15:30:33Z")

</div>

acunacha,

It appears that in the past few days you have not received a response to your  
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit [http://www.suse.com/support](http://www.suse.com/support) and search the knowledgebase and/or check all  
the other support options available.
- You could also try posting your message again. Make sure it is posted in the  
correct newsgroup. ([http://forums.suse.com](http://forums.suse.com))

Be sure to read the forum FAQ about what to expect in the way of responses:  
[http://forums.suse.com/faq.php](http://forums.suse.com/faq.php)

If this is a reply to a duplicate posting, please ignore and accept our apologies  
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team  
[http://forums.suse.com](http://forums.suse.com)

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [November 15, 2012, 4:57pm UTC](https://forums.suse.com/t/nfs4-issues-sles1-11/23276/3 "2012-11-15T16:57:50Z")

</div>

Hi Diego,

something just caught my eye that I didn’t see when I first read your question:

> server1:~ # mount -t nfs4 s2:/ /import/nfs/home/  
> server1:~ # ls /import/nfs/home/  
> home

> server1:~ # mount -a  
> mount.nfs4: mounting server2:/nfs\_exports/home failed, reason given by server:  
> No such file or directory

have you ever tried to do a “mount -t nfs4 s2:/home /import/nfs/home/”?

AFAIK, the mount semantics have changed with NFS4, with regards to the “pseudo filesystem”…

Regards,  
Jens
