# NFSv4-only Server without rpcbind

**URL:** <https://forums.suse.com/t/nfsv4-only-server-without-rpcbind/27943>\
**Category:** SLES Configure-Administer\
**Created:** [March 1, 2016, 4:59pm UTC](https://forums.suse.com/t/nfsv4-only-server-without-rpcbind/27943 "2016-03-01T16:59:04Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pesc](https://avatars.discourse-cdn.com/v4/letter/p/ecc23a/32.png) [@pesc](https://forums.suse.com/u/pesc)\
**Post date:** [March 1, 2016, 4:59pm UTC](https://forums.suse.com/t/nfsv4-only-server-without-rpcbind/27943/1 "2016-03-01T16:59:04Z")

</div>

Hello 🙂

How is it possible to run a NFSv4 Server without rpcbind? I’ve read in the release notes of SLES12 SP1 about it but it’s not working: [https://www.suse.com/releasenotes/x86\_64/SUSE-SLES/12-SP1/](https://www.suse.com/releasenotes/x86_64/SUSE-SLES/12-SP1/) (Search for “NFSv4 only configuration”)

What I’ve done so far:

```auto
node1:~ # cat /proc/fs/nfsd/versions
-2 -3 +4 +4.1 -4.2
```

Then I stop rpcbind and want to restart NFS, but NFS fails!

```auto
2016-03-01T16:29:11.984605+01:00 node1 kernel: [2355.147224] nfsd: last server has exited, flushing export cache
2016-03-01T16:29:11.991440+01:00 node1 rpc.mountd[1762]: Could not bind socket: (98) Address already in use
2016-03-01T16:29:11.992319+01:00 node1 rpc.mountd[1762]: message repeated 3 times: [Could not bind socket: (98) Address already in use]
2016-03-01T16:29:11.992551+01:00 node1 rpc.mountd[1762]: mountd: No V2 or V3 listeners created!
2016-03-01T16:29:11.993681+01:00 node1 rpc.mountd[1765]: Version 1.3.0 starting
2016-03-01T16:29:12.008810+01:00 node1 kernel: [2355.173557] svc: failed to register lockdv1 RPC service (errno 111).
2016-03-01T16:29:12.008821+01:00 node1 kernel: [2355.173563] lockd_up: makesock failed, error=-111
2016-03-01T16:29:12.009327+01:00 node1 rpc.nfsd[1768]: error starting threads: errno 111 (Connection refused)
2016-03-01T16:29:12.009691+01:00 node1 systemd[1]: Failed to start NFS server and services.
```

Any idea?

---

<div class="post-metadata">

**Author:** ![Jens-U](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@Jens-U](https://forums.suse.com/u/Jens-U)\
**Post date:** [March 1, 2016, 5:59pm UTC](https://forums.suse.com/t/nfsv4-only-server-without-rpcbind/27943/2 "2016-03-01T17:59:27Z")

</div>

Hi pesc,

while I do see that lockd tries to register with rpcbind and fails, mountd on top has difficulties opening its port:

> rpc.mountd[1762]: Could not bind socket: (98) Address already in use

might it be there’s another (old) rpm.mountd active? when running “lsof -i4”, do you see any process having the mountd port open, like in the following example?

` [FONT=monospace][COLOR=#000000]rpc.mount 5487 root 7u IPv4 75225 0t0 UDP *:mountd[/COLOR]
rpc.mount 5487 root 8u IPv4 75229 0t0 TCP *:mountd (LISTEN)`

rpc.nfsd does not tell which connection fails - maybe it’s the one to rpc.mountd?

Regards,  
Jens  
[/FONT]
