# Old error not fixed?

**URL:** <https://forums.suse.com/t/old-error-not-fixed/15830>\
**Category:** General\
**Created:** [November 14, 2019, 5:33pm UTC](https://forums.suse.com/t/old-error-not-fixed/15830 "2019-11-14T17:33:55Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Akito](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/akito/32/5805_2.png) [@Akito](https://forums.suse.com/u/Akito)\
**Post date:** [November 14, 2019, 5:33pm UTC](https://forums.suse.com/t/old-error-not-fixed/15830/1 "2019-11-14T17:33:55Z")

</div>

Don’t know what I am missing but I am experiencing the following category of error described here:

> [@Private registry not working](http://forums.suse.com/t/private-registry-not-working/10535):
>
> I’m trying to configure registry in my fresh rancher 2.0 installation. I created a cluster and in Default \>\> Resources \>\> Registries, I added my private registry with scope “Available to all namespaces in this project”. The registry is a Nexus where I created the kubernetes user. When I try to deploy a pod using this registry, I got : 3s 18s 2 spring-cloud-config-c9dddbd6c-4dsnv.15313e7861d9f8a5 Pod spec.containers{spring-cloud-config} Warning Failed …

> <https://github.com/rancher/rancher/issues/13339>
>
> \*\*Rancher versions:\*\*
> rancher/rancher:master
> 
> Currently using private registr…y with basic authentication will succeed for deploying k8s components but will fail for deploying the pods because kubelet has no idea what credentials are being used and it fails to pull the pause image and pods images.

I am using Rancher v2.3.2 with Kubernetes.  
My private registry works flawlessly everywhere, except within Rancher.
