# podman and SLES15

**URL:** <https://forums.suse.com/t/podman-and-sles15/35134>\
**Category:** SLES Virtualization\
**Created:** [July 10, 2020, 8:05am UTC](https://forums.suse.com/t/podman-and-sles15/35134 "2020-07-10T08:05:17Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![swadm](https://avatars.discourse-cdn.com/v4/letter/s/bc79bd/32.png) [@swadm](https://forums.suse.com/u/swadm)\
**Post date:** [July 10, 2020, 8:05am UTC](https://forums.suse.com/t/podman-and-sles15/35134/1 "2020-07-10T08:05:17Z")

</div>

Just trying to get a rootless podman image to run on SLES 15 SP1.  
Happy to see that SLE-Module-Containers15-SP1-Updates provides podman 1.8.0-4.20.1  
Learned that fuse3 package is required (otherwise “using mount program /usr/bin/fuse-overlayfs: fuse: failed to exec fusermount3: No such file or directory”)  
But even then, a non-root user will get a permission following error, e.g.:  
podmantest@host:~\> podman run --name testcontainer --rm -d alpine top  
ERRO[0000] error unmounting /home/podmantest/.local/share/containers/storage/overlay/2675cf666fd8d9ed48cb3786d71063395ad988531e7265c7f1f46b10314c5618/merged: invalid argument  
Error: error mounting storage for container b8a341ed9ea8bfee36704290c5d2488921b3704b71dfe2b6238bc3c90a8157f3: error creating overlay mount to /home/podmantest/.local/share/containers/storage/overlay/2675cf666fd8d9ed48cb3786d71063395ad988531e7265c7f1f46b10314c5618/merged: using mount program /usr/bin/fuse-overlayfs: fusermount3: mount failed: Operation not permitted  
fuse-overlayfs: cannot mount: Operation not permitted  
: exit status 1  
podmantest@host:~\>  
In [https://github.com/containers/podman/issues/5732](https://github.com/containers/podman/issues/5732) I found “FUSE in a user namespace needs at least Linux 4.18”. As SLES15SP1 has 4.12.14, how should I work around this.  
Thanks!  
Tom

---

<div class="post-metadata">

**Author:** ![atgracey](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/atgracey/32/9234_2.png) [@atgracey](https://forums.suse.com/u/atgracey)\
**Post date:** [July 12, 2020, 7:59pm UTC](https://forums.suse.com/t/podman-and-sles15/35134/2 "2020-07-12T19:59:12Z")

</div>

Hey,  
This is a fantastic question and something that I’ve been running into as well.

As I understand it (and I’ll confirm tomorrow with some of our more knowledgeable engineers), rootless podman/buildah/skopeo does require the new kernel supported in 15 SP2.

Thank you,  
Andrew Gracey

P. S. If you are following my guide, I believe I’m running as root and there might be a mistake suggesting that you didn’t need to. I was also running some tests on TW that might have led me to conflate the two tests. Sorry if this is the case ☹

---

<div class="post-metadata">

**Author:** ![swadm](https://avatars.discourse-cdn.com/v4/letter/s/bc79bd/32.png) [@swadm](https://forums.suse.com/u/swadm)\
**Post date:** [July 13, 2020, 5:54am UTC](https://forums.suse.com/t/podman-and-sles15/35134/3 "2020-07-13T05:54:46Z")

</div>

Andrew,  
thanks. I hope that also SP1 will get the newer kernel through current patches.  
Kind regards, Tom

---

<div class="post-metadata">

**Author:** ![swadm](https://avatars.discourse-cdn.com/v4/letter/s/bc79bd/32.png) [@swadm](https://forums.suse.com/u/swadm)\
**Post date:** [August 11, 2020, 12:45pm UTC](https://forums.suse.com/t/podman-and-sles15/35134/4 "2020-08-11T12:45:56Z")

</div>

Meanwhile SP2 is officially available, and upgrading catapulted my VM from kernel 4.12.14 to 5.3.18.  
And the best thing: podman now runs as a non-root user: Problem solved!
