# Problems when Registering new Clients

**URL:** https://forums.suse.com/t/problems-when-registering-new-clients/28534
**Category:** SUSE Multi Linux Manager
**Created:** [August 17, 2016, 12:00pm UTC](https://forums.suse.com/t/problems-when-registering-new-clients/28534 "2016-08-17T12:00:37Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![mal90](https://avatars.discourse-cdn.com/v4/letter/m/dec6dc/32.png) [@mal90](https://forums.suse.com/u/mal90)
#### Post date: [August 17, 2016, 12:00pm UTC](https://forums.suse.com/t/problems-when-registering-new-clients/28534/1 "2016-08-17T12:00:37Z")

</div>

Hi,

since a few weeks i am having troubles registering new clients to SUSE Manager 2.1. I had no problems for 400+ Servers but now i can`t register any new maschines. I can easily recreate it with any maschine that is already registered to the SUSE Manager.

When i install a new maschine via Autoyast and try to run the Bootstrapscript afterwards i get this error:

## REGISTRATION

- registering  
Traceback (most recent call last):  
File “/usr/sbin/rhnreg\_ks”, line 33, in   
from up2date\_client import rhnreg  
File “/usr/share/rhn/up2date\_client/rhnreg.py”, line 21, in   
import hardware  
File “/usr/share/rhn/up2date\_client/hardware.py”, line 52, in   
from hardware\_hal import check\_hal\_dbus\_status, get\_hal\_computer, read\_hal  
ImportError: No module named hardware\_hal

I tried to recreate it with an updated maschine that is already registered to SUSE Manager. These are my findings on it:

1. When I delete the System from SUSE Manager and rerun the Bootstrap Script on the target Maschine it is registered without any problem.

2. When I delete the System from SUSE Manager and follow this “Unregister Maschines Guide” [https://www.novell.com/support/kb/doc.php?id=7013242](https://www.novell.com/support/kb/doc.php?id=7013242) and try to rerun the Bootstrap Script it fails with the same Error above.

3. Newly installed Maschines installed via Autoyast with Repositories that are Updated every week also fail to register with the same Error.

Could somebody point out what i am missing?

Thanks alot in advance

Malcolm

---

<div class="post-metadata">

### Author: ![kwk](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/kwk/32/11997_2.png) [@kwk](https://forums.suse.com/u/kwk)
#### Post date: [August 18, 2016, 9:36am UTC](https://forums.suse.com/t/problems-when-registering-new-clients/28534/2 "2016-08-18T09:36:40Z")

</div>

Please make sure that the SUSE Manager Server is up to date with latest patches. Then re-create the ‘bootstrap’ repositories with ‘mgr-create-bootstrap-repo’ and try again.

---

<div class="post-metadata">

### Author: ![mal90](https://avatars.discourse-cdn.com/v4/letter/m/dec6dc/32.png) [@mal90](https://forums.suse.com/u/mal90)
#### Post date: [August 18, 2016, 10:04am UTC](https://forums.suse.com/t/problems-when-registering-new-clients/28534/3 "2016-08-18T10:04:05Z")

</div>

[QUOTE=kwk;33964]Please make sure that the SUSE Manager Server is up to date with latest patches. Then re-create the ‘bootstrap’ repositories with ‘mgr-create-bootstrap-repo’ and try again.[/QUOTE]

I already checked the SUSE Manager for updates, but there were none. Thanks for pointing out the ‘mgr-create-bootstrap-repo’, i recreated the ‘bootstrap’ repos.

After running ‘zypper rm -u spacewalksd spacewalk-check zypp-plugin-spacewalk spacewalk-client-tools’ again i tried to run the bootstrap script again:

…  
Retrieving repository ‘susemanager-client-setup’ metadata …[done]  
Building repository ‘susemanager-client-setup’ cache …[done]  
Specified repositories have been refreshed.  
Loading repository data…  
Reading installed packages…  
Resolving package dependencies…

The following 8 NEW packages are going to be installed:  
python-gobject2 python-gudev python-hwdata spacewalk-check  
spacewalk-client-setup spacewalk-client-tools spacewalksd  
zypp-plugin-spacewalk

The following package is going to be upgraded:  
rhnlib

The following 9 packages are not supported by their vendor:  
python-gobject2 python-gudev python-hwdata rhnlib spacewalk-check  
spacewalk-client-setup spacewalk-client-tools spacewalksd  
zypp-plugin-spacewalk

…  
It installs the packages but then fails again with:

## REGISTRATION

- registering  
Traceback (most recent call last):  
File “/usr/sbin/rhnreg\_ks”, line 37, in   
from up2date\_client import rhnreg  
File “/usr/share/rhn/up2date\_client/rhnreg.py”, line 20, in   
from up2date\_client import hardware  
File “/usr/share/rhn/up2date\_client/hardware.py”, line 63, in   
from up2date\_client.hardware\_hal import check\_hal\_dbus\_status, get\_hal\_computer, read\_hal  
ImportError: No module named hardware\_hal

\*\*\* Error: Registering the system failed.

Maybe I should point out that any attempt to run ‘rhnreg\_ks’ from commandline also fails with the traceback above.

---

<div class="post-metadata">

### Author: ![mal90](https://avatars.discourse-cdn.com/v4/letter/m/dec6dc/32.png) [@mal90](https://forums.suse.com/u/mal90)
#### Post date: [September 6, 2016, 1:03pm UTC](https://forums.suse.com/t/problems-when-registering-new-clients/28534/4 "2016-09-06T13:03:08Z")

</div>

Hi,

the Problem was solved!

I found out that the Netbackup RPMs we added to SUSE Manager were causing these Problems.

Package-List:

Package 

Summary

Content Provider

SYMCnbclt-7.6.0.1-1.x86\_64 NetBackup Client  
SYMCnbjava-7.6.0.1-1.x86\_64 NetBackup Java Console  
SYMCnbjre-7.6.0.1-1.x86\_64 NetBackup Java JRE  
SYMCpddea-8.0.1.0-0.x86\_64 Symantec Deduplication Agent  
VRTSpbx-1.5.4.0-0.x86\_64 Symantec Private Branch Exchange

It seems they provided some required Libaries which were somehow incompatible to the Packages required for the SuSe Manager registration process. After removing these packages everything went fine.

Greetings

Malcolm

---

<div class="post-metadata">

### Author: ![hwirths\_nde](https://avatars.discourse-cdn.com/v4/letter/h/cc9497/32.png) [@hwirths\_nde](https://forums.suse.com/u/hwirths_nde)
#### Post date: [March 28, 2017, 6:34pm UTC](https://forums.suse.com/t/problems-when-registering-new-clients/28534/5 "2017-03-28T18:34:20Z")

</div>

I discovered the same error today trying to register a SLES12 SP1 client with an up to date bootstrap repository to a SUSE Manager 3 instance.

In my case I found the following:

- Indeed, there is no file ‘/usr/share/rhn/up2date\_client/hardware\_hal.py’ on the client machine.
- Instead there is a file ‘/usr/share/rhn/up2date\_client/hardware\_gudev.py’, which is the preferred source of import in the ‘/usr/share/rhn/up2date\_client/hardware.py’ script. Only if the import from this module fails, functions from the ‘hardware\_hal’ module are tried to import.
- The imports from the ‘hardware\_gudev’ module failed, because a needed shared object file, /usr/lib64/libgobject-2.0.so.0 in my case, was missing.

After installing the corresponding package ‘libgobject-2\_0-0’ everything went as expected.

A look into the zypper history showed:

- The package ‘libgobject-2\_0-0’ has been removed by a previous deinstallation I made.
- Running the bootstrap script installed at least the ‘python-gobject2’ package, but not the ‘libgobject-2\_0-0’.

---

<div class="post-metadata">

### Author: ![Attila](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@Attila](https://forums.suse.com/u/Attila)
#### Post date: [April 6, 2017, 12:24pm UTC](https://forums.suse.com/t/problems-when-registering-new-clients/28534/6 "2017-04-06T12:24:51Z")

</div>

Hello,

I installed the latest packages to the SM3 server, but after the new client registration hasn’t worked.

Problem caused: apache2-2.4.16-19.1

Solution: You can downgrade the apache2 from 2.4.16-19.1 to 2.4.16-12.1.

Command to downgrade: zypper in --oldpackage apache2=2.4.16-12.1 apache2-prefork=2.4.16-12.1 apache2-utils=2.4.16-12.1
