# Rancher 2.0 vxlan issue

**URL:** <https://forums.suse.com/t/rancher-2-0-vxlan-issue/7588>\
**Category:** Rancher 1.x\
**Created:** [October 16, 2017, 2:40pm UTC](https://forums.suse.com/t/rancher-2-0-vxlan-issue/7588 "2017-10-16T14:40:17Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![accroc](https://avatars.discourse-cdn.com/v4/letter/a/d9b06d/32.png) [@accroc](https://forums.suse.com/u/accroc)\
**Post date:** [October 16, 2017, 2:40pm UTC](https://forums.suse.com/t/rancher-2-0-vxlan-issue/7588/1 "2017-10-16T14:40:17Z")

</div>

Rancher 2.0 works fine with ipsec but not with vxlan:

The r-core-services-vxlan-router does not start:

```
Oct 16 16:02:05 worker-node-01 dockerd[894]: time="2017-10-16T16:02:05.965035618+02:00" level=error msg="containerd: start container" error="oci runtime error: sysctl \"io.rancher.container.orchestration\" is not in a separate kernel namespace\n" id=896d212dd9673e65972577ee79e10f3c80c2b795d95918639a40fcaf63571b13
    Oct 16 16:02:05 worker-node-01 dockerd[894]: time="2017-10-16T16:02:05.969648164+02:00" level=error msg="Create container failed with error: invalid header field value \"oci runtime error: sysctl \\\"io.rancher.container.orchestration\\\" is not in a separate kernel namespace\\n\""
    Oct 16 16:02:06 worker-node-01 dockerd[894]: time="2017-10-16T16:02:06.016641519+02:00" level=error msg="Handler for POST /v1.24/containers/896d212dd9673e65972577ee79e10f3c80c2b795d95918639a40fcaf63571b13/start returned error: invalid header field value \"oci runtime error: sysctl \\\"io.rancher.container.orchestration\\\" is not in a separate kernel namespace\\n\""
    Oct 16 16:02:06 worker-node-01 dockerd[894]: time="2017-10-16T16:02:06.020529115+02:00" level=error msg="Handler for POST /v1.24/containers/896d212dd9673e65972577ee79e10f3c80c2b795d95918639a40fcaf63571b13/kill returned error: Cannot kill container 896d212dd9673e65972577ee79e10f3c80c2b795d95918639a40fcaf63571b13: Container 896d212dd9673e65972577ee79e10f3c80c2b795d95918639a40fcaf63571b13 is not running"   

```

Does someone have an idea or documentation to configure it ?

---

<div class="post-metadata">

**Author:** ![accroc](https://avatars.discourse-cdn.com/v4/letter/a/d9b06d/32.png) [@accroc](https://forums.suse.com/u/accroc)\
**Post date:** [October 18, 2017, 1:50pm UTC](https://forums.suse.com/t/rancher-2-0-vxlan-issue/7588/2 "2017-10-18T13:50:02Z")

</div>

Found a solution.

- Edit your vxlan service
- Upgrade the router (sidekick)
- show advanced options =\> Labels
- Delete “io.rancher.container.orchestration = cattle”

Regards

---

<div class="post-metadata">

**Author:** ![leodotcloud](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/leodotcloud/32/3103_2.png) [@leodotcloud](https://forums.suse.com/u/leodotcloud)\
**Post date:** [November 6, 2017, 5:46pm UTC](https://forums.suse.com/t/rancher-2-0-vxlan-issue/7588/3 "2017-11-06T17:46:56Z")

</div>

@accroc Can you please file a github issue with more details?  
rancher/server version?  
Docker version?

sysctl settings and labels are two different aspects, not sure why are there related here.

@niusmallnan can you please take a look at this?

---

<div class="post-metadata">

**Author:** ![leodotcloud](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/leodotcloud/32/3103_2.png) [@leodotcloud](https://forums.suse.com/u/leodotcloud)\
**Post date:** [November 6, 2017, 5:53pm UTC](https://forums.suse.com/t/rancher-2-0-vxlan-issue/7588/4 "2017-11-06T17:53:45Z")

</div>

Please file a github issue, closing this thread.

---

<div class="post-metadata">

**Author:** ![leodotcloud](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/leodotcloud/32/3103_2.png) [@leodotcloud](https://forums.suse.com/u/leodotcloud)\
**Post date:** [November 6, 2017, 5:53pm UTC](https://forums.suse.com/t/rancher-2-0-vxlan-issue/7588/5 "2017-11-06T17:53:47Z")

</div>


