# Rancher HA cluster

**URL:** https://forums.suse.com/t/rancher-ha-cluster/14705
**Category:** SUSE Rancher Prime
**Created:** [July 2, 2019, 8:06pm UTC](https://forums.suse.com/t/rancher-ha-cluster/14705 "2019-07-02T20:06:00Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![pkeshab](https://avatars.discourse-cdn.com/v4/letter/p/94ad74/32.png) [@pkeshab](https://forums.suse.com/u/pkeshab)
#### Post date: [July 2, 2019, 8:06pm UTC](https://forums.suse.com/t/rancher-ha-cluster/14705/1 "2019-07-02T20:06:00Z")

</div>

I am trying to set Rancher HA cluster with nginx load balancer in front of three nodes following the official documentation [https://rancher.com/docs/rancher/v2.x/en/installation/ha/kubernetes-rke](https://rancher.com/docs/rancher/v2.x/en/installation/ha/kubernetes-rke)

Everything works fine till I run rancher helm charts. Everytime I get the following issue.

_2019/07/02 19:43:53 [ERROR] Failed to connect to peer wss://10.42.2.5/v3/connect [local ID=10.42.0.6]: dial tcp 10.42.2.5:443: connect: connection timed out_  
Can anyone guide me in this issue?
