# Rancher on Openstack, Error creating machine: Error detecting OS: OS type not recognized

**URL:** <https://forums.suse.com/t/rancher-on-openstack-error-creating-machine-error-detecting-os-os-type-not-recognized/18852>\
**Category:** General\
**Created:** [November 19, 2020, 7:54am UTC](https://forums.suse.com/t/rancher-on-openstack-error-creating-machine-error-detecting-os-os-type-not-recognized/18852 "2020-11-19T07:54:25Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![mca](https://avatars.discourse-cdn.com/v4/letter/m/3da27b/32.png) [@mca](https://forums.suse.com/u/mca)\
**Post date:** [November 19, 2020, 7:54am UTC](https://forums.suse.com/t/rancher-on-openstack-error-creating-machine-error-detecting-os-os-type-not-recognized/18852/1 "2020-11-19T07:54:25Z")

</div>

Hello,

I’m trying to set rancher with Openstack node driver.  
When rancher is trying to set k8s nodes, I get this error:

Error creating machine: Error detecting OS: OS type not recognized

my nodes are rhel 7.7 (/etc/os-release):

NAME=“Red Hat Enterprise Linux Server”  
VERSION=“7.7 (Maipo)”  
ID=“rhel”  
ID\_LIKE=“fedora”  
VARIANT=“Server”  
VARIANT\_ID=“server”  
VERSION\_ID=“7.7”  
PRETTY\_NAME=“Red Hat Enterprise Linux”  
ANSI\_COLOR=“0;31”

I am using rancher 2.5.2 in standalone mode (rancher docker image)  
Openstack 13

Thanks

---

<div class="post-metadata">

**Author:** ![mca](https://avatars.discourse-cdn.com/v4/letter/m/3da27b/32.png) [@mca](https://forums.suse.com/u/mca)\
**Post date:** [November 25, 2020, 9:45am UTC](https://forums.suse.com/t/rancher-on-openstack-error-creating-machine-error-detecting-os-os-type-not-recognized/18852/2 "2020-11-25T09:45:05Z")

</div>

Problem resolved by building a custom install without using node driver
