# Rancher Setup issues

**URL:** <https://forums.suse.com/t/rancher-setup-issues/39920>\
**Category:** Rancher Setup Public Cloud\
**Created:** [January 29, 2023, 4:01pm UTC](https://forums.suse.com/t/rancher-setup-issues/39920 "2023-01-29T16:01:46Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Elad\_Soffer](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/elad_soffer/32/9805_2.png) [@Elad\_Soffer](https://forums.suse.com/u/Elad_Soffer)\
**Post date:** [January 29, 2023, 4:01pm UTC](https://forums.suse.com/t/rancher-setup-issues/39920/1 "2023-01-29T16:01:46Z")

</div>

Hi,

After being pointed toward this installation option, I’ve ran into some problems.

The ec2 instance was brought up ok.  
I’ve assigned an IAM role to the instance with permissions as detailed [here](https://raw.githubusercontent.com/SUSE-Enceladus/suse-rancher-setup/main/aws-iam/iam_role.json)  
And, logged into it using the instance-id and account number successfully.  
Hitting the next button on the next screen trys to get the /aws/permissions page and fails.  
I’m not sure if this points to the root cause. Digging through the instance, I’ve reached a log file (`/var/lib/suse-rancher-setup/log/production.log`) which logs this error every time I try to reload the /aws/permissions page.

```auto
I, [2023-01-29T13:34:15.559651 #505] INFO -- : Executing "ec2metadata --api 2021-07-15 --info".
E, [2023-01-29T13:34:15.743054 #505] ERROR -- : Error output: Error: option --info not recognized    
I, [2023-01-29T13:34:15.743461 #505] INFO -- : Standard output: Syntax: /usr/bin/ec2metadata [--options]
I, [2023-01-29T13:34:15.743501 #505] INFO -- : Standard output: Query and display EC2 metadata related to the AMI instance
I, [2023-01-29T13:34:15.743535 #505] INFO -- : Standard output:                                                                             
I, [2023-01-29T13:34:15.743567 #505] INFO -- : Standard output: If no options are specified, all will be displayed.
I, [2023-01-29T13:34:15.743592 #505] INFO -- : Standard output: Options:                               
----- more irrelevant Standard output dump -------
E, [2023-01-29T13:34:15.754865 #505] ERROR -- : Status: 1

```

Have I missed something in the process?

Thanks,  
Elad

---

<div class="post-metadata">

**Author:** ![Dusan\_Dragula](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/dusan_dragula/32/9806_2.png) [@Dusan\_Dragula](https://forums.suse.com/u/Dusan_Dragula)\
**Post date:** [January 30, 2023, 12:33am UTC](https://forums.suse.com/t/rancher-setup-issues/39920/2 "2023-01-30T00:33:26Z")

</div>

Hi, I have same issue, not able to continue with setup.

---

<div class="post-metadata">

**Author:** ![bear454](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/bear454/32/9125_2.png) [@bear454](https://forums.suse.com/u/bear454)\
**Post date:** [January 30, 2023, 5:51pm UTC](https://forums.suse.com/t/rancher-setup-issues/39920/3 "2023-01-30T17:51:50Z")

</div>

Thanks for posting. We’ve identified the issue, and are working expediting an update to both resolve this and roll out some great new features.

In the meantime SUSE Rancher Setup v20230114 is being restricted in the AWS Marketplace. Please try again with the prior version v20221013, which does not have this issue.

---

<div class="post-metadata">

**Author:** ![Elad\_Soffer](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/elad_soffer/32/9805_2.png) [@Elad\_Soffer](https://forums.suse.com/u/Elad_Soffer)\
**Post date:** [January 30, 2023, 7:27pm UTC](https://forums.suse.com/t/rancher-setup-issues/39920/4 "2023-01-30T19:27:59Z")

</div>

Thanks for updating.  
I’ll test it tomorrow.

---

<div class="post-metadata">

**Author:** ![Elad\_Soffer](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/elad_soffer/32/9805_2.png) [@Elad\_Soffer](https://forums.suse.com/u/Elad_Soffer)\
**Post date:** [January 31, 2023, 9:49am UTC](https://forums.suse.com/t/rancher-setup-issues/39920/5 "2023-01-31T09:49:28Z")

</div>

Thanks again,  
Using the suggested version worked.
