# Rancher Web UI Connection Refused

**URL:** <https://forums.suse.com/t/rancher-web-ui-connection-refused/41334>\
**Category:** General\
**Created:** [August 16, 2023, 1:54am UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334 "2023-08-16T01:54:43Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![gururaj0](https://avatars.discourse-cdn.com/v4/letter/g/958977/32.png) [@gururaj0](https://forums.suse.com/u/gururaj0)\
**Post date:** [August 16, 2023, 1:54am UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334/1 "2023-08-16T01:54:44Z")

</div>

Hi All,  
I m new to Rancher. Trying a POC.

Followed: Helm CLI Quick Start

Install successful on a Bastion host.  
Upon Opening the rancher url in web browser or curl

Error:  
**[xxx.xxx.60.139.sslip.io](http://xxx.xxx.60.139.sslip.io)** refused to connect

Step:  
[opc@wlsoke-bastion ~]$ helm install rancher rancher-latest/rancher \

> –namespace cattle-system   
> –set [hostname=xxxx.sslip.io](http://hostname=xxxx.sslip.io)   
> –set replicas=1   
> –set bootstrapPassword=xxxxxxxxxxx

WARNING: Kubernetes configuration file is group-readable. This is insecure. Location: /home/opc/.kube/config  
WARNING: Kubernetes configuration file is world-readable. This is insecure. Location: /home/opc/.kube/config  
NAME: rancher  
LAST DEPLOYED: Tue Aug 15 14:26:29 2023  
NAMESPACE: cattle-system  
STATUS: deployed  
REVISION: 1  
TEST SUITE: None  
NOTES:  
Rancher Server has been installed.

NOTE: Rancher may take several minutes to fully initialize. Please standby while Certificates are being issued, Containers are started and the Ingress rule comes up.

Any idea what could be wrong ?

Firewall is disabled and Ingress rules are verified for 443 and 80 for machine’s subnet.

Thank you in advance  
Gururaj

---

<div class="post-metadata">

**Author:** ![malcolmlewis1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis1/32/10022_2.png) [@malcolmlewis1](https://forums.suse.com/u/malcolmlewis1)\
**Post date:** [August 16, 2023, 3:14am UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334/2 "2023-08-16T03:14:27Z")

</div>

@gururaj0 Hi and welcome to the Forum 😄

Did you check k3s is running and all the pods were created/running etc?

---

<div class="post-metadata">

**Author:** ![gururaj0](https://avatars.discourse-cdn.com/v4/letter/g/958977/32.png) [@gururaj0](https://forums.suse.com/u/gururaj0)\
**Post date:** [August 16, 2023, 3:22am UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334/3 "2023-08-16T03:22:51Z")

</div>

@malcolmlewis1 Thank you. I didn’t install any K3s as it never worked. Not sure if this is needed ? If so, pls explain why it is needed and clear instruction please.

curl -sfL [https://get.k3s.io](https://get.k3s.io) | INSTALL\_K3S\_VERSION=1.26+k3s1 sh -s - server --cluster-init  
This didn’t do anything. I m on Red Hat Enterprise Linux Server release 7.9 (Maipo)

[opc@wlsoke-bastion ~]$ kubectl get ingress -n cattle-system  
NAME CLASS HOSTS ADDRESS PORTS AGE  
rancher [xxx.xxx.xx.xxx.sslip.io](http://xxx.xxx.xx.xxx.sslip.io) 80, 443 11h

[opc@wlsoke-bastion ~]$ kubectl get svc -n cattle-system  
NAME TYPE CLUSTER-IP EXTERNAL-IP PORT(S) AGE  
rancher ClusterIP 10.96.159.215 80/TCP,443/TCP 12h  
rancher-webhook ClusterIP 10.96.130.52 443/TCP 12h  
webhook-service ClusterIP 10.96.18.150 443/TCP 12h

[opc@wlsoke-bastion ~]$ kubectl get pods -n cattle-system  
NAME READY STATUS RESTARTS AGE  
rancher-f774856cc-lxlwc 1/1 Running 0 73m  
rancher-webhook-788c48b988-ff6f7 1/1 Running 0 12h

Regards  
Gururaj

---

<div class="post-metadata">

**Author:** ![gururaj0](https://avatars.discourse-cdn.com/v4/letter/g/958977/32.png) [@gururaj0](https://forums.suse.com/u/gururaj0)\
**Post date:** [August 16, 2023, 4:21am UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334/4 "2023-08-16T04:21:37Z")

</div>

Just to clarify, I m installing Rancher on an existing kubernetes cluster.

---

<div class="post-metadata">

**Author:** ![malcolmlewis1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis1/32/10022_2.png) [@malcolmlewis1](https://forums.suse.com/u/malcolmlewis1)\
**Post date:** [August 16, 2023, 11:28am UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334/5 "2023-08-16T11:28:21Z")

</div>

@gururaj0 Ahh ok. So is the version of k3s running supported by Rancher.

[https://www.suse.com/suse-rancher/support-matrix/all-supported-versions/rancher-v2-7-5/](https://www.suse.com/suse-rancher/support-matrix/all-supported-versions/rancher-v2-7-5/)

---

<div class="post-metadata">

**Author:** ![gururaj0](https://avatars.discourse-cdn.com/v4/letter/g/958977/32.png) [@gururaj0](https://forums.suse.com/u/gururaj0)\
**Post date:** [August 18, 2023, 2:19am UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334/6 "2023-08-18T02:19:04Z")

</div>

@malcolmlewis1 Yes k3s was the issue. The documentation wasn’t great as how to install it. Anyways now it is working. One question I was wondering how in the world without any dns entry the rancher url is working on the browser ?

Ref: Now if you navigate to \<IP\_OF\_LINUX\_NODE\>.sslip.io in a web browser, you should see the Rancher UI.

Regards  
Gururaj

---

<div class="post-metadata">

**Author:** ![malcolmlewis1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis1/32/10022_2.png) [@malcolmlewis1](https://forums.suse.com/u/malcolmlewis1)\
**Post date:** [August 18, 2023, 2:59am UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334/7 "2023-08-18T02:59:43Z")

</div>

@gururaj0 [sslip.io](http://sslip.io) will resolve to your ip, see [https://sslip.io/](https://sslip.io/)

I use local dns and hosts files here.

---

<div class="post-metadata">

**Author:** ![gururaj0](https://avatars.discourse-cdn.com/v4/letter/g/958977/32.png) [@gururaj0](https://forums.suse.com/u/gururaj0)\
**Post date:** [August 18, 2023, 2:24pm UTC](https://forums.suse.com/t/rancher-web-ui-connection-refused/41334/8 "2023-08-18T14:24:45Z")

</div>

@malcolmlewis1 Malcom, that answers ! Thank you.
