# Re: fv machine HA

**URL:** <https://forums.suse.com/t/re-fv-machine-ha/22058>\
**Category:** SLES Virtualization\
**Created:** [September 13, 2011, 11:56pm UTC](https://forums.suse.com/t/re-fv-machine-ha/22058 "2011-09-13T23:56:02Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![System1](https://avatars.discourse-cdn.com/v4/letter/s/51bf81/32.png) [@System1](https://forums.suse.com/u/System1)\
**Post date:** [September 13, 2011, 11:56pm UTC](https://forums.suse.com/t/re-fv-machine-ha/22058/1 "2011-09-13T23:56:02Z")

</div>

needee;2135850 Wrote:[color=blue]

> OS: SLES 11 SP1 with onlin updates + HAE SP1
> 
> if I cluster a FV(win 2k8) XEN machine, in case of migration(or the  
> node running the vm goes down).. may we expect a downtime(restart of vm  
> on the other node) ? or does it resume on the  
> surviving node without a downtime(or with negligible downtime)?
> 
> sorry if I am asking this question in wrong place
> 
> Regards  
> needee[/color]

Hi Needee,

You’ve posted in the right spot 🙂

The answer to you’re question depends on what you are doing/what is  
happening… You mention both HA and Live migration in the situation  
you are describing.

HA will kick in if your host fails… but the way it kicks in is by  
simply starting (cold boot as to say) the VM’s that where running on the  
Xen host that just failed.  
Unless you can predict the Xen host is going to fail, the active state  
of the VM’s will fail just as hard as the Xen host. So it’s high  
availability as there is an automated process to (re)start the VM’s as  
quickly as possible on another Xen host that is still alive.

Live Migration on the other hand, is done between active Xen hosts…  
and when setup correctly you should not notice any downtime - just a  
little hickup while the VM hops over from one Xen node to the other.  
This works by first having the Xen host that is running the VM you want  
to migrate, to copy the active state (RAM, etc) of that VM to the other  
Xen host… when that active state has been synced between the Xen hosts  
(99%), the VM is put in a frozen state on the current Xen host… last  
bits are synced over and the VM is unfrozen on the other Xen node.  
Typically you’ll only miss one en two seconds of connectivity and the  
node will be back online without it (or the connected clients) being  
aware of anything have happened.

The only solution I’ve worked with that can run a fully fault tolerant  
VM (from a host perspective) is VMware vSphere. It is resource hungry  
as you are actually running two sessions of the VM, each session on one  
of the hosts where one session is active and the other is read-only (and  
constantly syncing with the active one).  
With this solution you can pull the plug on one host, and your VM will  
stay running in an active state. Nice, but again quite resource hungry.  
There could be other solutions that do something similar… I have not  
worked with them.

Hope that helps…

Willem

–  
Novell Knowledge Partner (voluntary sysop)

## It ain’t anything like Harry Potter.. but you gotta love the magic IT can bring to this world

magic31’s Profile: [http://forums.novell.com/member.php?userid=2303](http://forums.novell.com/member.php?userid=2303)  
View this thread: [http://forums.novell.com/showthread.php?t=444453](http://forums.novell.com/showthread.php?t=444453)
