# Re: xen based Windows 2008R2 VM

**URL:** <https://forums.suse.com/t/re-xen-based-windows-2008r2-vm/22053>\
**Category:** SLES Virtualization\
**Created:** [September 13, 2011, 1:03pm UTC](https://forums.suse.com/t/re-xen-based-windows-2008r2-vm/22053 "2011-09-13T13:03:30Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![System1](https://avatars.discourse-cdn.com/v4/letter/s/51bf81/32.png) [@System1](https://forums.suse.com/u/System1)\
**Post date:** [September 13, 2011, 1:03pm UTC](https://forums.suse.com/t/re-xen-based-windows-2008r2-vm/22053/1 "2011-09-13T13:03:30Z")

</div>

On 09/09/2011 11:36 AM, magic31 wrote:[color=blue]

> KBR;2132921 Wrote:[color=green]
> 
> > Hi all,
> > 
> > After joining the ad domain and rebooting the xenbased w2k8R2 VM this  
> > server has lost its disks and can not boot. We are using sles 10 sp2/3  
> > with (Novell/SUSE Virtual machine driver pack).  
> > Also there are issues in eventviewer which we solve by editing the  
> > config.xen file and replacing “model rtl8138” with “type netfront”
> > 
> > The vm’s are placed on a cluster ocfs2 volume handled by HA2
> > 
> > Strange thing is thatw e have several windows server virtual machine  
> > running for years, it looks like this issue is started since windows  
> > 2008 R2 (in a domain).
> > 
> > Any hints ideas are very welcome!
> > 
> > Regards  
> > KB[/color]
> 
> Possibly the Windows disk has been marked offline for some reason?  
> What exactly are you seeing when trying to boot the affected VM? Is  
> Windows throwing an error, or does the VM not get passed the first boot  
> phase?
> 
> -Willem
> 
> [/color]  
> The problem is caused by a move of the vm and back again, the disk image  
> file is a sparse file which during the move was “unsparsed”. The move  
> back again resulted in a disk which did not fit anymore on the original  
> location. So the disk was corrupt.  
> Now the only issue is that when we uninstall vmdp v1.3 the windows vm is  
> broke. If we upgrade to vmdp 1.7 first we can do an uninstall. It does  
> not matter which vmdp version we use we always have atapi, disk and acpi  
> error in teh event viewer. The acpi errors can be fixed by changing  
> “model=rtlxxx into type = netfront” but the disk and atapi errors stay.  
> Novell has stated that vmdp 1.7 is the way to go and the disk and atapi  
> errors are informational only.

Regards  
Karel
