# Repo Import failed

**URL:** <https://forums.suse.com/t/repo-import-failed/25084>\
**Category:** SUSE Studio / Studio Express\
**Created:** [February 6, 2014, 2:46am UTC](https://forums.suse.com/t/repo-import-failed/25084 "2014-02-06T02:46:01Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![System1](https://avatars.discourse-cdn.com/v4/letter/s/51bf81/32.png) [@System1](https://forums.suse.com/u/System1)\
**Post date:** [February 6, 2014, 2:46am UTC](https://forums.suse.com/t/repo-import-failed/25084/1 "2014-02-06T02:46:01Z")

</div>

I am trying to import my repo I am hosting on my server.  
I can add my repository simply with: sudo zypper ar -f URL ALIAS  
or sudo zypper ar -r URL/file.repo  
on openSUSE but I cannot add it in SuseStudio.  
It says: Importing the repository ‘’ () failed:  
Where is the problem?

## – LycheeLinux

LycheeLinux’s Profile: [http://forums.opensuse.org/member.php?userid=80497](http://forums.opensuse.org/member.php?userid=80497)  
View this thread: [http://forums.opensuse.org/showthread.php?t=495199](http://forums.opensuse.org/showthread.php?t=495199)

---

<div class="post-metadata">

**Author:** ![Jim1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jim1/32/9120_2.png) [@Jim1](https://forums.suse.com/u/Jim1)\
**Post date:** [February 6, 2014, 6:17am UTC](https://forums.suse.com/t/repo-import-failed/25084/2 "2014-02-06T06:17:38Z")

</div>

On Thu, 06 Feb 2014 00:46:01 +0000, LycheeLinux wrote:  
[color=blue]

> I am trying to import my repo I am hosting on my server.  
> I can add my repository simply with: sudo zypper ar -f URL ALIAS or sudo  
> zypper ar -r URL/file.repo on openSUSE but I cannot add it in  
> SuseStudio.  
> It says: Importing the repository ‘’ () failed:  
> Where is the problem?[/color]

Where is your server located? ie, is it behind a firewall? If so, is  
port forwarding enabled to get the connection to your server?

Jim

–  
Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
Novell/SUSE/NetIQ Knowledge Partner

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [February 6, 2014, 12:06pm UTC](https://forums.suse.com/t/repo-import-failed/25084/3 "2014-02-06T12:06:02Z")

</div>

My Repo is on my public server where I am also hosting my website. I can  
browse through the repo and add it in opensuse manually. Why should I  
need portforwarding then? If this would be the problem I should not be  
able to add it manually too.

Jim Henderson;2622430 Wrote:[color=blue]

> On Thu, 06 Feb 2014 00:46:01 +0000, LycheeLinux wrote:  
> [color=green]
> 
> > I am trying to import my repo I am hosting on my server.  
> > I can add my repository simply with: sudo zypper ar -f URL ALIAS or[/color]  
> > sudo[color=green]  
> > zypper ar -r URL/file.repo on openSUSE but I cannot add it in  
> > SuseStudio.  
> > It says: Importing the repository ‘’ () failed:  
> > Where is the problem?[/color]
> 
> Where is your server located? ie, is it behind a firewall? If so, is  
> port forwarding enabled to get the connection to your server?
> 
> Jim
> 
> –  
> Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
> Novell/SUSE/NetIQ Knowledge Partner[/color]

## – LycheeLinux

LycheeLinux’s Profile: [http://forums.opensuse.org/member.php?userid=80497](http://forums.opensuse.org/member.php?userid=80497)  
View this thread: [http://forums.opensuse.org/showthread.php?t=495199](http://forums.opensuse.org/showthread.php?t=495199)

---

<div class="post-metadata">

**Author:** ![Jim1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jim1/32/9120_2.png) [@Jim1](https://forums.suse.com/u/Jim1)\
**Post date:** [February 6, 2014, 5:06pm UTC](https://forums.suse.com/t/repo-import-failed/25084/4 "2014-02-06T17:06:35Z")

</div>

On Thu, 06 Feb 2014 10:06:02 +0000, LycheeLinux wrote:  
[color=blue]

> My Repo is on my public server where I am also hosting my website. I can  
> browse through the repo and add it in opensuse manually. Why should I  
> need portforwarding then? If this would be the problem I should not be  
> able to add it manually too.[/color]

There are a number of ways to set up a repo server, and if you’re behind  
a firewall, that would explain why it’s not importing properly, so I  
wanted to eliminate that.

Since that’s not the issue, we’ll need more information about how the repo  
is set up and its connectivity in order to provide further assistance. 🙂

## Jim

Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
Novell/SUSE/NetIQ Knowledge Partner

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [February 6, 2014, 6:36pm UTC](https://forums.suse.com/t/repo-import-failed/25084/5 "2014-02-06T18:36:01Z")

</div>

The Url is [repo.lycheelinux.com](http://repo.lycheelinux.com).  
I created it locally on my computer and uploaded it with rsync to the  
server.

Jim Henderson;2622515 Wrote:[color=blue]

> On Thu, 06 Feb 2014 10:06:02 +0000, LycheeLinux wrote:  
> [color=green]
> 
> > My Repo is on my public server where I am also hosting my website. I[/color]  
> > can[color=green]  
> > browse through the repo and add it in opensuse manually. Why should I  
> > need portforwarding then? If this would be the problem I should not be  
> > able to add it manually too.[/color]
> 
> There are a number of ways to set up a repo server, and if you’re behind  
> a firewall, that would explain why it’s not importing properly, so I  
> wanted to eliminate that.
> 
> Since that’s not the issue, we’ll need more information about how the  
> repo  
> is set up and its connectivity in order to provide further assistance.  
> 🙂
> 
> ## Jim
> 
> Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
> Novell/SUSE/NetIQ Knowledge Partner[/color]

## – LycheeLinux

LycheeLinux’s Profile: [http://forums.opensuse.org/member.php?userid=80497](http://forums.opensuse.org/member.php?userid=80497)  
View this thread: [http://forums.opensuse.org/showthread.php?t=495199](http://forums.opensuse.org/showthread.php?t=495199)

---

<div class="post-metadata">

**Author:** ![Jim1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jim1/32/9120_2.png) [@Jim1](https://forums.suse.com/u/Jim1)\
**Post date:** [February 6, 2014, 10:41pm UTC](https://forums.suse.com/t/repo-import-failed/25084/6 "2014-02-06T22:41:08Z")

</div>

On Thu, 06 Feb 2014 16:36:01 +0000, LycheeLinux wrote:  
[color=blue]

> The Url is [repo.lycheelinux.com](http://repo.lycheelinux.com).  
> I created it locally on my computer and uploaded it with rsync to the  
> server.[/color]

In looking at the import, it looks like you need to supply the path to  
the root of the repo rather than the path to the .repo file.

I tried that and it seems to start, but then it throws an error as well -  
but it looks like something they’ll need to look at on the backend. If  
you click the “Forum” link at the bottom of [susestudio.com](http://susestudio.com) (when logged  
in), that’ll get your question to the right people.

Jim

–  
Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
Novell/SUSE/NetIQ Knowledge Partner

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [February 7, 2014, 1:06am UTC](https://forums.suse.com/t/repo-import-failed/25084/7 "2014-02-07T01:06:01Z")

</div>

So what would you change exactly?

I already posted it there but I dont get any response.  
Jim Henderson;2622596 Wrote:[color=blue]

> On Thu, 06 Feb 2014 16:36:01 +0000, LycheeLinux wrote:  
> [color=green]
> 
> > The Url is [repo.lycheelinux.com](http://repo.lycheelinux.com).  
> > I created it locally on my computer and uploaded it with rsync to the  
> > server.[/color]
> 
> In looking at the import, it looks like you need to supply the path to  
> the root of the repo rather than the path to the .repo file.
> 
> ## I tried that and it seems to start, but then it throws an error as well
> 
> but it looks like something they’ll need to look at on the backend. If  
> you click the “Forum” link at the bottom of [susestudio.com](http://susestudio.com) (when logged  
> in), that’ll get your question to the right people.
> 
> Jim
> 
> –  
> Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
> Novell/SUSE/NetIQ Knowledge Partner[/color]

## – LycheeLinux

LycheeLinux’s Profile: [http://forums.opensuse.org/member.php?userid=80497](http://forums.opensuse.org/member.php?userid=80497)  
View this thread: [http://forums.opensuse.org/showthread.php?t=495199](http://forums.opensuse.org/showthread.php?t=495199)

---

<div class="post-metadata">

**Author:** ![Jim1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jim1/32/9120_2.png) [@Jim1](https://forums.suse.com/u/Jim1)\
**Post date:** [February 7, 2014, 4:06am UTC](https://forums.suse.com/t/repo-import-failed/25084/8 "2014-02-07T04:06:47Z")

</div>

On Thu, 06 Feb 2014 23:06:01 +0000, LycheeLinux wrote:  
[color=blue]

> So what would you change exactly?[/color]

The URL. [http://repo.lycheelinux.com](http://repo.lycheelinux.com) is what you should use, leave off  
the /[file].repo part of it, as it’s not needed.  
[color=blue]

> I already posted it there but I dont get any response.[/color]

Let me see if I can poke someone, as the URL that you should use doesn’t  
seem to be working either.

Jim

–  
Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
Novell/SUSE/NetIQ Knowledge Partner

---

<div class="post-metadata">

**Author:** ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)\
**Post date:** [February 7, 2014, 5:13am UTC](https://forums.suse.com/t/repo-import-failed/25084/9 "2014-02-07T05:13:51Z")

</div>

> [@](#):
>
> On Thu 06 Feb 2014 11:06:01 PM CST, LycheeLinux wrote:
> 
> So what would you change exactly?
> 
> I already posted it there but I dont get any response.  
> Jim Henderson;2622596 Wrote:[color=blue]
> 
> > On Thu, 06 Feb 2014 16:36:01 +0000, LycheeLinux wrote:  
> > [color=green]
> > 
> > > The Url is [repo.lycheelinux.com](http://repo.lycheelinux.com).  
> > > I created it locally on my computer and uploaded it with rsync to  
> > > the server.[/color]
> > 
> > In looking at the import, it looks like you need to supply the path to  
> > the root of the repo rather than the path to the .repo file.
> > 
> > I tried that and it seems to start, but then it throws an error as  
> > well -  
> > but it looks like something they’ll need to look at on the backend.  
> > If you click the “Forum” link at the bottom of [susestudio.com](http://susestudio.com) (when  
> > logged in), that’ll get your question to the right people.
> > 
> > Jim
> > 
> > –  
> > Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
> > Novell/SUSE/NetIQ Knowledge Partner[/color]

Hi  
Why host something that can already be added direct from OBS into SUSE  
Studio? For random rpm’s, just upload them?

Owncloud use OBS directly to create all there rpms etc for distribution.

–  
Cheers Malcolm Â°Â¿Â° SUSE Knowledge Partner (Linux Counter #276890)  
openSUSE 13.1 (Bottle) (x86\_64) GNOME 3.10.2 Kernel 3.11.6-4-desktop  
If you find this post helpful and are logged into the web interface,  
please show your appreciation and click on the star below… Thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [February 7, 2014, 2:56pm UTC](https://forums.suse.com/t/repo-import-failed/25084/10 "2014-02-07T14:56:02Z")

</div>

I already tried it without the .repo file.  
Thanks.

I just uploaded some test packages. It is much nicer for me to have my  
own repository.

## – LycheeLinux

LycheeLinux’s Profile: [http://forums.opensuse.org/member.php?userid=80497](http://forums.opensuse.org/member.php?userid=80497)  
View this thread: [http://forums.opensuse.org/showthread.php?t=495199](http://forums.opensuse.org/showthread.php?t=495199)

---

<div class="post-metadata">

**Author:** ![Jim1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jim1/32/9120_2.png) [@Jim1](https://forums.suse.com/u/Jim1)\
**Post date:** [February 7, 2014, 8:08pm UTC](https://forums.suse.com/t/repo-import-failed/25084/11 "2014-02-07T20:08:37Z")

</div>

On Fri, 07 Feb 2014 12:56:02 +0000, LycheeLinux wrote:  
[color=blue]

> I already tried it without the .repo file.[/color]

You hadn’t mentioned that - not sure how we were supposed to know that  
without you telling us that.

Is there any other information - things you’ve tried, etc - that you  
might be assuming we know?

## Jim

Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
Novell/SUSE/NetIQ Knowledge Partner

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [February 8, 2014, 6:56pm UTC](https://forums.suse.com/t/repo-import-failed/25084/12 "2014-02-08T18:56:02Z")

</div>

Sorry I tried also signed and unsigned. Nothing more I think.  
I works with yum and zypper in opensuse but not in SUSEStudio.

Jim Henderson;2622886 Wrote:[color=blue]

> On Fri, 07 Feb 2014 12:56:02 +0000, LycheeLinux wrote:  
> [color=green]
> 
> > I already tried it without the .repo file.[/color]
> 
> You hadn’t mentioned that - not sure how we were supposed to know that  
> without you telling us that.
> 
> Is there any other information - things you’ve tried, etc - that you  
> might be assuming we know?
> 
> ## Jim
> 
> Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
> Novell/SUSE/NetIQ Knowledge Partner[/color]

## – LycheeLinux

LycheeLinux’s Profile: [http://forums.opensuse.org/member.php?userid=80497](http://forums.opensuse.org/member.php?userid=80497)  
View this thread: [http://forums.opensuse.org/showthread.php?t=495199](http://forums.opensuse.org/showthread.php?t=495199)

---

<div class="post-metadata">

**Author:** ![Jim1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jim1/32/9120_2.png) [@Jim1](https://forums.suse.com/u/Jim1)\
**Post date:** [February 8, 2014, 10:13pm UTC](https://forums.suse.com/t/repo-import-failed/25084/13 "2014-02-08T22:13:55Z")

</div>

On Sat, 08 Feb 2014 16:56:02 +0000, LycheeLinux wrote:  
[color=blue]

> Sorry I tried also signed and unsigned. Nothing more I think. I works  
> with yum and zypper in opensuse but not in SUSEStudio.[/color]

I’ve asked that someone poke the person who’s supposed to be monitoring  
the mailing list/forum for Studio, so hopefully you’ll get an answer over  
there shortly. To diagnose this requires (I think) someone on the backend  
to look and see what error’s being generated there.

## Jim

Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
Novell/SUSE/NetIQ Knowledge Partner

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [February 8, 2014, 10:56pm UTC](https://forums.suse.com/t/repo-import-failed/25084/14 "2014-02-08T22:56:02Z")

</div>

Thanks 😉 Yeah the error which is displayed is not really helping me 😃

Jim Henderson;2623244 Wrote:[color=blue]

> On Sat, 08 Feb 2014 16:56:02 +0000, LycheeLinux wrote:  
> [color=green]
> 
> > Sorry I tried also signed and unsigned. Nothing more I think. I works  
> > with yum and zypper in opensuse but not in SUSEStudio.[/color]
> 
> I’ve asked that someone poke the person who’s supposed to be monitoring  
> the mailing list/forum for Studio, so hopefully you’ll get an answer  
> over  
> there shortly. To diagnose this requires (I think) someone on the  
> backend  
> to look and see what error’s being generated there.
> 
> ## Jim
> 
> Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
> Novell/SUSE/NetIQ Knowledge Partner[/color]

## – LycheeLinux

LycheeLinux’s Profile: [http://forums.opensuse.org/member.php?userid=80497](http://forums.opensuse.org/member.php?userid=80497)  
View this thread: [http://forums.opensuse.org/showthread.php?t=495199](http://forums.opensuse.org/showthread.php?t=495199)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/suse/original/2X/5/5012ba89e3ffb5220dac47d5ea0ba032e2fe1cb6.png) [@system](https://forums.suse.com/u/system)\
**Post date:** [February 17, 2014, 12:36am UTC](https://forums.suse.com/t/repo-import-failed/25084/15 "2014-02-17T00:36:02Z")

</div>

I have not been contacted in any way yet?  
LycheeLinux;2623255 Wrote:[color=blue]

> Thanks 😉 Yeah the error which is displayed is not really helping me :D[/color]

## – LycheeLinux

LycheeLinux’s Profile: [http://forums.opensuse.org/member.php?userid=80497](http://forums.opensuse.org/member.php?userid=80497)  
View this thread: [http://forums.opensuse.org/showthread.php?t=495199](http://forums.opensuse.org/showthread.php?t=495199)

---

<div class="post-metadata">

**Author:** ![Jim1](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/jim1/32/9120_2.png) [@Jim1](https://forums.suse.com/u/Jim1)\
**Post date:** [February 21, 2014, 12:38am UTC](https://forums.suse.com/t/repo-import-failed/25084/16 "2014-02-21T00:38:26Z")

</div>

On Sun, 16 Feb 2014 22:36:02 +0000, LycheeLinux wrote:  
[color=blue]

> I have not been contacted in any way yet?  
> LycheeLinux;2623255 Wrote:[color=green]
> 
> > Thanks 😉 Yeah the error which is displayed is not really helping me :D[/color][/color]

Try posting to that list again (the “forum” link on the SUSE Studio  
site). Might be that they couldn’t find the post easily.

Jim

–  
Jim Henderson, CNA6, CDE, CNI, LPIC-1, CLA10, CLP10  
Novell/SUSE/NetIQ Knowledge Partner
